Subject: [PATCH v2 1/2] community/gst-plugins-bad: enable SCTP stack

From: Daniel Santana <[email-masked]>
Date: Mon, 3 Feb 2020 00:41:05 -0300

This is required by the webrtcbin element to use data channels.
---
 community/gst-plugins-bad/APKBUILD | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index b1576aa63a..509ff4246d 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=gst-plugins-bad
 pkgver=1.16.2
-pkgrel=3
+pkgrel=4
 pkgdesc="GStreamer streaming media framework bad plug-ins"
 url="https://gstreamer.freedesktop.org"
 arch="all"
@@ -14,7 +14,7 @@ makedepends="alsa-lib-dev bluez-dev bzip2-dev curl-dev directfb-dev faac-dev
 	libmodplug-dev libsrtp-dev libvdpau-dev libwebp-dev libnice-dev
 	libx11-dev mesa-dev meson neon-dev openssl-dev opus-dev orc-compiler
 	orc-dev spandsp-dev tiff-dev x265-dev vulkan-loader-dev vulkan-headers
-	wayland-dev wayland-protocols gobject-introspection-dev"
+	wayland-dev wayland-protocols gobject-introspection-dev libusrsctp-dev"
 
 case "$CARCH" in
 	s390x) ;;
@@ -36,6 +36,7 @@ build() {
 		-Dpackage-name="GStreamer bad plug-ins (Alpine Linux)" \
 		-Dintrospection=enabled \
 		-Dvulkan=enabled \
+		-Dsctp=enabled \
 		. output
 	ninja -C output
 }
-- 
2.25.0

---

From: Daniel Santana <[email-masked]>
Date: Mon, 3 Feb 2020 00:41:06 -0300

---
 {testing => community}/e2tools/APKBUILD  | 0
 {testing => community}/e2tools/e2cp.1    | 0
 {testing => community}/e2tools/e2ln.1    | 0
 {testing => community}/e2tools/e2ls.1    | 0
 {testing => community}/e2tools/e2mkdir.1 | 0
 {testing => community}/e2tools/e2mv.1    | 0
 {testing => community}/e2tools/e2rm.1    | 0
 {testing => community}/e2tools/e2tail.1  | 0
 {testing => community}/e2tools/e2tools.7 | 0
 9 files changed, 0 insertions(+), 0 deletions(-)
 rename {testing => community}/e2tools/APKBUILD (100%)
 rename {testing => community}/e2tools/e2cp.1 (100%)
 rename {testing => community}/e2tools/e2ln.1 (100%)
 rename {testing => community}/e2tools/e2ls.1 (100%)
 rename {testing => community}/e2tools/e2mkdir.1 (100%)
 rename {testing => community}/e2tools/e2mv.1 (100%)
 rename {testing => community}/e2tools/e2rm.1 (100%)
 rename {testing => community}/e2tools/e2tail.1 (100%)
 rename {testing => community}/e2tools/e2tools.7 (100%)

diff --git a/testing/e2tools/APKBUILD b/community/e2tools/APKBUILD
similarity index 100%
rename from testing/e2tools/APKBUILD
rename to community/e2tools/APKBUILD
diff --git a/testing/e2tools/e2cp.1 b/community/e2tools/e2cp.1
similarity index 100%
rename from testing/e2tools/e2cp.1
rename to community/e2tools/e2cp.1
diff --git a/testing/e2tools/e2ln.1 b/community/e2tools/e2ln.1
similarity index 100%
rename from testing/e2tools/e2ln.1
rename to community/e2tools/e2ln.1
diff --git a/testing/e2tools/e2ls.1 b/community/e2tools/e2ls.1
similarity index 100%
rename from testing/e2tools/e2ls.1
rename to community/e2tools/e2ls.1
diff --git a/testing/e2tools/e2mkdir.1 b/community/e2tools/e2mkdir.1
similarity index 100%
rename from testing/e2tools/e2mkdir.1
rename to community/e2tools/e2mkdir.1
diff --git a/testing/e2tools/e2mv.1 b/community/e2tools/e2mv.1
similarity index 100%
rename from testing/e2tools/e2mv.1
rename to community/e2tools/e2mv.1
diff --git a/testing/e2tools/e2rm.1 b/community/e2tools/e2rm.1
similarity index 100%
rename from testing/e2tools/e2rm.1
rename to community/e2tools/e2rm.1
diff --git a/testing/e2tools/e2tail.1 b/community/e2tools/e2tail.1
similarity index 100%
rename from testing/e2tools/e2tail.1
rename to community/e2tools/e2tail.1
diff --git a/testing/e2tools/e2tools.7 b/community/e2tools/e2tools.7
similarity index 100%
rename from testing/e2tools/e2tools.7
rename to community/e2tools/e2tools.7
-- 
2.25.0

---

From: Natanael Copa <[email-masked]>
Date: Mon, 3 Feb 2020 12:02:00 +0100

Hi!

On Mon,  3 Feb 2020 00:41:06 -0300

>  rename {testing => community}/e2tools/e2tools.7 (100%)

I think it would be better if we could use upstream patch[1] with the
man pages instead of have a copy of them in our aports tree.

[1]: https://github.com/e2tools/e2tools/commit/475d6f970a0067181841bdb6fbd8f166703bd154

-nc

---

From: Natanael Copa <[email-masked]>
Date: Mon, 3 Feb 2020 11:17:07 +0000

use upstream patch for man pages.
---

What do you think about this?

-nc

 testing/e2tools/APKBUILD        |  34 +--
 testing/e2tools/e2cp.1          |  61 ----
 testing/e2tools/e2ln.1          |  39 ---
 testing/e2tools/e2ls.1          |  59 ----
 testing/e2tools/e2mkdir.1       |  41 ---
 testing/e2tools/e2mv.1          |  39 ---
 testing/e2tools/e2rm.1          |  34 ---
 testing/e2tools/e2tail.1        |  46 ---
 testing/e2tools/e2tools.7       |  72 -----
 testing/e2tools/man-pages.patch | 477 ++++++++++++++++++++++++++++++++
 10 files changed, 487 insertions(+), 415 deletions(-)
 delete mode 100644 testing/e2tools/e2cp.1
 delete mode 100644 testing/e2tools/e2ln.1
 delete mode 100644 testing/e2tools/e2ls.1
 delete mode 100644 testing/e2tools/e2mkdir.1
 delete mode 100644 testing/e2tools/e2mv.1
 delete mode 100644 testing/e2tools/e2rm.1
 delete mode 100644 testing/e2tools/e2tail.1
 delete mode 100644 testing/e2tools/e2tools.7
 create mode 100644 testing/e2tools/man-pages.patch

diff --git a/testing/e2tools/APKBUILD b/testing/e2tools/APKBUILD
index 296aac4a06..d42b500d20 100644
--- a/testing/e2tools/APKBUILD
+++ b/testing/e2tools/APKBUILD
@@ -2,24 +2,23 @@
 # Maintainer: Daniel Santana <[email-masked]>
 pkgname=e2tools
 pkgver=0.0.16
-pkgrel=1
+pkgrel=2
 pkgdesc="Utilities for manipulating files in an ext2/ext3 filesystem"
 url="https://e2tools.github.io/"
 arch="all"
 license="GPL-2.0-only"
-makedepends="e2fsprogs-dev"
+makedepends="e2fsprogs-dev autoconf automake libtool"
 subpackages="$pkgname-doc"
 source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
-	e2cp.1
-	e2ln.1
-	e2ls.1
-	e2mkdir.1
-	e2mv.1
-	e2rm.1
-	e2tail.1
-	e2tools.7
+	man-pages.patch
 	"
 
+prepare() {
+	default_prepare
+	rm -f configure
+	autoreconf -vif
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
@@ -34,20 +33,7 @@ check() {
 
 package() {
 	make DESTDIR="$pkgdir" install
-	install -dm 0755 "$pkgdir"/usr/share/man/man1
-	install -dm 0755 "$pkgdir"/usr/share/man/man7
-	install -pm 0644 "$srcdir"/e2tools.7 "$pkgdir"/usr/share/man/man7
-	for man in e2cp.1 e2ln.1 e2ls.1 e2mkdir.1 e2mv.1 e2rm.1 e2tail.1; do
-		install -pm 0644 "$srcdir/$man" "$pkgdir"/usr/share/man/man1
-	done
 }
 
 sha512sums="8be79385c07027286951755a7ca0407215b517d4abba5546a0958fcb5e8feaffc993d35dd56bde39e14d397875941fc812c713db3d27247cd8e9ee7ed6a153b4  e2tools-0.0.16.tar.gz
-11c91db4c1997e528e00f928d75e7330424b432ecbf03ac5f84ccf9bebba590a36839de4db1020c8fdbc43994669bc8ca027ede266fff0932bcdba01da614ffd  e2cp.1
-3ac5f23671444b4c77a0f51c8bca5eb3f3c90b5210e6ccfc9a6d076fe84075d63c863810a2140364625069a9cdc2541bd47ad43d0d785e1b4f58de3b74996a2c  e2ln.1
-86f129044eab493ce4fd81d892468388c9eac20f318f3e11f396090d4bed93d9bfc5cda1d48a522ec619271fcaa7f154f63c40095da9e93ad8dd2e55e075e8ed  e2ls.1
-4fbec4742c5b3b4b78544b9a0b50834b79ea08872eebaa81b41220c0d57c05891289684dff36faf6114235f78874d5d7f075a716aa8c72760b307782be01481d  e2mkdir.1
-2a4f3d1c6cb7dda083e1934523f0ec27200deb53b43359e5d366bedc0e15dd4f0f9cf9ad993089aa34c30a30810aab51ffc204181451055cf3d2050b774e544b  e2mv.1
-c2c85abe3360a202edb0bdde762e177eb1aec9a9775ae56716a3d45abbb2107e9cadebd73519932eaab413a054d870aaf547cc4ee1cf8595cd87666b050f3a41  e2rm.1
-f2f1535e23eff2d6238b9c7c47aca9691b2f55e70f91552c88877b49d02abaae6bff95eb034d954f4977cf04c49bc23a4cf0a8f693356b54d013e8ed6f367a0d  e2tail.1
-68303012608439ba0db2e6e09ed163c0b291ccd90f7615122fd99847d795f241d6a3fd40da97d31c1016ee4f11458c2e7c415c7348397cadbb519c7e49654938  e2tools.7"
+7c2811f4c94c75f5da6d5457cc8371b892d43798259dc672e9d5563b2bf0e43830755d3ef9380ce8fbd04083dfab0724bfe31384e357f122843f2048e1b04510  man-pages.patch"
diff --git a/testing/e2tools/e2cp.1 b/testing/e2tools/e2cp.1
deleted file mode 100644
index 1842c9c35a..0000000000
--- a/testing/e2tools/e2cp.1
+++ /dev/null
@@ -1,61 +0,0 @@
-.TH E2CP 1 "March 2, 2005"
-.\"
-.SH NAME
-e2cp \- copies files from/to an e2fs filesystem
-.\"
-.SH SYNOPSIS
-.B e2cp
-.RI [ options ] " files... dest"
-.\"
-.SH DESCRIPTION
-The \fBe2cp\fP command copies files to/from an e2fs filesystem from/to the
-machine's filesystem.
-.\"
-.SH OPTIONS
-A single `-' (dash) can be used instead of a file name to indicate standard
-input/output.
-.TP
-.B \-0
-Input lines terminated by a null character.
-.TP
-.B \-a
-Absolute directory names - create directories instead of just copying
-into the destination. Only valid for copying into an ext2fs filesystem.
-.TP
-.B \-d \fIdest_dir\fP
-Destination of files to be copied. May be in the ext2fs filesystem or
-the host filesystem.
-.TP
-.B \-G \fIgid\fP
-Set the default group to gid.
-.TP
-.B \-O \fIuid\fP
-Set the default file owner to uid.
-.TP
-.B \-p
-Preserve host file attributes (permissions, times, etc.) when copying
-files.
-.TP
-.B \-P \fImode\fP
-Set the file permissions (ie 755, 666).
-.TP
-.B \-s \fIsrc_dir\fP
-The source of the files to be copied.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2mv (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2ln.1 b/testing/e2tools/e2ln.1
deleted file mode 100644
index 8755c7c3c2..0000000000
--- a/testing/e2tools/e2ln.1
+++ /dev/null
@@ -1,39 +0,0 @@
-.TH E2LN 1 "March 2, 2005"
-.\"
-.SH NAME
-e2ln \- create hard links on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2ln
-.RI [ options ] " source destination"
-.\"
-.SH DESCRIPTION
-The \fBe2ln\fP command is used to create hard links on an ext2 filesystem.
-.\"
-.SH OPTIONS
-.TP
-.B \-f
-Force the operation to remove any existing files.
-.TP
-.B \-s
-Create a symlink.
-.TP
-.B \-v
-Be verbose.
-.PP
-Note: creating symlinks is not operational at this time.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2mv (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2ls.1 b/testing/e2tools/e2ls.1
deleted file mode 100644
index cc763f9202..0000000000
--- a/testing/e2tools/e2ls.1
+++ /dev/null
@@ -1,59 +0,0 @@
-.TH E2LS 1 "March 2, 2005"
-.\"
-.SH NAME
-e2ls \- list files and directories on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2ls
-.RI [ options ] " file_specification"
-.\"
-.SH DESCRIPTION
-The \fBe2ls\fP command is used to list files and directories on an ext2
-filesystem.
-.PP
-Note: Files deleted via e2rm sometimes will show up even without the -D
-option. It is being investigated.
-.\"
-.SH OPTIONS
-.TP
-.B \-a
-Show hidden directories.
-.TP
-.B \-c
-Sort by creation time (must include -t when using -l).
-.TP
-.B \-d \fIdir\fP
-Open the ext2 filesystem specified by dir.
-.TP
-.B \-D
-Show deleted files bracketed with ><.
-.TP
-.B \-f
-No sorting of the file list.
-.TP
-.B \-i
-Show the inodes (very useful for the -l option).
-.TP
-.B \-l
-Long listing.
-.TP
-.B \-r
-Reverse the sort order.
-.TP
-.B \-t
-Sort by time.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2mv (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2mkdir.1 b/testing/e2tools/e2mkdir.1
deleted file mode 100644
index 1c230ec3bc..0000000000
--- a/testing/e2tools/e2mkdir.1
+++ /dev/null
@@ -1,41 +0,0 @@
-.TH E2MKDIR 1 "March 2, 2005"
-.\"
-.SH NAME
-e2mkdir \- creates a directory on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2mkdir
-.RI [ options ] " directory..."
-.\"
-.SH DESCRIPTION
-The \fBe2mkdir\fP command creates directories on an ext2 filesystem. It
-behaves similar to `mkdir -p'.
-.\"
-.SH OPTIONS
-.TP
-.B \-G \fIgid\fP
-Set the default group to gid.
-.TP
-.B \-O \fIuid\fP
-Set the default file owner to uid.
-.TP
-.B \-P \fImode\fP
-Set the file permissions (ie 755, 666).
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mv (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2mv.1 b/testing/e2tools/e2mv.1
deleted file mode 100644
index 604226679c..0000000000
--- a/testing/e2tools/e2mv.1
+++ /dev/null
@@ -1,39 +0,0 @@
-.TH E2MV 1 "March 2, 2005"
-.\"
-.SH NAME
-e2mv \- moves or renames files on an ext2fs filesystem
-.\"
-.SH SYNOPSIS
-.B e2mv
-.RI [ options ] " files... dest"
-.\"
-.SH DESCRIPTION
-The \fBe2mv\fP command moves or renames files on an ext2fs filesystem. The
-source files must be explicitly stated. It does not use regular expressions,
-yet.
-.\"
-.SH OPTIONS
-.TP
-.B \-f
-Force the operation to remove any existing files.
-.TP
-.B \-s
-Swap names of the two files.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2rm.1 b/testing/e2tools/e2rm.1
deleted file mode 100644
index 1a6417283e..0000000000
--- a/testing/e2tools/e2rm.1
+++ /dev/null
@@ -1,34 +0,0 @@
-.TH E2RM 1 "March 2, 2005"
-.\"
-.SH NAME
-e2rm \- removes files and directories on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2rm
-.RI [ options ] " files..."
-.\"
-.SH DESCRIPTION
-The \fBe2rm\fP command removes files and directories on an ext2 filesystem.
-.\"
-.SH OPTIONS
-.TP
-.B \-r
-Recursively delete files if a directory name is given.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2mv (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2tail.1 b/testing/e2tools/e2tail.1
deleted file mode 100644
index bd48600fd4..0000000000
--- a/testing/e2tools/e2tail.1
+++ /dev/null
@@ -1,46 +0,0 @@
-.TH E2TAIL 1 "March 2, 2005"
-.\"
-.SH NAME
-e2tail \- a basic version of the tail command for an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2tail
-.RI [ options ] " file"
-.\"
-.SH DESCRIPTION
-The \fBe2tail\fP command implements a basic version of the tail command.
-.\"
-.SH OPTIONS
-.TP
-.B \-n \fInum_lines\fP
-The number of lines to display
-.TP
-.B \-f
-Output appended data as the file grows.  This is inode dependent, so if the
-file is renamed, it will keep checking it.
-.TP
-.B \-F
-Output appended data as the file grows.  This is file name dependent, so if
-the file is renamed, it will check on any new files with the same name as the
-original.  This is useful for watching log files that may be rotated out
-occasionally.  This was requested by a person in the computer security field
-for monitoring 'honeypot' type machines.
-.TP
-.B \-s \fIsleep_interval\fP
-The number of seconds to sleep before checking if the file has grown while
-in 'follow' mode.  The default is 1.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2mv (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/e2tools.7 b/testing/e2tools/e2tools.7
deleted file mode 100644
index c4bb9f5124..0000000000
--- a/testing/e2tools/e2tools.7
+++ /dev/null
@@ -1,72 +0,0 @@
-.TH E2TOOLS 7 "March 2, 2005"
-.\"
-.SH NAME
-e2tools \-  utilities to manipulate files in an ext2/ext3 filesystem
-.\"
-.SH DESCRIPTION
-E2tools is a simple set of GPL'ed utilities to read, write, and
-manipulate files in an ext2/ext3 filesystem. These utilities access a
-filesystem directly using the ext2fs library. I wrote these tools in order
-to copy files into a linux filesystem on a machine that does not have ext2
-support. Of course, they can also be used on a linux machine to read/write
-to disk images or floppies without having to mount them or have root
-access.
-.PP
-Supported functionality:
-.TP
-.B e2cp
-copy files
-.TP
-.B e2mv
-move files
-.TP
-.B e2rm
-remove files
-.TP
-.B e2mkdir
-create directory
-.TP
-.B e2ln
-create hard links
-.TP
-.B e2ls
-list files/directories
-.TP
-.B e2tail
-output the last part of a file
-.PP
-In general, to specify a directory or file on an ext2 filesystem for the
-e2tools utilities, use the following form:
-.IP
-filesystem:directory_path
-.PP
-The filesystem can be an unmounted partition or a regular file that's been
-formatted to contain an ext2 filesystem.  In general, if a command takes
-multiple file names on the command line, if the first one contains an ext2
-file specification, the rest of the files are assumed to be on the same
-filesystem until another one is explicitly stated:
-.IP
-/tmp/boot.img:/tmp/file1
-.IP
-/tmp/file2
-.IP
-/tmp/file3
-.IP
-/tmp/boot2.img:/tmp/file4
-.PP
-Files 1-3 are on /tmp/boot.img and the last file is on /tmp/boot2.img
-.\"
-.SH SEE ALSO
-.BR e2cp (1),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2mv (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
-.PP
-This manual page was written by Lucas Wall <[email-masked]>,
-for the Debian project (but may be used by others).
diff --git a/testing/e2tools/man-pages.patch b/testing/e2tools/man-pages.patch
new file mode 100644
index 0000000000..c514608fe2
--- /dev/null
+++ b/testing/e2tools/man-pages.patch
@@ -0,0 +1,477 @@
+From 475d6f970a0067181841bdb6fbd8f166703bd154 Mon Sep 17 00:00:00 2001
+From: Hans Ulrich Niedermann <[email-masked]>
+Date: Mon, 17 Dec 2007 15:49:03 +0100
+Subject: [PATCH] Add man pages (courtesy of Lucas Wall at Debian)
+
+---
+ Makefile.am |  2 ++
+ e2cp.1      | 61 +++++++++++++++++++++++++++++++++++++++++++++
+ e2ln.1      | 39 +++++++++++++++++++++++++++++
+ e2ls.1      | 59 +++++++++++++++++++++++++++++++++++++++++++
+ e2mkdir.1   | 41 ++++++++++++++++++++++++++++++
+ e2mv.1      | 39 +++++++++++++++++++++++++++++
+ e2rm.1      | 34 +++++++++++++++++++++++++
+ e2tail.1    | 46 ++++++++++++++++++++++++++++++++++
+ e2tools.7   | 72 +++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 9 files changed, 393 insertions(+)
+ create mode 100644 e2cp.1
+ create mode 100644 e2ln.1
+ create mode 100644 e2ls.1
+ create mode 100644 e2mkdir.1
+ create mode 100644 e2mv.1
+ create mode 100644 e2rm.1
+ create mode 100644 e2tail.1
+ create mode 100644 e2tools.7
+
+diff --git a/Makefile.am b/Makefile.am
+index 037d501..b897d25 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -21,6 +21,8 @@ e2cp_SOURCES = \
+ 	write.c write.h
+ 
+ EXTRA_DIST = README TODO e2tools.spec
++dist_man_MANS = e2tools.7
++dist_man_MANS += e2cp.1 e2ln.1 e2ls.1 e2mkdir.1 e2mv.1 e2rm.1 e2tail.1
+ 
+ install-exec-hook:
+ 	$(LN_S) -f e2cp $(DESTDIR)$(bindir)/e2ln
+diff --git a/e2cp.1 b/e2cp.1
+new file mode 100644
+index 0000000..1842c9c
+--- /dev/null
++++ b/e2cp.1
+@@ -0,0 +1,61 @@
++.TH E2CP 1 "March 2, 2005"
++.\"
++.SH NAME
++e2cp \- copies files from/to an e2fs filesystem
++.\"
++.SH SYNOPSIS
++.B e2cp
++.RI [ options ] " files... dest"
++.\"
++.SH DESCRIPTION
++The \fBe2cp\fP command copies files to/from an e2fs filesystem from/to the
++machine's filesystem.
++.\"
++.SH OPTIONS
++A single `-' (dash) can be used instead of a file name to indicate standard
++input/output.
++.TP
++.B \-0
++Input lines terminated by a null character.
++.TP
++.B \-a
++Absolute directory names - create directories instead of just copying
++into the destination. Only valid for copying into an ext2fs filesystem.
++.TP
++.B \-d \fIdest_dir\fP
++Destination of files to be copied. May be in the ext2fs filesystem or
++the host filesystem.
++.TP
++.B \-G \fIgid\fP
++Set the default group to gid.
++.TP
++.B \-O \fIuid\fP
++Set the default file owner to uid.
++.TP
++.B \-p
++Preserve host file attributes (permissions, times, etc.) when copying
++files.
++.TP
++.B \-P \fImode\fP
++Set the file permissions (ie 755, 666).
++.TP
++.B \-s \fIsrc_dir\fP
++The source of the files to be copied.
++.TP
++.B \-v
++Be verbose.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2mv (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2ln.1 b/e2ln.1
+new file mode 100644
+index 0000000..8755c7c
+--- /dev/null
++++ b/e2ln.1
+@@ -0,0 +1,39 @@
++.TH E2LN 1 "March 2, 2005"
++.\"
++.SH NAME
++e2ln \- create hard links on an ext2 filesystem
++.\"
++.SH SYNOPSIS
++.B e2ln
++.RI [ options ] " source destination"
++.\"
++.SH DESCRIPTION
++The \fBe2ln\fP command is used to create hard links on an ext2 filesystem.
++.\"
++.SH OPTIONS
++.TP
++.B \-f
++Force the operation to remove any existing files.
++.TP
++.B \-s
++Create a symlink.
++.TP
++.B \-v
++Be verbose.
++.PP
++Note: creating symlinks is not operational at this time.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2mv (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2cp (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2ls.1 b/e2ls.1
+new file mode 100644
+index 0000000..cc763f9
+--- /dev/null
++++ b/e2ls.1
+@@ -0,0 +1,59 @@
++.TH E2LS 1 "March 2, 2005"
++.\"
++.SH NAME
++e2ls \- list files and directories on an ext2 filesystem
++.\"
++.SH SYNOPSIS
++.B e2ls
++.RI [ options ] " file_specification"
++.\"
++.SH DESCRIPTION
++The \fBe2ls\fP command is used to list files and directories on an ext2
++filesystem.
++.PP
++Note: Files deleted via e2rm sometimes will show up even without the -D
++option. It is being investigated.
++.\"
++.SH OPTIONS
++.TP
++.B \-a
++Show hidden directories.
++.TP
++.B \-c
++Sort by creation time (must include -t when using -l).
++.TP
++.B \-d \fIdir\fP
++Open the ext2 filesystem specified by dir.
++.TP
++.B \-D
++Show deleted files bracketed with ><.
++.TP
++.B \-f
++No sorting of the file list.
++.TP
++.B \-i
++Show the inodes (very useful for the -l option).
++.TP
++.B \-l
++Long listing.
++.TP
++.B \-r
++Reverse the sort order.
++.TP
++.B \-t
++Sort by time.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2mv (1),
++.BR e2mkdir (1),
++.BR e2cp (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2mkdir.1 b/e2mkdir.1
+new file mode 100644
+index 0000000..1c230ec
+--- /dev/null
++++ b/e2mkdir.1
+@@ -0,0 +1,41 @@
++.TH E2MKDIR 1 "March 2, 2005"
++.\"
++.SH NAME
++e2mkdir \- creates a directory on an ext2 filesystem
++.\"
++.SH SYNOPSIS
++.B e2mkdir
++.RI [ options ] " directory..."
++.\"
++.SH DESCRIPTION
++The \fBe2mkdir\fP command creates directories on an ext2 filesystem. It
++behaves similar to `mkdir -p'.
++.\"
++.SH OPTIONS
++.TP
++.B \-G \fIgid\fP
++Set the default group to gid.
++.TP
++.B \-O \fIuid\fP
++Set the default file owner to uid.
++.TP
++.B \-P \fImode\fP
++Set the file permissions (ie 755, 666).
++.TP
++.B \-v
++Be verbose.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mv (1),
++.BR e2cp (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2mv.1 b/e2mv.1
+new file mode 100644
+index 0000000..6042266
+--- /dev/null
++++ b/e2mv.1
+@@ -0,0 +1,39 @@
++.TH E2MV 1 "March 2, 2005"
++.\"
++.SH NAME
++e2mv \- moves or renames files on an ext2fs filesystem
++.\"
++.SH SYNOPSIS
++.B e2mv
++.RI [ options ] " files... dest"
++.\"
++.SH DESCRIPTION
++The \fBe2mv\fP command moves or renames files on an ext2fs filesystem. The
++source files must be explicitly stated. It does not use regular expressions,
++yet.
++.\"
++.SH OPTIONS
++.TP
++.B \-f
++Force the operation to remove any existing files.
++.TP
++.B \-s
++Swap names of the two files.
++.TP
++.B \-v
++Be verbose.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2cp (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2rm.1 b/e2rm.1
+new file mode 100644
+index 0000000..1a64172
+--- /dev/null
++++ b/e2rm.1
+@@ -0,0 +1,34 @@
++.TH E2RM 1 "March 2, 2005"
++.\"
++.SH NAME
++e2rm \- removes files and directories on an ext2 filesystem
++.\"
++.SH SYNOPSIS
++.B e2rm
++.RI [ options ] " files..."
++.\"
++.SH DESCRIPTION
++The \fBe2rm\fP command removes files and directories on an ext2 filesystem.
++.\"
++.SH OPTIONS
++.TP
++.B \-r
++Recursively delete files if a directory name is given.
++.TP
++.B \-v
++Be verbose.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2cp (1),
++.BR e2mv (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2tail.1 b/e2tail.1
+new file mode 100644
+index 0000000..bd48600
+--- /dev/null
++++ b/e2tail.1
+@@ -0,0 +1,46 @@
++.TH E2TAIL 1 "March 2, 2005"
++.\"
++.SH NAME
++e2tail \- a basic version of the tail command for an ext2 filesystem
++.\"
++.SH SYNOPSIS
++.B e2tail
++.RI [ options ] " file"
++.\"
++.SH DESCRIPTION
++The \fBe2tail\fP command implements a basic version of the tail command.
++.\"
++.SH OPTIONS
++.TP
++.B \-n \fInum_lines\fP
++The number of lines to display
++.TP
++.B \-f
++Output appended data as the file grows.  This is inode dependent, so if the
++file is renamed, it will keep checking it.
++.TP
++.B \-F
++Output appended data as the file grows.  This is file name dependent, so if
++the file is renamed, it will check on any new files with the same name as the
++original.  This is useful for watching log files that may be rotated out
++occasionally.  This was requested by a person in the computer security field
++for monitoring 'honeypot' type machines.
++.TP
++.B \-s \fIsleep_interval\fP
++The number of seconds to sleep before checking if the file has grown while
++in 'follow' mode.  The default is 1.
++.\"
++.SH SEE ALSO
++.BR e2tools (7),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2cp (1),
++.BR e2rm (1),
++.BR e2mv (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
+diff --git a/e2tools.7 b/e2tools.7
+new file mode 100644
+index 0000000..c4bb9f5
+--- /dev/null
++++ b/e2tools.7
+@@ -0,0 +1,72 @@
++.TH E2TOOLS 7 "March 2, 2005"
++.\"
++.SH NAME
++e2tools \-  utilities to manipulate files in an ext2/ext3 filesystem
++.\"
++.SH DESCRIPTION
++E2tools is a simple set of GPL'ed utilities to read, write, and
++manipulate files in an ext2/ext3 filesystem. These utilities access a
++filesystem directly using the ext2fs library. I wrote these tools in order
++to copy files into a linux filesystem on a machine that does not have ext2
++support. Of course, they can also be used on a linux machine to read/write
++to disk images or floppies without having to mount them or have root
++access.
++.PP
++Supported functionality:
++.TP
++.B e2cp
++copy files
++.TP
++.B e2mv
++move files
++.TP
++.B e2rm
++remove files
++.TP
++.B e2mkdir
++create directory
++.TP
++.B e2ln
++create hard links
++.TP
++.B e2ls
++list files/directories
++.TP
++.B e2tail
++output the last part of a file
++.PP
++In general, to specify a directory or file on an ext2 filesystem for the
++e2tools utilities, use the following form:
++.IP
++filesystem:directory_path
++.PP
++The filesystem can be an unmounted partition or a regular file that's been
++formatted to contain an ext2 filesystem.  In general, if a command takes
++multiple file names on the command line, if the first one contains an ext2
++file specification, the rest of the files are assumed to be on the same
++filesystem until another one is explicitly stated:
++.IP
++/tmp/boot.img:/tmp/file1
++.IP
++/tmp/file2
++.IP
++/tmp/file3
++.IP
++/tmp/boot2.img:/tmp/file4
++.PP
++Files 1-3 are on /tmp/boot.img and the last file is on /tmp/boot2.img
++.\"
++.SH SEE ALSO
++.BR e2cp (1),
++.BR e2ln (1),
++.BR e2ls (1),
++.BR e2mkdir (1),
++.BR e2mv (1),
++.BR e2rm (1),
++.BR e2tail (1).
++.\"
++.SH AUTHOR
++The \fBe2tools\fP were written by Keith Sheffield <[email-masked]>.
++.PP
++This manual page was written by Lucas Wall <[email-masked]>,
++for the Debian project (but may be used by others).
-- 
2.25.0

---

From: Natanael Copa <[email-masked]>
Date: Mon, 3 Feb 2020 11:43:09 +0100

On Mon,  3 Feb 2020 00:41:05 -0300

> +++ b/community/gst-plugins-bad/APKBUILD

libusrsctp is in testing so it needs to move to community too. Would be
nice to have a new release first though.

https://github.com/sctplab/usrsctp/issues/136

Thanks!

-nc