Subject: [PATCH] testing/i3status-rust: new aport

From: Galen Abell <[email-masked]>
Date: Tue, 11 Feb 2020 12:32:05 -0500

https://github.com/greshake/i3status-rust
i3status replacement in Rust
testing/
---
 testing/i3status-rust/APKBUILD | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 testing/i3status-rust/APKBUILD

diff --git a/testing/i3status-rust/APKBUILD b/testing/i3status-rust/APKBUILD
new file mode 100644
index 0000000000..9cdb4ae2ba
--- /dev/null
+++ b/testing/i3status-rust/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Galen Abell <[email-masked]>
+# Maintainer: Galen Abell <[email-masked]>
+pkgname="i3status-rust"
+pkgver="0.13.1"
+pkgrel=0
+pkgdesc="i3status replacement in Rust"
+url="https://github.com/greshake/i3status-rust"
+arch="all"
+license="GPL-3.0-only"
+makedepends="rust cargo"
+options="!check" # no tests
+provides="i3status-rs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/greshake/i3status-rust/archive/v$pkgver.tar.gz"
+
+build() {
+	cargo build --release --verbose
+}
+
+package() {
+	install -Dm755 target/release/i3status-rs "$pkgdir"/usr/bin/i3status-rs
+}
+sha512sums="85c009d9164caac3b209c6afd0d7ad874cf8cea57a6c66c21a9484b186297f02c55cb8fb913db86cd0ccb55cabf14014900043927f9dea768ac7dc5b29a9f787  i3status-rust-0.13.1.tar.gz"
-- 
2.25.0

---

From: Leo <[email-masked]>
Date: Tue, 11 Feb 2020 14:37:21 -0300

On Tue, 11 Feb 2020 12:32:05 -0500
Galen Abell <[email-masked]> wrote:

> diff --git a/testing/i3status-rust/APKBUILD
> b/testing/i3status-rust/APKBUILD new file mode 100644

Won't work in s390x, please make an MR in our GitLab if possible, we
have CI there that will check if the package builds on other arches.

> +	install -Dm755 target/release/i3status-rs
> "$pkgdir"/usr/bin/i3status-rs +}