Subject: [PATCH] testing/py3-zeroconf: ifaddr is a dependency

From: David Florness <[email-masked]>
Date: Wed, 18 Mar 2020 19:59:20 -0600

ifaddr is a dependency for zeroconf:
https://github.com/jstasiak/python-zeroconf/blob/8e3adf8300a6f2b0bc0dcc4cde54d8890e0727e9/setup.py#L46

---
 testing/py3-ifaddr/APKBUILD   | 29 +++++++++++++++++++++++++++++
 testing/py3-zeroconf/APKBUILD |  2 +-
 2 files changed, 30 insertions(+), 1 deletion(-)
 create mode 100644 testing/py3-ifaddr/APKBUILD

diff --git a/testing/py3-ifaddr/APKBUILD b/testing/py3-ifaddr/APKBUILD
new file mode 100644
index 0000000000..5afecf3ab9
--- /dev/null
+++ b/testing/py3-ifaddr/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: David Florness <[email-masked]>
+# Maintainer: David Florness <[email-masked]>
+pkgname="py3-ifaddr"
+_pkgname="ifaddr"
+pkgver="0.1.6"
+pkgrel=0
+pkgdesc="Enumerates all IP addresses on all network adapters of the system"
+url="https://github.com/pydron/$_pkgname"
+arch="all"
+license="MIT"
+options="!check"
+depends="python3"
+makedepends="py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/pydron/$_pkgname/archive/${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --prefix="/usr" --optimize=1
+}
+
+sha512sums="f8bfe0141f0c4e83404c8feead15a144e3f81fdfd9aeb5c9ca490789dfc7f74fa8cf36c895d048b595c340e17f7d82d96e3cdc25174ff67f3bb06a306094d59a  ifaddr-0.1.6.tar.gz"
diff --git a/testing/py3-zeroconf/APKBUILD b/testing/py3-zeroconf/APKBUILD
index d04514a3d4..b6186a662d 100644
--- a/testing/py3-zeroconf/APKBUILD
+++ b/testing/py3-zeroconf/APKBUILD
@@ -12,7 +12,7 @@ license="LGPL-2.0-or-later"
 replaces="py-zeroconf" # for backwards compatibility
 provides="py-zeroconf=$pkgver-r$pkgrel" # for backwards compatibility
 options="!check"
-depends="py3-six py3-netifaces"
+depends="python3 py3-six py3-netifaces py3-ifaddr"
 makedepends="py3-setuptools python3-dev"
 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
 builddir="$srcdir"/$_pkgname-$pkgver
-- 
2.25.2

---

From: David Florness <[email-masked]>
Date: Wed, 18 Mar 2020 20:23:49 -0600

Apologies for the duplicate email.

-- 
David

---

From: Kevin Daudt <[email-masked]>
Date: Thu, 19 Mar 2020 07:42:59 +0100

> +++ b/testing/py3-ifaddr/APKBUILD

Hello David,

This has been applied, thanks for your contributtion.

Note that we also accept contributions through our Gitlab instance,                                                                                                                                                                            
which will run the changes through our CI system.                                                                                                                                                                                              
                                                                                                                                                                                                                                               
See [this mr][0] for example which I used to verify this and your other                                                                                                                                                                        
patches.                                                                                                                                                                                                                                       
                                                                                                                                                                                                                                               
Kind regards, Kevin                                                                                                                                                                                                                            
                                                                                                                                                                                                                                               
[0]: https://gitlab.alpinelinux.org/alpine/aports/merge_requests/5571

---

From: David Florness <[email-masked]>
Date: Fri, 20 Mar 2020 11:46:56 -0600

Thanks Kevin.  Is using GitLab Alpine's preferred way to receive
patches?  I prefer git-send-email but I'll use whatever the project
wants me to.

--
David