Subject: [PATCH] testing/tre: new aport

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Wed, 14 Oct 2020 10:04:46 +0200

https://laurikari.net/tre
POSIX compliant regexp matching library.
Includes agrep for approximate grepping.
---
 testing/tre/APKBUILD | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 testing/tre/APKBUILD

diff --git a/testing/tre/APKBUILD b/testing/tre/APKBUILD
new file mode 100644
index 0000000000..4eb0e68fe4
--- /dev/null
+++ b/testing/tre/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor:
+# Maintainer:
+pkgname=tre
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="POSIX compliant regexp matching library. Includes agrep for approximate grepping."
+url="https://laurikari.net/tre"
+arch="all"
+license="BSD"
+depends="musl"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://laurikari.net/tre/tre-$pkgver.tar.bz2"
+
+build() {
+	cd "$srcdir/$pkgname-$pkgver"
+ 	./configure --prefix=/usr --enable-static
+	make
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+
+}
+
+sha512sums="db7465993e0d25eee8e52f974427b8a040234cf0f017769eb94ee88bc6261821336aad7f762bfa82db7e2212d8449bc221592586f061c528a59a550773cbc263  tre-0.8.0.tar.bz2"
-- 
2.28.0

---

From: Milan P. Stanić <[email-masked]>
Date: Wed, 14 Oct 2020 12:04:22 +0200

Hi,

I tried to build it as it is posted but it fail.
Maybe consider using version from https://github.com/laurikari/tre/

> +++ b/testing/tre/APKBUILD

It is not good idea to introduce package if no one intend to maintain
it.

> +url="https://laurikari.net/tre"
            ^^^^
This is not needed, it is by default.

> +	cd "$srcdir/$pkgname-$pkgver"
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Also this is not needed, it is default
> + 	./configure --prefix=/usr --enable-static

Keep these two aligned, i.e. equally indented

---

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Wed, 14 Oct 2020 15:18:18 +0200

i will fix error shortly,

but for other comments,
i would love to mantain that package whenever i am available, but for next couple of monthes i will not be available that much and the package maybe weeks behind if update comes in

the version on website is well tested and have less dependencies
and it's actually easier to build,
is it says any error msg? or any clue why it fail to build

---

From: Milan P. Stanić <[email-masked]>
Date: Wed, 14 Oct 2020 17:09:45 +0200

Hi,

> i would love to mantain that package whenever i am available, but for next couple of monthes i will not be available that much and the package maybe weeks behind if update comes in

That is ok, especially with software which don't have errors.
Someone will upgrade or/and even fix it if you are not available.
So you can add yourself in Maintainer field without problem.
 
> is it says any error msg? or any clue why it fail to build

I will put in gitlab.alpinelinux.org/aports where CI will try to build
it and show all errors or success.

BTW, gitlab.alpinelinux.org is preferred workflow for Alpine
development.

-- 
regards

---

From: Milan P. Stanić <[email-masked]>
Date: Wed, 14 Oct 2020 17:27:53 +0200

Hi Al-Hassan,

> it and show all errors or success.

Here is merge request: 
https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/13610

You can see where it fails.

-- 
regards