Subject: [PATCH v2] testing/tre: new aport

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Wed, 14 Oct 2020 15:30:01 +0200

https://laurikari.net/tre
POSIX compliant regexp matching library.
Includes agrep for approximate grepping.
---
 testing/tre/APKBUILD | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 testing/tre/APKBUILD

diff --git a/testing/tre/APKBUILD b/testing/tre/APKBUILD
new file mode 100644
index 0000000000..eddfb91bd3
--- /dev/null
+++ b/testing/tre/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor:
+# Maintainer:
+pkgname=tre
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="POSIX compliant regexp matching library. Includes agrep for approximate grepping."
+url="https://laurikari.net/tre"
+arch="all"
+license="BSD"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://laurikari.net/tre/tre-$pkgver.tar.bz2"
+
+build() {
+	./configure --prefix=/usr --enable-static
+	make
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="db7465993e0d25eee8e52f974427b8a040234cf0f017769eb94ee88bc6261821336aad7f762bfa82db7e2212d8449bc221592586f061c528a59a550773cbc263  tre-0.8.0.tar.bz2"
-- 
2.28.0

---

From: Leo <[email-masked]>
Date: Wed, 14 Oct 2020 14:22:44 -0300

On Wed, 14 Oct 2020 15:30:01 +0200

> +++ b/testing/tre/APKBUILD

Why no Maintainer ?

> +pkgname=tre
> +pkgver=0.8.0
> +pkgrel=0
> +pkgdesc="POSIX compliant regexp matching library. Includes agrep for
> approximate grepping." +url="https://laurikari.net/tre"
> +arch="all"
> +license="BSD"

Need to use an SPDX identifier

> +	./configure --prefix=/usr --enable-static

Please also pass --build=$CBUILD and --host=$CHOST

---

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Thu, 15 Oct 2020 00:05:00 +0200

sorry for late replay

i can be the maintainer if it's okay to be one week behind from any program update to update the package
because sometimes i can access computer on weekdays

---

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Thu, 15 Oct 2020 00:06:14 +0200

> because sometimes i can access computer on weekdays

can't

---

From: Al-Hassan Abdel-Raouf <[email-masked]>
Date: Thu, 15 Oct 2020 00:11:28 +0200

also i get error when passing --build=$CBUILD and --host=$CHOST to configure

and compile fine without them, maybe you can help me

The Error Message:

```
checking build system type... x86_64-unknown-linux-gnu
checking host system type... Invalid configuration `x86_64-alpine-linux-musl': machine `x86_64-alpine-linux' not recognized
configure: error: /bin/sh utils/config.sub x86_64-alpine-linux-musl failed'`'`
```

---

From: Leo <[email-masked]>
Date: Wed, 14 Oct 2020 20:26:03 -0300

On Thu, 15 Oct 2020 00:11:28 +0200
Al-Hassan Abdel-Raouf <[email-masked]> wrote:

> checking host system type... Invalid configuration
> `x86_64-alpine-linux-musl': machine `x86_64-alpine-linux' not
> recognized configure: error: /bin/sh utils/config.sub
> x86_64-alpine-linux-musl failed'`'` ```

Add update_config_guess inside prepare()

```sh
prepare() {
    default_prepare
    update_config_guess
}
```