Subject: [PATCH 1/1] main/iputils: Update to 20200821

From: Petr Vorel <[email-masked]>
Date: Sun, 24 Jan 2021 23:55:34 +0100

Changes related to this release:
* Define BUILD_TFTPD=true, because tftpd has been disabled by default
* Removed openssl-dev build dependency because MD5 implementation was
copied to iputils project.
* Update paths for ping, tftpd (moved to own directories).
* Drop patch from this release.

Signed-off-by: Petr Vorel <[email-masked]>
---
 main/iputils/APKBUILD | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)

diff --git a/main/iputils/APKBUILD b/main/iputils/APKBUILD
index bf4553519e..932974c1e8 100644
--- a/main/iputils/APKBUILD
+++ b/main/iputils/APKBUILD
@@ -1,16 +1,14 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=iputils
-pkgver=20190709
+pkgver=20200821
 pkgrel=1
 pkgdesc="IP Configuration Utilities (and Ping)"
 url="https://github.com/iputils/iputils/"
 arch="all"
-# openssl is only used in 'ninfod' and 'ping' which are BSD-3-Clause
 license="BSD-3-Clause AND GPL-2.0-or-later AND MIT"
-makedepends="libcap-dev openssl-dev meson"
+makedepends="libcap-dev meson"
 replaces="bbsuid"
 source="https://github.com/iputils/iputils/archive/s$pkgver.tar.gz
-	fix-libcap.patch::https://github.com/iputils/iputils/commit/18f9a84e0e702841d6cc4d5f593de4fbd1348e83.patch
 	"
 options="!check suid"
 builddir="$srcdir/$pkgname-s$pkgver"
@@ -19,6 +17,7 @@ build() {
 	abuild-meson \
 		-DNO_SETCAP_OR_SUID=true \
 		-DBUILD_RARPD=true \
+		-DBUILD_TFTPD=true \
 		-DBUILD_TRACEROUTE6=true \
 		-DBUILD_MANS=false \
 		-DUSE_IDN=false \
@@ -31,12 +30,12 @@ package() {
 	local name
 	cd "$builddir"/build
 
-	for name in arping clockdiff rarpd rdisc tftpd tracepath; do
+	for name in arping clockdiff rarpd rdisc tftpd/tftpd tracepath; do
 		install -D -m755 $name "$pkgdir"/usr/sbin/$name
 	done
 	install -D -m755 ninfod/ninfod "$pkgdir"/usr/sbin/ninfod
 
-	for name in ping traceroute6; do
+	for name in ping/ping traceroute6; do
 		install -D -m4755 $name "$pkgdir"/bin/$name
 	done
 
@@ -44,5 +43,4 @@ package() {
 	ln -s ping "$pkgdir"/bin/ping6
 }
 
-sha512sums="5db18ac49fa46ed810da4d508e78f4baf2d5c07e7f923eb49d005ad8745743d8861e5788b34a7e37fb7261cee7ddfb768b737eee9d200502ea53537142cac6b5  s20190709.tar.gz
-3c6b181e285e9e7ee500934a8984a299c01f84fb16e7f4d4bc678662b8f5a4f452b1d5bdfab38497a74c83be90ced052167d69f9ea4b9ef2eb0900392abd3924  fix-libcap.patch"
+sha512sums="4a57c3637cdd9aab2600682774e27370716cbdf1c7ac8ae61bf86c21c08701a5b697792df4aa95309b196eaa74f3cb6b2836a40f04da0e602156e982ac99d8c9  s20200821.tar.gz"
-- 
2.30.0

---

From: maxice8 <[email-masked]>
Date: Sun, 24 Jan 2021 19:57:37 -0300

> +++ b/main/iputils/APKBUILD

pkgrel needs to be reset to 0 when upgrading

> -       fix-libcap.patch::
> https://github.com/iputils/iputils/commit/18f9a84e0e702841d6cc4d5f593de4fbd1348e83.patch
>         "
>  options="!check suid"
> -
> sha512sums="5db18ac49fa46ed810da4d508e78f4baf2d5c07e7f923eb49d005ad874
> 5743d8861e5788b34a7e37fb7261cee7ddfb768b737eee9d200502ea53537142cac6b
> 5  s20190709.tar.gz
> -
> 3c6b181e285e9e7ee500934a8984a299c01f84fb16e7f4d4bc678662b8f5a4f452b1d5
> bdfab38497a74c83be90ced052167d69f9ea4b9ef2eb0900392abd3924  fix-
> libcap.patch"
> +sha512sums="4a57c3637cdd9aab2600682774e27370716cbdf1c7ac8ae61bf86c21
> c08701a5b697792df4aa95309b196eaa74f3cb6b2836a40f04da0e602156e982ac99d
> 8c9  s20200821.tar.gz"