Subject: [PATCH v2 1/1] testing/linux-test-project: new aport

From: Petr Vorel <[email-masked]>
Date: Mon, 25 Jan 2021 20:09:21 +0100

Signed-off-by: Petr Vorel <[email-masked]>
---
Changes v1->v2:
* update title to testing to reflect directory

Kind regards,
Petr

 testing/linux-test-project/APKBUILD | 79 +++++++++++++++++++++++++++++
 1 file changed, 79 insertions(+)
 create mode 100644 testing/linux-test-project/APKBUILD

diff --git a/testing/linux-test-project/APKBUILD b/testing/linux-test-project/APKBUILD
new file mode 100644
index 0000000000..e8bd718b90
--- /dev/null
+++ b/testing/linux-test-project/APKBUILD
@@ -0,0 +1,79 @@
+# Contributor: Petr Vorel <[email-masked]>
+# Maintainer: Petr Vorel <[email-masked]>
+pkgname=ltp-full
+pkgver=20210121
+pkgrel=0
+pkgdesc="The Linux Test Project"
+url="http://linux-test-project.github.io"
+arch="all"
+license="GPL-2.0-or-later"
+depends="
+	acl
+	attr
+	bc
+	binutils
+	e2fsprogs
+	iputils
+	iproute2
+"
+depends_dev="
+	acl-dev
+	autoconf
+	automake
+	bison
+	flex
+	gcc
+	keyutils-dev
+	libaio-dev
+	libacl
+	libcap-dev
+	libselinux-dev
+	libsepol-dev
+	libtirpc-dev
+	linux-headers
+	make
+	musl-dev
+	numactl-dev
+	openssl-dev
+	pkgconfig
+"
+makedepends="$depends_dev"
+options="!check" # no tests
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.xz"
+builddir="$srcdir/ltp-full-$pkgver"
+
+prepare() {
+	default_prepare
+
+	# https://github.com/linux-test-project/ltp/blob/master/travis/alpine.sh
+	cd "$builddir"
+	rm -rf \
+	testcases/kernel/sched/process_stress/process.c \
+	testcases/kernel/syscalls/confstr/confstr01.c \
+	testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
+	testcases/kernel/syscalls/getcontext/getcontext01.c \
+	testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
+	testcases/kernel/syscalls/timer_create/timer_create01.c \
+	testcases/kernel/syscalls/timer_create/timer_create03.c \
+	utils/benchmark/ebizzy-0.3
+	cd -
+}
+
+build() {
+	LEXLIB=-lfl \
+	./configure \
+		--with-realtime-testsuite \
+		--with-open-posix-testsuite \
+		--disable-metadata \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr
+	make V=1
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="382e4b851138805f58093bc8232df5d22f9cf64ffa110bbaa5c5637517c47663772b96c55eca172f447bee7d1a1fb29084660c5374c4042461c59ba8faab3101  ltp-full-20210121.tar.xz"
-- 
2.28.0

---

From: Petr Vorel <[email-masked]>
Date: Wed, 27 Jan 2021 21:52:54 +0100

Hi,

> * update title to testing to reflect directory

Any change LTP gets accepted as a package?
Or are the any objections, anything to change?
I don't expect it'd ever leave testing (it's a testing tool anyway), but other
embedded distros found it useful (Buildroot, OpenEmbedded).
I also work on native musl support (broken tests will be fixed, deleting them
now it's just a temporary workaround).

Kind regards,
Petr

---

From: Petr Vorel <[email-masked]>
Date: Wed, 18 Jan 2023 21:43:55 +0100

Hi all,

would it be possible to add LTP [1] to Alpine? I'm using it for
testing kernel on various architectures
I suppose others would use it as well (it's at least in Buildroot, Yocto).

I wonder if Alpine just does not want this package or there is
something wrong with the patch
(I haven't got any reply to my patches).

Thanks for info.

Kind regards,
Petr

[1] https://github.com/linux-test-project/ltp

---

From: "alice" <[email-masked]>
Date: Wed, 18 Jan 2023 22:03:31 +0100

> (I haven't got any reply to my patches).

you would have to create a merge request on gitlab, as the mailing list for
patches has been down for a while.

---

From: Petr Vorel <[email-masked]>
Date: Thu, 19 Jan 2023 20:11:13 +0100

Hi Alice,

> patches has been down for a while.

Thanks for info, I'll do PR. I just wasn't sure if anybody is against
that package
(I know it's a testing package).

Kind regards,
Petr

---

From: Petr Vorel <[email-masked]>
Date: Thu, 19 Jan 2023 21:35:53 +0100

Hi all,

> (I know it's a testing package).

FYI LTP 20220930 submitted:
https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/43366

Kind regards,
Petr