Subject: [PATCH] community/siglo: upgrade to 0.8.12

From: Neil O'Fix <[email-masked]>
Date: Sat, 7 Aug 2021 13:51:16 +0200

add py3-xdg dependency introduced in siglo 0.6.2
---
 community/siglo/APKBUILD | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/community/siglo/APKBUILD b/community/siglo/APKBUILD
index 0a731a0b4e..710f2c433c 100644
--- a/community/siglo/APKBUILD
+++ b/community/siglo/APKBUILD
@@ -1,13 +1,14 @@
 # Maintainer: Martijn Braam <[email-masked]>
 # Contributor: Martijn Braam <[email-masked]>
+# Contributor: Neil O'Fix <[email-masked]>
 pkgname=siglo
-pkgver=0.6.0
+pkgver=0.8.12
 pkgrel=0
 pkgdesc="GTK app to sync InfiniTime watch with PinePhone"
 url="https://github.com/alexr4535/siglo"
 arch="noarch"
 license="MPL-2.0"
-depends="python3 py3-gobject3 gtk+3.0 bluez bluez-btmgmt py3-dbus py3-gatt py3-requests"
+depends="python3 py3-gobject3 gtk+3.0 bluez bluez-btmgmt py3-dbus py3-gatt py3-requests py3-xdg"
 makedepends="glib-dev meson"
 source="https://github.com/alexr4535/siglo/archive/v$pkgver/siglo-v$pkgver.tar.gz"
 options="!check" # There's no testsuite
@@ -20,4 +21,4 @@ build() {
 package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
-sha512sums="238a8713e471abb8f1a954ae3d6ba68a77cf7603502fefe4f5d26fb8add3a13cc4a14f30f50cac2ce010906e4587c0ae147469ed50f7ba683b146161cd97528e  siglo-v0.6.0.tar.gz"
+sha512sums="07cb73f09281c857ed67f209c49f291cc25745f1dc8973961740b13a876c60514428bbcbb07df2e52cd76c74e4166fe75ac7b41aa818ac32a9cc62b603f4cfc6  siglo-v$pkgver.tar.gz"
-- 
2.20.1

---

From: Andy Postnikov <[email-masked]>
Date: Sun, 08 Aug 2021 00:24:09 -0000

there's duplicate https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24024

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24012#note_172563

---

From: Bart Ribbers <[email-masked]>
Date: Sat, 07 Aug 2021 16:42:31 -0000

> +sha512sums="07cb73f09281c857ed67f209c49f291cc25745f1dc8973961740b13a876c60514428bbcbb07df2e52cd76c74e4166fe75ac7b41aa818ac32a9cc62b603f4cfc6  siglo-v$pkgver.tar.gz"

Lol, you are not supposed to modify the `$sha512sums` variable. It should only be generated with `abuild checksum`. And it definitely shouldn't contain variables.

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24012#note_172506

---

From: Neil O'Fix <[email-masked]>
Date: Sun, 8 Aug 2021 16:54:43 +0200

add py3-xdg dependency introduced in siglo 0.6.2
---
Changes v1 -> v2:
 - sha512 checksum generated with `abuild checksum`

Sorry for the double merge request, I forgot to add the In-Reply-To
header in my patch v2 email. I hope this one is correct.

Closes !24024

 community/siglo/APKBUILD | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

index 0a731a0b4e..def2551b0d 100644
@@ -20,4 +21,6 @@ build() {
+sha512sums="
+07cb73f09281c857ed67f209c49f291cc25745f1dc8973961740b13a876c60514428bbcbb07df2e52cd76c74e4166fe75ac7b41aa818ac32a9cc62b603f4cfc6  siglo-v0.8.12.tar.gz
+"
-- 
2.20.1

---

From: mailinglist-bot <[email-masked]>
Date: Sun, 08 Aug 2021 14:59:35 -0000

> +sha512sums="07cb73f09281c857ed67f209c49f291cc25745f1dc8973961740b13a876c60514428bbcbb07df2e52cd76c74e4166fe75ac7b41aa818ac32a9cc62b603f4cfc6  siglo-v$pkgver.tar.gz"

Neil O'Fix <[email-masked]> replied via email:

```

Closes !24024

```

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24012#note_172620

---

From: Leo <[email-masked]>
Date: Mon, 23 Aug 2021 08:34:13 -0000

closed this one and reopoened !24024 due to how @mailinglist-bot works (it creates new MRs for new patches instead of updating the current one)

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24012#note_176222