Subject: [PATCH v2] community/siglo: upgrade to 0.8.12

From: Neil O'Fix <[email-masked]>
Date: Sat, 7 Aug 2021 19:24:29 +0200

add py3-xdg dependency introduced in siglo 0.6.2
---
 community/siglo/APKBUILD | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/community/siglo/APKBUILD b/community/siglo/APKBUILD
index 0a731a0b4e..def2551b0d 100644
--- a/community/siglo/APKBUILD
+++ b/community/siglo/APKBUILD
@@ -1,13 +1,14 @@
 # Maintainer: Martijn Braam <[email-masked]>
 # Contributor: Martijn Braam <[email-masked]>
+# Contributor: Neil O'Fix <[email-masked]>
 pkgname=siglo
-pkgver=0.6.0
+pkgver=0.8.12
 pkgrel=0
 pkgdesc="GTK app to sync InfiniTime watch with PinePhone"
 url="https://github.com/alexr4535/siglo"
 arch="noarch"
 license="MPL-2.0"
-depends="python3 py3-gobject3 gtk+3.0 bluez bluez-btmgmt py3-dbus py3-gatt py3-requests"
+depends="python3 py3-gobject3 gtk+3.0 bluez bluez-btmgmt py3-dbus py3-gatt py3-requests py3-xdg"
 makedepends="glib-dev meson"
 source="https://github.com/alexr4535/siglo/archive/v$pkgver/siglo-v$pkgver.tar.gz"
 options="!check" # There's no testsuite
@@ -20,4 +21,6 @@ build() {
 package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
-sha512sums="238a8713e471abb8f1a954ae3d6ba68a77cf7603502fefe4f5d26fb8add3a13cc4a14f30f50cac2ce010906e4587c0ae147469ed50f7ba683b146161cd97528e  siglo-v0.6.0.tar.gz"
+sha512sums="
+07cb73f09281c857ed67f209c49f291cc25745f1dc8973961740b13a876c60514428bbcbb07df2e52cd76c74e4166fe75ac7b41aa818ac32a9cc62b603f4cfc6  siglo-v0.8.12.tar.gz
+"
-- 
2.20.1

---

From: Bart Ribbers <[email-masked]>
Date: Mon, 09 Aug 2021 10:17:52 -0000

Closing as duplicate of !24012

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24024#note_173325

---

From: Leo <[email-masked]>
Date: Sat, 04 Sep 2021 18:20:59 -0000

ping @MartijnBraam

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24024#note_178401

---

From: algitbot <[email-masked]>
Date: Mon, 04 Oct 2021 19:00:07 -0000

Sorry to bother you @mailinglist-bot,

but we've detected that this merge request hasn't seen any recent activity. If you need help or want to discuss your approach with developers you can ping `@MartijnBraam`. You can also ask on IRC on `#alpine-devel` on irc.oftc.net. If no further activity occurs in this MR, Alpine developers may close it in the future.

Thanks for your contribution.

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/24024#note_183661