Subject: [PATCH v4 0/3] Add hledger, hledger-ui, and hledger-web

From: Dhruvin Gandhi <[email-masked]>
Date: Tue, 14 Dec 2021 12:35:58 +0530

This version adds cabal.project.freeze file to all packages to make
sure the dependencies are locked.

Dhruvin Gandhi (3):
  testing/hledger: new aport
  testing/hledger-ui: new aport
  testing/hledger-web: new aport

 testing/hledger-ui/APKBUILD              |  42 +++
 testing/hledger-ui/cabal.project.freeze  | 191 ++++++++++++++
 testing/hledger-web/APKBUILD             |  42 +++
 testing/hledger-web/cabal.project.freeze | 321 +++++++++++++++++++++++
 testing/hledger/APKBUILD                 |  44 ++++
 testing/hledger/cabal.project.freeze     | 156 +++++++++++
 6 files changed, 796 insertions(+)
 create mode 100644 testing/hledger-ui/APKBUILD
 create mode 100644 testing/hledger-ui/cabal.project.freeze
 create mode 100644 testing/hledger-web/APKBUILD
 create mode 100644 testing/hledger-web/cabal.project.freeze
 create mode 100644 testing/hledger/APKBUILD
 create mode 100644 testing/hledger/cabal.project.freeze

-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Tue, 14 Dec 2021 12:36:00 +0530

---
 testing/hledger-ui/APKBUILD             |  42 ++++++
 testing/hledger-ui/cabal.project.freeze | 191 ++++++++++++++++++++++++
 2 files changed, 233 insertions(+)
 create mode 100644 testing/hledger-ui/APKBUILD
 create mode 100644 testing/hledger-ui/cabal.project.freeze

diff --git a/testing/hledger-ui/APKBUILD b/testing/hledger-ui/APKBUILD
new file mode 100644
index 0000000000..dfa7d154ab
--- /dev/null
+++ b/testing/hledger-ui/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=hledger-ui
+pkgver=1.24.1
+pkgrel=0
+pkgdesc="Curses-style terminal interface for the hledger accounting system"
+url="https://hledger.org/hledger-ui.html"
+arch="x86_64" # limited by ghc
+license="GPL-3.0-only"
+makedepends="ghc cabal libffi-dev ncurses-dev"
+subpackages="$pkgname-doc"
+source="https://hackage.haskell.org/package/hledger-ui-$pkgver/hledger-ui-$pkgver.tar.gz
+	cabal.project.freeze"
+
+export CABAL_DIR="$srcdir"/cabal
+
+prepare() {
+	default_prepare
+	cp "$srcdir"/cabal.project.freeze .
+}
+
+build() {
+	cabal update
+	cabal build --prefix=/usr --enable-relocatable
+}
+
+check() {
+	cabal test
+}
+
+package() {
+	local ghcver=$(ghc --version | cut -d " " -f 8)
+	install -Dm755 \
+		"dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
+		"$pkgdir"/usr/bin/$pkgname
+	install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="
+9a71ba18c76a477a12df34adb4d1d11e5a72769b14e27950ff675107faf210dbe9ee18d4e6bf13151789f73591e72b62fb7f3ea581a2ddff6457814d9220f4d4  hledger-ui-1.24.1.tar.gz
+a8c9d31b82ad69cf0ad7324186f3f9b49ee7400b8eb450ce8fa6f99da28c138982bf16b1f1d20bf9ef7380509ea273d1e913d8d0e87192aba69154891aeab1bc  cabal.project.freeze
+"
diff --git a/testing/hledger-ui/cabal.project.freeze b/testing/hledger-ui/cabal.project.freeze
new file mode 100644
index 0000000000..7b03fa243a
--- /dev/null
+++ b/testing/hledger-ui/cabal.project.freeze
@@ -0,0 +1,191 @@
+active-repositories: hackage.haskell.org:merge
+constraints: any.Cabal ==3.4.0.0,
+             any.Decimal ==0.5.2,
+             any.Diff ==0.4.0,
+             any.Glob ==0.10.2,
+             any.Only ==0.1,
+             any.QuickCheck ==2.14.2,
+             QuickCheck -old-random +templatehaskell,
+             any.StateVar ==1.2.2,
+             any.aeson ==1.5.6.0,
+             aeson -bytestring-builder -cffi -developer -fast,
+             any.aeson-pretty ==0.8.9,
+             aeson-pretty -lib-only,
+             any.ansi-terminal ==0.11.1,
+             ansi-terminal -example,
+             any.ansi-wl-pprint ==0.6.9,
+             ansi-wl-pprint -example,
+             any.array ==0.5.4.0,
+             any.assoc ==1.0.2,
+             any.async ==2.2.4,
+             async -bench,
+             any.attoparsec ==0.14.3,
+             attoparsec -developer,
+             any.base ==4.15.0.0,
+             any.base-compat ==0.12.1,
+             any.base-compat-batteries ==0.12.1,
+             any.base-orphans ==0.8.6,
+             any.bifunctors ==5.5.11,
+             bifunctors +semigroups +tagged,
+             any.binary ==0.8.8.0,
+             any.blaze-builder ==0.4.2.2,
+             any.blaze-html ==0.9.1.2,
+             any.blaze-markup ==0.8.2.8,
+             any.brick ==0.65,
+             brick -demos,
+             any.bytestring ==0.10.12.1,
+             any.cabal-doctest ==1.0.9,
+             any.call-stack ==0.4.0,
+             any.case-insensitive ==1.2.1.0,
+             any.cassava ==0.5.2.0,
+             cassava -bytestring--lt-0_10_4,
+             any.cassava-megaparsec ==2.0.4,
+             cassava-megaparsec -dev,
+             any.clock ==0.8.2,
+             clock -llvm,
+             any.cmdargs ==0.10.21,
+             cmdargs +quotation -testprog,
+             any.colour ==2.3.6,
+             any.comonad ==5.0.8,
+             comonad +containers +distributive +indexed-traversable,
+             any.config-ini ==0.2.4.0,
+             config-ini -enable-doctests,
+             any.constraints ==0.13.2,
+             any.containers ==0.6.4.1,
+             any.contravariant ==1.5.5,
+             contravariant +semigroups +statevar +tagged,
+             any.control-monad-free ==0.6.2,
+             any.csv ==0.1.2,
+             any.data-clist ==0.1.2.3,
+             any.data-default ==0.7.1.1,
+             any.data-default-class ==0.1.2.0,
+             any.data-default-instances-containers ==0.0.1,
+             any.data-default-instances-dlist ==0.0.1,
+             any.data-default-instances-old-locale ==0.0.1,
+             any.data-fix ==0.3.2,
+             any.deepseq ==1.4.5.0,
+             any.directory ==1.3.6.1,
+             any.distributive ==0.6.2.1,
+             distributive +semigroups +tagged,
+             any.dlist ==1.0,
+             dlist -werror,
+             any.doclayout ==0.3.1.1,
+             any.emojis ==0.1.2,
+             any.enclosed-exceptions ==1.0.3,
+             any.exceptions ==0.10.4,
+             any.extra ==1.7.10,
+             any.file-embed ==0.0.15.0,
+             any.filepath ==1.4.2.1,
+             any.fsnotify ==0.3.0.1,
+             any.ghc-bignum ==1.0,
+             any.ghc-boot-th ==9.0.1,
+             any.ghc-prim ==0.7.0,
+             any.githash ==0.1.6.2,
+             any.hashable ==1.3.5.0,
+             hashable +integer-gmp -random-initial-seed,
+             any.hashtables ==1.2.4.2,
+             hashtables -bounds-checking -debug -detailed-profiling -portable -sse42 +unsafe-tricks,
+             any.haskeline ==0.8.1.0,
+             any.hinotify ==0.4.1,
+             any.hledger ==1.24.1,
+             hledger +terminfo +threaded,
+             any.hledger-lib ==1.24.1,
+             hledger-ui +threaded,
+             any.html ==1.0.1.2,
+             any.indexed-traversable ==0.1.2,
+             any.integer-logarithms ==1.0.3.1,
+             integer-logarithms -check-bounds +integer-gmp,
+             any.lifted-async ==0.10.2.2,
+             any.lifted-base ==0.2.3.12,
+             any.lucid ==2.11.0,
+             any.math-functions ==0.3.4.2,
+             math-functions +system-erf +system-expm1,
+             any.megaparsec ==9.2.0,
+             megaparsec -dev,
+             any.microlens ==0.4.12.0,
+             any.microlens-ghc ==0.4.13.1,
+             any.microlens-mtl ==0.2.0.1,
+             any.microlens-platform ==0.4.2.1,
+             any.microlens-th ==0.4.3.10,
+             any.mmorph ==1.2.0,
+             any.monad-control ==1.0.3.1,
+             any.mtl ==2.2.2,
+             any.old-locale ==1.0.0.7,
+             any.optparse-applicative ==0.16.1.0,
+             optparse-applicative +process,
+             any.parallel ==3.2.2.0,
+             any.parsec ==3.1.14.0,
+             any.parser-combinators ==1.3.0,
+             parser-combinators -dev,
+             any.pretty ==1.1.3.6,
+             any.pretty-simple ==4.0.0.0,
+             pretty-simple -buildexample -buildexe,
+             any.prettyprinter ==1.7.1,
+             prettyprinter -buildreadme +text,
+             any.prettyprinter-ansi-terminal ==1.1.3,
+             any.primitive ==0.7.3.0,
+             any.process ==1.6.11.0,
+             any.random ==1.2.1,
+             any.regex-base ==0.94.0.2,
+             any.regex-tdfa ==1.3.1.1,
+             regex-tdfa -force-o2,
+             any.rts ==1.0,
+             any.safe ==0.3.19,
+             any.scientific ==0.3.7.0,
+             scientific -bytestring-builder -integer-simple,
+             any.shakespeare ==2.0.25,
+             shakespeare -test_coffee -test_export -test_roy,
+             any.shelly ==1.9.0,
+             shelly -build-examples -lifted,
+             any.split ==0.2.3.4,
+             any.splitmix ==0.1.0.4,
+             splitmix -optimised-mixer,
+             any.stm ==2.5.0.0,
+             any.strict ==0.4.0.1,
+             strict +assoc,
+             any.tabular ==0.2.2.8,
+             any.tagged ==0.8.6.1,
+             tagged +deepseq +transformers,
+             any.tasty ==1.4.2.1,
+             tasty +clock +unix,
+             any.tasty-hunit ==0.10.0.3,
+             any.template-haskell ==2.17.0.0,
+             any.temporary ==1.3,
+             any.terminfo ==0.4.1.4,
+             any.text ==1.2.4.1,
+             any.text-short ==0.1.4,
+             text-short -asserts,
+             any.text-zipper ==0.11,
+             any.th-abstraction ==0.4.3.0,
+             any.th-compat ==0.1.3,
+             any.th-lift ==0.8.2,
+             any.these ==1.1.1.1,
+             these +assoc,
+             any.time ==1.9.3,
+             any.time-compat ==1.9.6.1,
+             time-compat -old-locale,
+             any.timeit ==2.0,
+             any.transformers ==0.5.6.2,
+             any.transformers-base ==0.4.6,
+             transformers-base +orphaninstances,
+             any.transformers-compat ==0.7.1,
+             transformers-compat -five +five-three -four +generic-deriving +mtl -three -two,
+             any.type-equality ==1,
+             any.uglymemo ==0.1.0.1,
+             any.unbounded-delays ==0.1.1.1,
+             any.unix ==2.7.2.2,
+             any.unix-compat ==0.5.3,
+             unix-compat -old-time,
+             any.unordered-containers ==0.2.16.0,
+             unordered-containers -debug,
+             any.utf8-string ==1.0.2,
+             any.utility-ht ==0.0.16,
+             any.uuid-types ==1.0.5,
+             any.vector ==0.12.3.1,
+             vector +boundschecks -internalchecks -unsafechecks -wall,
+             any.vty ==5.33,
+             any.wcwidth ==0.0.2,
+             wcwidth -cli +split-base,
+             any.wizards ==1.0.3,
+             any.word-wrap ==0.5
+index-state: hackage.haskell.org 2021-12-14T06:08:15Z
-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Tue, 14 Dec 2021 12:35:59 +0530

---
 testing/hledger/APKBUILD             |  44 ++++++++
 testing/hledger/cabal.project.freeze | 156 +++++++++++++++++++++++++++
 2 files changed, 200 insertions(+)
 create mode 100644 testing/hledger/APKBUILD
 create mode 100644 testing/hledger/cabal.project.freeze

diff --git a/testing/hledger/APKBUILD b/testing/hledger/APKBUILD
new file mode 100644
index 0000000000..8eb95959f1
--- /dev/null
+++ b/testing/hledger/APKBUILD
@@ -0,0 +1,44 @@
+pkgname=hledger
+pkgdesc="Command-line interface for the hledger accounting system"
+url="https://hledger.org/hledger.html"
+subpackages="$pkgname-doc $pkgname-bash-completion"
+source="https://hackage.haskell.org/package/hledger-$pkgver/hledger-$pkgver.tar.gz
+	install -Dm644 shell-completion/$pkgname-completion.bash \
+		"$pkgdir"/usr/share/bash-completion/completions/$pkgname
+0941258f7c6f699967261eaf9e20c1f81f6694b8f559ac1e729f37cff64dce3b787447f69c222115437318e8ccd6c4273e52befa41b3419f8fb4cc131c7fcdf7  hledger-1.24.1.tar.gz
+fc86ff74ad6a01e844ffba7072ce23c705c9e2c2be81542687d1295ec33fa892ba8d2b1a341eaac3afae27d9bdb84cb523c9c696581c9ba8d6a99a8a62a5e282  cabal.project.freeze
diff --git a/testing/hledger/cabal.project.freeze b/testing/hledger/cabal.project.freeze
index 0000000000..c9a8df42d4
+++ b/testing/hledger/cabal.project.freeze
@@ -0,0 +1,156 @@
+             any.wizards ==1.0.3

---

From: Dhruvin Gandhi <[email-masked]>
Date: Tue, 14 Dec 2021 12:36:01 +0530

---
 2 files changed, 363 insertions(+)

diff --git a/testing/hledger-web/APKBUILD b/testing/hledger-web/APKBUILD
new file mode 100644
index 0000000000..42781e0ecb
--- /dev/null
+++ b/testing/hledger-web/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=hledger-web
+pkgver=1.24.1
+pkgrel=0
+pkgdesc="Web interface for the hledger accounting system"
+url="https://hledger.org/hledger-web.html"
+arch="x86_64" # limited by ghc
+license="GPL-3.0-only"
+makedepends="ghc cabal libffi-dev ncurses-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://hackage.haskell.org/package/hledger-web-$pkgver/hledger-web-$pkgver.tar.gz
+	cabal.project.freeze"
+
+export CABAL_DIR="$srcdir"/cabal
+
+prepare() {
+	default_prepare
+	cp "$srcdir"/cabal.project.freeze .
+}
+
+build() {
+	cabal update
+	cabal build --prefix=/usr --enable-relocatable
+}
+
+check() {
+	cabal test
+}
+
+package() {
+	local ghcver=$(ghc --version | cut -d " " -f 8)
+	install -Dm755 \
+		"dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
+		"$pkgdir"/usr/bin/$pkgname
+	install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="
+49e6292faad4a1311d1af950a98a546e6ec61f5dfa97539e62a806e63bbd43351861ab4c45f8eb7284e98367fb92e206a217e998c6572ca8b2f37e91bb93daaf  hledger-web-1.24.1.tar.gz
+4e9341d76148248016abb82bf090f2bd9b93d698ddc4309625b04ca2fc00d918038f8c7c204a5ef8580b1f852b70d8f684988d494935d80dd84f4b573f9ea38b  cabal.project.freeze
+"
diff --git a/testing/hledger-web/cabal.project.freeze b/testing/hledger-web/cabal.project.freeze
new file mode 100644
index 0000000000..2889c92d7c
--- /dev/null
+++ b/testing/hledger-web/cabal.project.freeze
@@ -0,0 +1,321 @@
+active-repositories: hackage.haskell.org:merge
+constraints: any.Cabal ==3.4.0.0,
+             any.Decimal ==0.5.2,
+             any.Diff ==0.4.0,
+             any.Glob ==0.10.2,
+             any.HUnit ==1.6.2.0,
+             any.Only ==0.1,
+             any.QuickCheck ==2.14.2,
+             QuickCheck -old-random +templatehaskell,
+             any.aeson ==1.5.6.0,
+             aeson -bytestring-builder -cffi -developer -fast,
+             any.aeson-pretty ==0.8.9,
+             aeson-pretty -lib-only,
+             any.alex ==3.2.6,
+             alex +small_base,
+             any.ansi-terminal ==0.11.1,
+             ansi-terminal -example,
+             any.ansi-wl-pprint ==0.6.9,
+             ansi-wl-pprint -example,
+             any.appar ==0.1.8,
+             any.array ==0.5.4.0,
+             any.asn1-encoding ==0.9.6,
+             any.asn1-parse ==0.9.5,
+             any.asn1-types ==0.3.4,
+             any.assoc ==1.0.2,
+             any.async ==2.2.4,
+             async -bench,
+             any.attoparsec ==0.14.3,
+             attoparsec -developer,
+             any.attoparsec-iso8601 ==1.0.2.0,
+             attoparsec-iso8601 -developer -fast,
+             any.auto-update ==0.1.6,
+             any.base ==4.15.0.0,
+             any.base-compat ==0.12.1,
+             any.base-compat-batteries ==0.12.1,
+             any.base-orphans ==0.8.6,
+             any.base-unicode-symbols ==0.2.4.2,
+             base-unicode-symbols +base-4-8 -old-base,
+             any.base64 ==0.4.2.3,
+             any.base64-bytestring ==1.2.1.0,
+             any.basement ==0.0.12,
+             any.bifunctors ==5.5.11,
+             bifunctors +semigroups +tagged,
+             any.binary ==0.8.8.0,
+             any.blaze-builder ==0.4.2.2,
+             any.blaze-html ==0.9.1.2,
+             any.blaze-markup ==0.8.2.8,
+             any.bsb-http-chunked ==0.0.0.4,
+             any.byteable ==0.1.1,
+             any.byteorder ==1.0.4,
+             any.bytestring ==0.10.12.1,
+             any.cabal-doctest ==1.0.9,
+             any.call-stack ==0.4.0,
+             any.case-insensitive ==1.2.1.0,
+             any.cassava ==0.5.2.0,
+             cassava -bytestring--lt-0_10_4,
+             any.cassava-megaparsec ==2.0.4,
+             cassava-megaparsec -dev,
+             any.cereal ==0.5.8.2,
+             cereal -bytestring-builder,
+             any.cipher-aes ==0.2.11,
+             cipher-aes +support_aesni,
+             any.clientsession ==0.9.1.2,
+             clientsession -test,
+             any.clock ==0.8.2,
+             clock -llvm,
+             any.cmdargs ==0.10.21,
+             cmdargs +quotation -testprog,
+             any.colour ==2.3.6,
+             any.comonad ==5.0.8,
+             comonad +containers +distributive +indexed-traversable,
+             any.conduit ==1.3.4.2,
+             any.conduit-extra ==1.3.5,
+             any.connection ==0.3.1,
+             any.containers ==0.6.4.1,
+             any.control-monad-free ==0.6.2,
+             any.cookie ==0.4.5,
+             any.cprng-aes ==0.6.1,
+             any.crypto-api ==0.13.3,
+             crypto-api -all_cpolys,
+             any.crypto-cipher-types ==0.0.9,
+             any.crypto-random ==0.0.9,
+             any.cryptonite ==0.29,
+             cryptonite -check_alignment +integer-gmp -old_toolchain_inliner +support_aesni +support_deepseq -support_pclmuldq +support_rdrand -support_sse +use_target_attributes,
+             any.cryptonite-conduit ==0.2.2,
+             any.css-text ==0.1.3.0,
+             any.csv ==0.1.2,
+             any.data-default ==0.7.1.1,
+             any.data-default-class ==0.1.2.0,
+             any.data-default-instances-containers ==0.0.1,
+             any.data-default-instances-dlist ==0.0.1,
+             any.data-default-instances-old-locale ==0.0.1,
+             any.data-fix ==0.3.2,
+             any.deepseq ==1.4.5.0,
+             any.directory ==1.3.6.1,
+             any.distributive ==0.6.2.1,
+             distributive +semigroups +tagged,
+             any.dlist ==1.0,
+             dlist -werror,
+             any.doclayout ==0.3.1.1,
+             any.easy-file ==0.2.2,
+             any.email-validate ==2.3.2.15,
+             any.emojis ==0.1.2,
+             any.entropy ==0.4.1.7,
+             entropy -halvm,
+             any.exceptions ==0.10.4,
+             any.extra ==1.7.10,
+             any.fast-logger ==3.1.0,
+             any.file-embed ==0.0.15.0,
+             any.filepath ==1.4.2.1,
+             any.ghc ==9.0.1,
+             any.ghc-bignum ==1.0,
+             any.ghc-boot ==9.0.1,
+             any.ghc-boot-th ==9.0.1,
+             any.ghc-byteorder ==4.11.0.0.10,
+             any.ghc-heap ==9.0.1,
+             any.ghc-prim ==0.7.0,
+             any.ghci ==9.0.1,
+             any.githash ==0.1.6.2,
+             any.happy ==1.20.0,
+             any.hashable ==1.3.5.0,
+             hashable +integer-gmp -random-initial-seed,
+             any.hashtables ==1.2.4.2,
+             hashtables -bounds-checking -debug -detailed-profiling -portable -sse42 +unsafe-tricks,
+             any.haskeline ==0.8.1.0,
+             any.haskell-lexer ==1.1,
+             any.hjsmin ==0.2.0.4,
+             any.hledger ==1.24.1,
+             hledger +terminfo +threaded,
+             any.hledger-lib ==1.24.1,
+             hledger-web -dev -library-only +threaded,
+             any.hourglass ==0.2.12,
+             any.hpc ==0.6.1.0,
+             any.hsc2hs ==0.68.8,
+             hsc2hs -in-ghc-tree,
+             any.hspec ==2.9.4,
+             any.hspec-core ==2.9.4,
+             any.hspec-discover ==2.9.4,
+             any.hspec-expectations ==0.8.2,
+             any.html ==1.0.1.2,
+             any.html-conduit ==1.3.2.2,
+             any.http-api-data ==0.4.3,
+             http-api-data -use-text-show,
+             any.http-client ==0.7.9,
+             http-client +network-uri,
+             any.http-client-tls ==0.3.5.3,
+             any.http-conduit ==2.3.8,
+             http-conduit +aeson,
+             any.http-date ==0.0.11,
+             any.http-types ==0.12.3,
+             any.http2 ==3.0.2,
+             http2 -devel -doc -h2spec,
+             any.indexed-traversable ==0.1.2,
+             any.integer-gmp ==1.1,
+             any.integer-logarithms ==1.0.3.1,
+             integer-logarithms -check-bounds +integer-gmp,
+             any.iproute ==1.7.12,
+             any.language-javascript ==0.7.1.0,
+             any.libyaml ==0.1.2,
+             libyaml -no-unicode -system-libyaml,
+             any.lift-type ==0.1.0.1,
+             any.lifted-base ==0.2.3.12,
+             any.lucid ==2.11.0,
+             any.math-functions ==0.3.4.2,
+             math-functions +system-erf +system-expm1,
+             any.megaparsec ==9.2.0,
+             megaparsec -dev,
+             any.memory ==0.16.0,
+             memory +support_basement +support_bytestring +support_deepseq +support_foundation,
+             any.microlens ==0.4.12.0,
+             any.microlens-th ==0.4.3.10,
+             any.mime-types ==0.1.0.9,
+             any.mmorph ==1.2.0,
+             any.monad-control ==1.0.3.1,
+             any.monad-logger ==0.3.36,
+             monad-logger +template_haskell,
+             any.monad-loops ==0.4.3,
+             monad-loops +base4,
+             any.mono-traversable ==1.0.15.3,
+             any.mtl ==2.2.2,
+             any.network ==3.1.2.5,
+             network -devel,
+             any.network-byte-order ==0.1.6,
+             any.network-uri ==2.6.4.1,
+             any.old-locale ==1.0.0.7,
+             any.old-time ==1.1.0.3,
+             any.optparse-applicative ==0.16.1.0,
+             optparse-applicative +process,
+             any.parsec ==3.1.14.0,
+             any.parser-combinators ==1.3.0,
+             parser-combinators -dev,
+             any.path-pieces ==0.2.1,
+             any.pem ==0.2.4,
+             any.persistent ==2.13.2.1,
+             any.persistent-template ==2.12.0.0,
+             any.pretty ==1.1.3.6,
+             any.pretty-show ==1.10,
+             any.pretty-simple ==4.0.0.0,
+             pretty-simple -buildexample -buildexe,
+             any.prettyprinter ==1.7.1,
+             prettyprinter -buildreadme +text,
+             any.prettyprinter-ansi-terminal ==1.1.3,
+             any.primitive ==0.7.3.0,
+             any.process ==1.6.11.0,
+             any.psqueues ==0.2.7.3,
+             any.quickcheck-io ==0.2.0,
+             any.random ==1.2.1,
+             any.regex-base ==0.94.0.2,
+             any.regex-tdfa ==1.3.1.1,
+             regex-tdfa -force-o2,
+             any.resource-pool ==0.2.3.2,
+             resource-pool -developer,
+             any.resourcet ==1.2.4.3,
+             any.rts ==1.0,
+             any.safe ==0.3.19,
+             any.scientific ==0.3.7.0,
+             scientific -bytestring-builder -integer-simple,
+             any.securemem ==0.1.10,
+             any.setenv ==0.1.1.3,
+             any.shakespeare ==2.0.25,
+             shakespeare -test_coffee -test_export -test_roy,
+             any.silently ==1.2.5.2,
+             any.simple-sendfile ==0.2.30,
+             simple-sendfile +allow-bsd,
+             any.skein ==1.0.9.4,
+             skein -big-endian -force-endianness -reference,
+             any.socks ==0.6.1,
+             any.split ==0.2.3.4,
+             any.splitmix ==0.1.0.4,
+             splitmix -optimised-mixer,
+             any.stm ==2.5.0.0,
+             any.stm-chans ==3.0.0.6,
+             any.streaming-commons ==0.2.2.3,
+             streaming-commons -use-bytestring-builder,
+             any.strict ==0.4.0.1,
+             strict +assoc,
+             any.tabular ==0.2.2.8,
+             any.tagged ==0.8.6.1,
+             tagged +deepseq +transformers,
+             any.tagsoup ==0.14.8,
+             any.tasty ==1.4.2.1,
+             tasty +clock +unix,
+             any.tasty-hunit ==0.10.0.3,
+             any.template-haskell ==2.17.0.0,
+             any.temporary ==1.3,
+             any.terminfo ==0.4.1.4,
+             any.text ==1.2.4.1,
+             any.text-short ==0.1.4,
+             text-short -asserts,
+             any.tf-random ==0.5,
+             any.th-abstraction ==0.4.3.0,
+             any.th-compat ==0.1.3,
+             any.th-lift ==0.8.2,
+             any.th-lift-instances ==0.1.18,
+             any.these ==1.1.1.1,
+             these +assoc,
+             any.time ==1.9.3,
+             any.time-compat ==1.9.6.1,
+             time-compat -old-locale,
+             any.time-manager ==0.0.0,
+             any.timeit ==2.0,
+             any.tls ==1.5.5,
+             tls +compat -hans +network,
+             any.transformers ==0.5.6.2,
+             any.transformers-base ==0.4.6,
+             transformers-base +orphaninstances,
+             any.transformers-compat ==0.7.1,
+             transformers-compat -five +five-three -four +generic-deriving +mtl -three -two,
+             any.typed-process ==0.2.8.0,
+             any.uglymemo ==0.1.0.1,
+             any.unbounded-delays ==0.1.1.1,
+             any.unix ==2.7.2.2,
+             any.unix-compat ==0.5.3,
+             unix-compat -old-time,
+             any.unix-time ==0.4.7,
+             any.unliftio ==0.2.20,
+             any.unliftio-core ==0.2.0.1,
+             any.unordered-containers ==0.2.16.0,
+             unordered-containers -debug,
+             any.utf8-string ==1.0.2,
+             any.utility-ht ==0.0.16,
+             any.uuid-types ==1.0.5,
+             any.vault ==0.3.1.5,
+             vault +useghc,
+             any.vector ==0.12.3.1,
+             vector +boundschecks -internalchecks -unsafechecks -wall,
+             any.vector-algorithms ==0.8.0.4,
+             vector-algorithms +bench +boundschecks -internalchecks -llvm +properties -unsafechecks,
+             any.wai ==3.2.3,
+             any.wai-app-static ==3.1.7.2,
+             wai-app-static -print,
+             any.wai-cors ==0.2.7,
+             any.wai-extra ==3.1.7,
+             wai-extra -build-example,
+             any.wai-handler-launch ==3.0.3.1,
+             any.wai-logger ==2.3.7,
+             any.warp ==3.3.18,
+             warp +allow-sendfilefd -network-bytestring -warp-debug,
+             any.wcwidth ==0.0.2,
+             wcwidth -cli +split-base,
+             any.wizards ==1.0.3,
+             any.word8 ==0.1.3,
+             any.x509 ==1.7.5,
+             any.x509-store ==1.6.7,
+             any.x509-system ==1.6.6,
+             any.x509-validation ==1.6.11,
+             any.xml-conduit ==1.9.1.1,
+             any.xml-types ==0.3.8,
+             any.xss-sanitize ==0.3.7,
+             any.yaml ==0.11.7.0,
+             yaml +no-examples +no-exe,
+             any.yesod ==1.6.1.2,
+             any.yesod-core ==1.6.21.0,
+             any.yesod-form ==1.7.0,
+             yesod-form +network-uri,
+             any.yesod-persistent ==1.6.0.7,
+             any.yesod-static ==1.6.1.0,
+             any.yesod-test ==1.6.12,
+             any.zlib ==0.6.2.3,
+             zlib -bundled-c-zlib -non-blocking-ffi -pkg-config
+index-state: hackage.haskell.org 2021-12-13T00:20:07Z
-- 
2.34.1

---

From: "Dhruvin Gandhi" <[email-masked]>
Date: Tue, 14 Dec 2021 13:07:05 +0530

Well, as Drew mentioned earlier in a private conversation, this patch
won't create MR due to known webhook limitation. From now on I'll have
to create MR(s) directly for large patches.