Subject: [PATCH] testing/9base: fix troff directory

From: Elaina Thompson <[email-masked]>
Date: Mon, 27 Dec 2021 13:09:34 -0800

as is, the troff directory gets placed in the incorrect place due to mkdir
already creating the directory. this should fix that behavior.

Ps: first patch (anywhere) apologies if anything is wrong or sloppy
---
 testing/9base/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/9base/APKBUILD b/testing/9base/APKBUILD
index 9d77b93e..3e713d00 100644
--- a/testing/9base/APKBUILD
+++ b/testing/9base/APKBUILD
@@ -47,7 +47,7 @@ troff() {
 	cd "$pkgdir"
 	mkdir -p "$subpkgdir/usr/lib/9base/bin"
 	mv "$pkgdir/usr/lib/9base/bin/troff" "$subpkgdir/usr/lib/9base/bin/troff"
-	mkdir -p "$subpkgdir/usr/lib/9base/lib/troff"
+	mkdir -p "$subpkgdir/usr/lib/9base/lib"
 	mv "$pkgdir/usr/lib/9base/lib/troff" "$subpkgdir/usr/lib/9base/lib/troff"
 }
 
-- 
2.34.1

---

From: algitbot <[email-masked]>
Date: Wed, 26 Jan 2022 22:00:04 -0000

Sorry to bother you @mailinglist-bot,

but we've detected that this merge request hasn't seen any recent activity. If you need help or want to discuss your approach with developers you can ping `@xihh87`. You can also ask on IRC on `#alpine-devel` on irc.oftc.net. If no further activity occurs in this MR, Alpine developers may close it in the future.

Thanks for your contribution.

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/28920#note_209527

---

From: alice <[email-masked]>
Date: Thu, 27 Jan 2022 01:30:27 -0000

this needed to bump pkgrel to actually affect the package

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/28920#note_209665

---

From: mailinglist-bot <[email-masked]>
Date: Thu, 27 Jan 2022 18:09:54 -0000

Elaina Thompson <[email-masked]> replied via email:

```

Ps: first patch (anywhere) apologies if anything is wrong or sloppy
---
Changes v1 -> v2
	- increment pkgrel
	- remove quotes in pkgname to resolve linting error

 testing/9base/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/9base/APKBUILD b/testing/9base/APKBUILD
index 9d77b93e46..f5ab3d70ad 100644
--- a/testing/9base/APKBUILD
+++ b/testing/9base/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Joshua Haase <[email-masked]>
 # Maintainer: Joshua Haase <[email-masked]>
-pkgname="9base"
+pkgname=9base
 pkgver=6
-pkgrel=0
+pkgrel=1
 pkgdesc="A port of various Plan 9 tools for Unix."
 url="https://tools.suckless.org/9base/"
 arch="all !armv7 !armhf !aarch64 !mips !mips64" # Needs arch specific config.mk
@@ -47,7 +47,7 @@ troff() {
 	cd "$pkgdir"
 	mkdir -p "$subpkgdir/usr/lib/9base/bin"
 	mv "$pkgdir/usr/lib/9base/bin/troff" "$subpkgdir/usr/lib/9base/bin/troff"
-	mkdir -p "$subpkgdir/usr/lib/9base/lib/troff"
+	mkdir -p "$subpkgdir/usr/lib/9base/lib"
 	mv "$pkgdir/usr/lib/9base/lib/troff" "$subpkgdir/usr/lib/9base/lib/troff"
 }
 
-- 
2.34.1

```

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/28920#note_209925

---

From: alice <[email-masked]>
Date: Thu, 27 Jan 2022 18:16:37 -0000

ah, that doesn't actually work- you need to send a new patch that will open a new merge request.  
(or just make a gitlab account and use the normal merge flow)

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/28920#note_209930

---

From: Elaina Thompson <[email-masked]>
Date: Thu, 27 Jan 2022 10:00:33 -0800

-- 
2.34.1