Subject: [PATCH] community/prometheus: upgrade to 2.35.0

From: Drew DeVault <[email-masked]>
Date: Fri, 22 Apr 2022 10:46:06 +0200

---
 community/prometheus/APKBUILD | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/community/prometheus/APKBUILD b/community/prometheus/APKBUILD
index a1066b302c..eb28d59117 100644
--- a/community/prometheus/APKBUILD
+++ b/community/prometheus/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Drew DeVault <[email-masked]>
 pkgname=prometheus
-pkgver=2.34.0
-pkgrel=1
+pkgver=2.35.0
+pkgrel=0
 pkgdesc="The Prometheus monitoring system and time series database"
 url="https://github.com/prometheus/prometheus"
 arch="all !riscv64" # npm
@@ -38,6 +38,7 @@ build() {
 	fi
 
 	make assets
+	make build
 	go mod vendor
 	go build \
 		-trimpath \
@@ -83,7 +84,7 @@ package() {
 }
 
 sha512sums="
-98e5c47e5630ce81cc59f3ea267c9abd49616eeb7d991e1c148eebe2451970067eaa72faa3f31a3c29dc543879acaf9898c49e31459a86afe01cb83c33902caa  prometheus-2.34.0.tar.gz
+7c5cf63ab976f9c265d5b33fdb8045092f865b1bd540b70c4a0d8b3328381e7b19d5198e60213836988850caaab9885db2a4e544bc2551b848077840076518f8  prometheus-2.35.0.tar.gz
 eb0cebe41782f90079f367832f7c9efa18b99df410506b65b2e0b11fa05f8f2956f68c0fca836664729d50b85fc969a96e99e1d32012fe3c655cddc0b16a7561  prometheus.initd
 24b34e586238d5b331639aa5c43b6a927692f251af2cea2787335eab30d2fc7d46975059595db4697ae0dc1d35b5e23cfc4e4b2e424442c209a05283ca22a239  prometheus.confd
 "

base-commit: 26122df9124b4363df88cffd2db929c8869e8cb2
prerequisite-patch-id: 941711984b73b51577fa4c00aeba004c06a6ddc3
prerequisite-patch-id: c616a10d78430421fd27961adb202c1846e9776a
prerequisite-patch-id: d6c67b207203e99a143162011c6efc89ce956d16
prerequisite-patch-id: 8998f9c236fd950b832692b121466f5ec661ec63
prerequisite-patch-id: 77d9be85e468b0c35f1f3f961d0f8a2ae9ab0937
prerequisite-patch-id: b07dedc2e3eae296e98d7e0dfa0565317a9cbb1c
prerequisite-patch-id: 1a1850807567fb69460e4819528d3e6efa09e8d1
-- 
2.35.2

---

From: Alpine Linux <[email-masked]>
Date: Fri, 22 Apr 2022 08:52:50 -0000

Hi!

We received your patch, but we were unable to apply it to the upstream
GitLab repository. Did you rebase?