Subject: [PATCH] testing/py3-googletrans: patched client.py

From: Eloi Torrents <[email-masked]>
Date: Fri, 13 May 2022 11:50:25 +0200

---
 testing/py3-googletrans/APKBUILD     |  8 ++++++--
 testing/py3-googletrans/client.patch | 12 ++++++++++++
 2 files changed, 18 insertions(+), 2 deletions(-)
 create mode 100644 testing/py3-googletrans/client.patch

diff --git a/testing/py3-googletrans/APKBUILD b/testing/py3-googletrans/APKBUILD
index 51f6aca119..e0a00e9a5e 100644
--- a/testing/py3-googletrans/APKBUILD
+++ b/testing/py3-googletrans/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Eloi Torrents <[email-masked]>
 pkgname=py3-googletrans
 pkgver=3.0.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Free Google Translate API for Python"
 url="https://py-googletrans.readthedocs.io/en/latest/"
 arch="noarch !armhf !ppc64le" # missing py3-httpx
@@ -13,7 +13,10 @@ depends="
 	"
 makedepends="py3-setuptools"
 checkdepends="py3-pytest"
-source="https://pypi.io/packages/source/g/googletrans/googletrans-$pkgver.tar.gz"
+source="
+	https://pypi.io/packages/source/g/googletrans/googletrans-$pkgver.tar.gz
+	client.patch
+	"
 builddir="$srcdir/googletrans-$pkgver"
 
 build() {
@@ -26,4 +29,5 @@ package() {
 
 sha512sums="
 1a31c52e1fc72ab45131c95ff3649d1d679e3c082adc2b43ba1e5d9bbc57bf740c9e14575c6416e406e6e6e1796cac57330fbb1a639ad96841464e042ef70981  googletrans-3.0.0.tar.gz
+00eaccaa3da8ebc7d18cde5970683667871fe849b510ce7609ee2b7a3c84d4fa60e89a51104be3b90f6fcff79580e6c438a5411a94fa7e846fcab6061409a062  client.patch
 "
diff --git a/testing/py3-googletrans/client.patch b/testing/py3-googletrans/client.patch
new file mode 100644
index 0000000000..5f1c125627
--- /dev/null
+++ b/testing/py3-googletrans/client.patch
@@ -0,0 +1,12 @@
+--- a/googletrans/client.py
++++ b/googletrans/client.py
+@@ -52,7 +52,7 @@
+ 
+     def __init__(self, service_urls=None, user_agent=DEFAULT_USER_AGENT,
+                  raise_exception=DEFAULT_RAISE_EXCEPTION,
+-                 proxies: typing.Dict[str, httpcore.SyncHTTPTransport] = None, timeout: Timeout = None):
++                 proxies: typing.Dict[str, httpcore.HTTPProxy] = None, timeout: Timeout = None):
+ 
+         self.client = httpx.Client()
+         if proxies is not None:  # pragma: nocover
+
-- 
2.36.1

---

From: Alpine Linux <[email-masked]>
Date: Fri, 13 May 2022 09:55:13 -0000

Hi!

We received your patch, but we were unable to apply it to the upstream
GitLab repository. Did you rebase?