Subject: [PATCH] community/os-prober: add missing blkid and grub-mount dependencies

From: Caleb Malchik <[email-masked]>
Date: Sun, 19 Mar 2023 18:55:51 -0400

From: Peter Shkenev <[email-masked]>

os-prober is unable to detect other operating systems without
grub-mount. Also, it uses blkid features that are unsupported by busybox
blkid.

(cherry picked from commit 911d58dc60edb8d2f8f27776e6c978beb273fdc5)
---
 community/os-prober/APKBUILD | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/community/os-prober/APKBUILD b/community/os-prober/APKBUILD
index 60557b1efdd..c1d0f589138 100644
--- a/community/os-prober/APKBUILD
+++ b/community/os-prober/APKBUILD
@@ -2,10 +2,11 @@
 # Maintainer: Bart Ribbers <[email-masked]>
 pkgname=os-prober
 pkgver=1.81
-pkgrel=0
+pkgrel=1
 pkgdesc="Utility to detect other OSes on a set of drives"
 url="https://joeyh.name/code/os-prober/"
-arch="all"
+arch="all !s390x" # grub-mount does not support s390x
+depends="grub-mount blkid"
 license="GPL-3.0-only"
 source="https://deb.debian.org/debian/pool/main/o/os-prober/os-prober_$pkgver.tar.xz"
 options="!check" # No tests
-- 
2.38.4

---

From: Caleb Malchik <[email-masked]>
Date: Sun, 19 Mar 2023 19:40:02 -0400

This patch is meant to be applied to the 3.17-stable branch, backporting
a fix from edge.

Please let me know if there's a better way to do this; I thought the
branch would show up in the email generated by git.

-- Caleb

---

From: Kevin Daudt <[email-masked]>
Date: Tue, 21 Mar 2023 11:56:37 +0000

> +++ b/community/os-prober/APKBUILD

This was backported through
https://gitlab.alpinelinux.org/alpine/aports/-/commit/75681e04170c781ff1c2542acde04330f353a8ea