Subject: [alpine-aports] patch for update-pvgrub

From: Bastien Durel <[email-masked]>
Date: Wed, 22 May 2019 09:58:55 +0200

Hello,

There is a painful bug in update-pvgrub that makes my VMs unbootable
each time I install a new kernel : it leads to an unparsable menu.lst
file

Here is the patch that correct it

Regards,

-- 
Bastien
From b15ad67567b9d222db0aae6d917010f844b9b72b Mon Sep 17 00:00:00 2001
From: Bastien Durel <[email-masked]>
Date: Thu, 20 Apr 2017 16:15:59 +0200
Subject: [PATCH] add real timeout to grub config file

as $rtimeout is undefined, config file ends with
  timeout
line, which makes pvgrub fail on int parsing
---
 main/compat-pvgrub/update-pvgrub | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/compat-pvgrub/update-pvgrub b/main/compat-pvgrub/update-pvgrub
index 56594a337b..7625d1d923 100755
--- a/main/compat-pvgrub/update-pvgrub
+++ b/main/compat-pvgrub/update-pvgrub
@@ -70,7 +70,7 @@ echo "default 0" >> $conf.new
 if [ "$hidden" = "1" ]; then
 	echo "hiddenmenu" >> $conf.new
 fi
-echo "timeout $rtimeout" >> $conf.new
+echo "timeout $timeout" >> $conf.new
 
 lst=0
 
-- 
2.21.0

---

From: Kevin Daudt <[email-masked]>
Date: Mon, 28 Oct 2019 20:30:23 +0100

> Here is the patch that correct it

Hello Bastien,

I noticed this was not applied yet (and another pvgrub patch was
provided as well, so I applied this patch.

Kind regards, Kevin.