Subject: [alpine-aports] [PATCH] testing/s-nail: update to v14.9.8

From: Steffen Nurpmeso <[email-masked]>
Date: Tue, 06 Mar 2018 00:11:54 +0100

---
 testing/s-nail/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/s-nail/APKBUILD b/testing/s-nail/APKBUILD
index bddd67ef..0dbba71f 100644
--- a/testing/s-nail/APKBUILD
+++ b/testing/s-nail/APKBUILD
@@ -2,7 +2,7 @@
 # Contributor: Ivan Tham <[email-masked]>
 # Maintainer: Ivan Tham <[email-masked]>
 pkgname=s-nail
-pkgver=14.9.6
+pkgver=14.9.8
 pkgrel=0
 pkgdesc="SysV mail/BSD Mail/POSIX mailx: send and receive Internet mail"
 url="https://www.sdaoden.eu/code.html#s-mailx"
@@ -31,7 +31,7 @@ build() {
 		VAL_SYSCONFDIR=/etc \
 		OPT_AUTOCC=no \
 		config &&
-	make build # XXX unite with config in v14.9.7
+	make build # XXX unite with config in v14.9.9
 }
 
 check() {
@@ -46,4 +46,4 @@ package() {
 	install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
 }
 
-sha512sums="3f9e5007b3a831c2f57148e8a4344cf08b9e625e04c50adc5e3cce90a466f417c3a7336e35f928680e2e97b4543cdf31a1d729ea5a880075c70d463e56fbb792  s-nail-14.9.6.tar.xz"
+sha512sums="f01e4355a94ec5613a67f95a12e05a106ad92808ee3d46d96b0ad6dbec98b64896ef19070eb3d8f712bbceb6f87589876bc96d64f30aced7085041d3e1a5218a  s-nail-14.9.8.tar.xz"
-- 
2.16.2

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Tue, 06 Mar 2018 01:02:59 +0100

Hi.

I justed noted it, but my dev machine is behind somewhat.
I get a reproducable crash with "apk check" in
t_behave_xxxheads_rfc2047-8.  This actually happens in
EVP_cleanup().  I cannot get that with gcc (but have not tried
heavily), only with clang.  Flags:

  #?0[steffen@essex s-nail]$ abuild check
  make[1]: Entering directory '/home/steffen/sec.arena/packwork.git/abuild-pkg/testing/s-nail/src/s-nail-14.9.8'
  clang -DNDEBUG -O1 -g -I./ -I/usr/include   -c ./xssl.c
  clang -Wl,--as-needed -o mail accmacvar.o attachment.o auxlily.o cmd-cnd.o cmd-folder.o cmd-headers.o cmd-message.o cmd-misc.o cmd-resend.o cmd-tab.o cmd-write.o
   collect.o colour.o dotlock.o edit.o filter.o fio.o folder.o go.o head.o ignore.o imap-search.o maildir.o main.o memory.o message.o mime-enc.o mime-param.o mime-
  parse.o mime-types.o mime.o nam-a-grp.o obs-imap-cache.o obs-imap.o obs-lzw.o path.o pop3.o popen.o quit.o send.o sendout.o shexp.o signal.o smtp.o socket.o spam
  .o ssl.o strings.o termcap.o thread.o tty.o ui-str.o urlcrecry.o xssl.o -L/lib -L/usr/lib  -lssl -lcrypto -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lidn -lcurse
  s             
     text    data     bss     dec     hex filename
   647086   15714   24384  687184   a7c50 mail

And then (heavily instrumented of course):

  make[1]: Entering directory '/home/steffen/sec.arena/packwork.git/abuild-pkg/testing/s-nail/src/s-nail-14.9.8'
  /bin/sh ./cc-test.sh --check-only ./mail
[..]
  [t_behave_xxxheads_rfc2047]
  reproducible_build: P(seudo)R(andomNumber)G(enerator): *SSL RAND_*
  >./go.c 1237
  reproducible_build: READ 5 bytes <reply>
  >./go.c 274
  EINS
  ZWEI
  DREI
  VIER
  FUENF
  1
  reproducible_build: >>> MTA: ./.tsendmail.sh, arguments: sendmail -i -- [email-masked] [email-masked]
  reproducible_build: >>> Date: Wed, 02 Oct 1996 01:50:07 +0000
  reproducible_build: >>> To: =?iso-8859-1?Q?z=E1za?= <[email-masked]>, dude <[email-masked]>
  reproducible_build: >>> Subject: Re: houston(...)
  reproducible_build: >>> References: <abra@1>
  reproducible_build: >>> In-Reply-To: <abra@1>
  reproducible_build: >>> MIME-Version: 1.0
  reproducible_build: >>> Content-Type: text/plain; charset=us-ascii
  reproducible_build: >>> 
  3
  4
  5
  6
  out
  <./go.c 814
  >./go.c 850
  <./go.c 986
  >./go.c 850
  <./go.c 986
  LEAVING MAIN LOP
  <./go.c 1400
  AFTER MAINLOOP
  AFTER AFTER AFTER MAINLOOP
  CIAO 1
  CIAO 2
  CIAO 3
  CIAO 10
  CIAO 100
  >ATEXIT
  =ATEXIT
[And these are actually as below!]
  Segmentation fault
  behave:xxxheads_rfc2047-8: error: unexpected exit status: 139 != 0
  ./cc-test.sh: line 5093: can't open ./.cc-test.mbox: no such file
  behave:xxxheads_rfc2047-8: error: checksum mismatch (got )
  make[1]: Leaving directory '/home/steffen/sec.arena/packwork.git/abuild-pkg/testing/s-nail/src/s-nail-14.9.8'

It is in xssl.c:

  # if defined HAVE_XSSL_CONFIG || defined HAVE_SSL_ALL_ALGORITHMS
  static void
  a_xssl_atexit(void){
     NYD2_ENTER;
  fprintf(stderr, ">ATEXIT\n");
  #  ifdef HAVE_XSSL_CONFIG
     if(a_xssl_state & a_XSSL_S_CONF_LOAD)
        CONF_modules_free();
  #  endif
  
  fprintf(stderr, "=ATEXIT\n");
  #  ifdef HAVE_SSL_ALL_ALGORITHMS
     if(a_xssl_state & a_XSSL_S_ALGO_LOAD)
        EVP_cleanup();
  #  endif
  fprintf(stderr, "<ATEXIT\n");
     NYD2_LEAVE;
  }
  # endif

So the crash must be in EVP_cleanup.  I have never seen this until
now, but i always use other compiler flags, it just happened to
happen in this "abuild" run.

Like i said, my box is not up-to-date:

  Installed:                                Available:
  g++-6.4.0-r6                            < 6.4.0-r7 
  patch-2.7.6-r1                          < 2.7.6-r2 
  linux-vanilla-4.14.20-r0                < 4.14.24-r0 
  busybox-initscripts-3.1-r2              < 3.1-r3 
  libcurl-7.58.0-r0                       < 7.58.0-r2 
  alpine-conf-3.7.0-r1                    < 3.7.0-r3 
  gcc-6.4.0-r6                            < 6.4.0-r7 
  libstdc++-6.4.0-r6                      < 6.4.0-r7 
  ncurses-libs-6.0_p20180121-r0           < 6.0_p20180121-r1 
  kmod-24-r0                              < 24-r1 
  harfbuzz-1.6.3-r0                       < 1.6.3-r2 
  libevent-2.1.8-r2                       < 2.1.8-r3 
  libgomp-6.4.0-r6                        < 6.4.0-r7 
  curl-7.58.0-r0                          < 7.58.0-r2 
  ncurses-terminfo-base-6.0_p20180121-r0  < 6.0_p20180121-r1 
  libgcc-6.4.0-r6                         < 6.4.0-r7 
  libsasl-2.1.26-r11                      < 2.1.26-r12 
  gawk-4.2.0-r0                           < 4.2.1-r0 
  libatomic-6.4.0-r6                      < 6.4.0-r7 
  perl-dbd-sqlite-1.54-r1                 < 1.56-r0 
  ncurses-terminfo-6.0_p20180121-r0       < 6.0_p20180121-r1 
  ncurses-dev-6.0_p20180121-r0            < 6.0_p20180121-r1 
  cryptsetup-libs-2.0.1-r0                < 2.0.1-r1 
  openrc-0.24.1-r5                        < 0.24.1-r6 

But i wondered how this could interfere.
In case you do not see this bug: *fantastic*!

Note, and this is why i report it: i get this crash only when run
via "abuild check", NOT when invoked directly:

  #?0[steffen@essex s-nail-14.9.8]$ ./cc-test.sh --mae-test \
      ./mail t_behave_xxxheads_rfc2047
  [..]
  [t_behave_xxxheads_rfc2047]
  reproducible_build: P(seudo)R(andomNumber)G(enerator): *SSL RAND_*
  >./go.c 1237
  reproducible_build: READ 5 bytes <reply>
  >./go.c 274
  EINS
  ZWEI
  DREI
  VIER
  FUENF
  1
  reproducible_build: >>> MTA: ./.tsendmail.sh, arguments: sendmail -i -- [email-masked] [email-masked]
  reproducible_build: >>> Date: Wed, 02 Oct 1996 01:50:07 +0000
  reproducible_build: >>> To: =?iso-8859-1?Q?z=E1za?= <[email-masked]>, dude <[email-masked]>
  reproducible_build: >>> Subject: Re: houston(...)
  reproducible_build: >>> References: <abra@1>
  reproducible_build: >>> In-Reply-To: <abra@1>
  reproducible_build: >>> MIME-Version: 1.0
  reproducible_build: >>> Content-Type: text/plain; charset=us-ascii
  reproducible_build: >>> 
  3
  4
  5
  6
  out
  <./go.c 814
  >./go.c 850
  <./go.c 986
  >./go.c 850
  <./go.c 986
  LEAVING MAIN LOP
  <./go.c 1400
  AFTER MAINLOOP
  AFTER AFTER AFTER MAINLOOP
  CIAO 1
  CIAO 2
  CIAO 3
  CIAO 10
  CIAO 100
  >ATEXIT
  =ATEXIT
  <ATEXIT
  ./cc-test.sh: line 5093: can't open ./.cc-test.mbox: no such file
  behave:xxxheads_rfc2047-8: error: checksum mismatch (got )
  cp: can't stat './.cc-test.mbox': No such file or directory

I would be very interested in getting this fixed.
Thank you!

--steffen
|

---