Subject: [alpine-aports] ruby-curb seems broken

From: Brad Murray <[email-masked]>
Date: Thu, 12 Mar 2015 19:02:08 +1300

/ # apk add ruby-curb
ERROR: unsatisfiable constraints:
  so:libruby.so.2.0 (missing):
    required by: ruby-curb-0.8.4-r1[so:libruby.so.2.0]

Doesn't seem to matter what I do, have tried with ruby, ruby-dev and
ruby-libs all present

Looking at both the APKBUILD, and the actual gem source on github, I can't
see any clear reference to what its complaining about.

I know libruby is one of the API linking libs, but why would the APK build
successfully (I've tested that works), but not be able to install

Brad

---

From: Natanael Copa <[email-masked]>
Date: Mon, 16 Mar 2015 11:30:18 +0100

On Thu, 12 Mar 2015 19:02:08 +1300

> successfully (I've tested that works), but not be able to install

I pushed a rebuild with ruby 2.1

Should work with ruby-curb-0.8.4-r2

thanks.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---