Subject: [alpine-aports] [PATCH] community/s-nail: upgrade to v14.9.13..

From: Steffen Nurpmeso <[email-masked]>
Date: Fri, 08 Mar 2019 17:36:05 +0100

This strips off the Kerberos binding, i think noone really ever
uses it; and if not maybe adding a special subpackage may be worth
thinking about?

P.S.: in community now, cool.  I have found it there!

P.P.S.: please do not use v14.9.12, it picks up weird
ISO C 2011 statement and implements -T differently to what was
announced.
---
 community/s-nail/APKBUILD | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/community/s-nail/APKBUILD b/community/s-nail/APKBUILD
index 0b943ec..3524198 100644
--- a/community/s-nail/APKBUILD
+++ b/community/s-nail/APKBUILD
@@ -1,14 +1,13 @@
-# Contributor: Steffen Nurpmeso <[email-masked]>
 # Contributor: Ivan Tham <[email-masked]>
 # Maintainer: Steffen Nurpmeso <[email-masked]>
 pkgname=s-nail
-pkgver=14.9.11
-pkgrel=3
+pkgver=14.9.13
+pkgrel=1
 pkgdesc="SysV mail/BSD Mail/POSIX mailx: send and receive Internet mail"
 url="https://www.sdaoden.eu/code.html#s-mailx"
 arch="all"
 license="BSD"
-makedepends="openssl-dev libidn-dev ncurses-dev krb5-dev"
+makedepends="openssl-dev libidn-dev ncurses-dev"
 options="suid"
 replaces="mailx"
 subpackages="$pkgname-doc"
@@ -24,11 +23,12 @@ build() {
 		VAL_PREFIX=/usr \
 		VAL_SYSCONFDIR=/etc \
 		\
+		OPT_GSSAPI=no \
 		VAL_IDNA=idn \
-		VAL_RANDOM="libgetrandom sysgetrandom urandom builtin" \
+		VAL_RANDOM="tls,libgetrandom,sysgetrandom,urandom,builtin" \
 		\
 		config
-	make build # XXX unite with config in v14.9.12
+	make build
 }
 
 check() {
@@ -43,4 +43,4 @@ package() {
 	install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
 }
 
-sha512sums="e33de63e9c938a466c9c894e6a04ead0ccf42923bc1afaa52e7d7d7f763498567c3033b74be41b633b73d16c8f6baf6a3bec14db16975493ffc402a70a1395d3  s-nail-14.9.11.tar.xz"
+sha512sums="6467846fab5752c708886ba7a66cd2038effc0cf8d72e2feb670283cf1d5436c27037087eeaa201c074964476ff0c213cffe74169fb03089ebf964fcc766e6ea  s-nail-14.9.13.tar.xz"
-- 
2.21.0

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Mon, 11 Mar 2019 16:43:33 +0100

Hi,

>  1 file changed, 7 insertions(+), 7 deletions(-)

build fails for me with:

  LINK mail-dotlock
   text       data        bss        dec        hex    filename
   4808        720         88       5616       15f0    mail-dotlock
  LINK mail
/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld:
mx-031.o: in function `main':
main.c:(.text.startup+0xbb): undefined reference to `su_state_set'
/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld:
main.c:(.text.startup+0xc5): undefined reference to `su_log_set_level'
/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld:
main.c:(.text.startup+0xad4): undefined reference to `su_cs_first_of'
/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld:
main.c:(.text.startup+0x1073): undefined reference to `su_state_set'
/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld:
mx-001.o: in function `a_amv_var_check_num':
...
...

Thanks

/eo

---

From: Steffen Nurpmeso <[email-masked]>
Date: Mon, 11 Mar 2019 17:03:30 +0100

Hello!

Leonardo Arena wrote in <CAGG_d8CK5FJP8mBX-Lhv9G6NCNX31Z5CaZO6y5RuDQ=qdW\
[email-masked]>:
 |Hi,
 |
 |On Fri, Mar 8, 2019 at 5:35 PM Steffen Nurpmeso <[1][email-masked][/\
 |1]> wrote:
 |
 |  [1] mailto:[email-masked]
 |
 ||This strips off the Kerberos binding, i think noone really ever
 ||uses it; and if not maybe adding a special subpackage may be worth
 ||thinking about?
 |
 ||P.S.: in community now, cool.  I have found it there!
 |
 ||P.P.S.: please do not use v14.9.12, it picks up weird
 ||ISO C 2011 statement and implements -T differently to what was
 ||announced.
 ||---
 || community/s-nail/APKBUILD | 14 +++++++-------
 || 1 file changed, 7 insertions(+), 7 deletions(-)
 |
 |build fails for me with:

I have never seen these errors:

 |  LINK mail-dotlock
 |   text       data        bss        dec        hex    filename
 |   4808        720         88       5616       15f0    mail-dotlock
 |  LINK mail
 |/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-li\
 |nux-musl/bin/ld: mx-031.o: in function `main':
 |main.c:(.text.startup+0xbb): undefined reference to `su_state_set'
 |/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-li\
 |nux-musl/bin/ld: main.c:(.text.startup+0xc5): undefined reference to \
 |`su_log_set_level'
 |/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-li\
 |nux-musl/bin/ld: main.c:(.text.startup+0xad4): undefined reference \
 |to `su_cs_first_of'
 |/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-li\
 |nux-musl/bin/ld: main.c:(.text.startup+0x1073): undefined reference \
 |to `su_state_set'
 |/usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-li\
 |nux-musl/bin/ld: mx-001.o: in function `a_amv_var_check_num':

May i see your compiler flags, please?

--steffen
|

---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Mon, 11 Mar 2019 17:38:00 +0100

Steffen Nurpmeso wrote in <[email-masked]>:
 |Leonardo Arena wrote in <CAGG_d8CK5FJP8mBX-Lhv9G6NCNX31Z5CaZO6y5RuDQ=qdW\
 [email-masked]>:
 ||On Fri, Mar 8, 2019 at 5:35 PM Steffen Nurpmeso <[1][email-masked][/\
 ||1]> wrote:
 ...
 ||build fails for me with:
 |
 |I have never seen these errors:
 ...
 ||main.c:(.text.startup+0xbb): undefined reference to `su_state_set'
 ...

I see now, -Os; yes, we now require inline functions.
This is what happens with automatic heuristics; i for one write
INLINE when i want to have a function inlined, otherwise i do not.
I do not want to reorganize sources and move statics to after
their use cases in order to avoid crappy heuristics taking place
and inline functions by themselves.  And even that will no longer
work with link time optimizations and whatever they are now doing.

But isn't that a compiler bug, i can use EXTRA_CFLAGS=-O3 which
sets -finline-functions according to [1] and works just fine?

  [1] http://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html

--steffen
|

---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Mon, 11 Mar 2019 17:41:37 +0100

Steffen Nurpmeso wrote in <[email-masked]>:
 |Steffen Nurpmeso wrote in <[email-masked]>:
 ||Leonardo Arena wrote in <CAGG_d8CK5FJP8mBX-Lhv9G6NCNX31Z5CaZO6y5RuDQ=qdW\
 [email-masked]>:
 |||On Fri, Mar 8, 2019 at 5:35 PM Steffen Nurpmeso <[1][email-masked][/\
 |||1]> wrote:
 | ...
 |||build fails for me with:
 ||
 ||I have never seen these errors:
 | ...
 |||main.c:(.text.startup+0xbb): undefined reference to `su_state_set'
 | ...
 |
 |I see now, -Os; yes, we now require inline functions.
 |This is what happens with automatic heuristics; i for one write
 |INLINE when i want to have a function inlined, otherwise i do not.
 |I do not want to reorganize sources and move statics to after
 |their use cases in order to avoid crappy heuristics taking place
 |and inline functions by themselves.  And even that will no longer
 |work with link time optimizations and whatever they are now doing.
 |
 |But isn't that a compiler bug, i can use EXTRA_CFLAGS=-O3 which
 |sets -finline-functions according to [1] and works just fine?

That is to say that -Os also sets this according to [1]:

  It also enables -finline-functions, causes the compiler to tune
  for code size rather than execution speed, and performs further
  optimizations designed to reduce code size.

So it seems maybe some pieces of cake think inlining is done
whereas others do not.
This leads me to that terribline "inline" behaviour of ISO C all
in all.  In C++ if a compilation unit needs that thing or an
address thereof it simply creates an instance, damn.  And
_Static_assert is also c..p compared to C++ static_assert or so.
S....y d..n ISO C decisions, all over the place.

 |  [1] http://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html

--steffen
|

---