Subject: [PATCH] testing/scc: new aport

From: KAAtheWise <[email-masked]>
Date: Sun, 26 Mar 2023 15:33:46 +0000

A port for the SCC SLOC/CLOC counter.
---
 testing/scc/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/scc/APKBUILD

diff --git a/testing/scc/APKBUILD b/testing/scc/APKBUILD
new file mode 100644
index 00000000000..a7a313f954c
--- /dev/null
+++ b/testing/scc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: KAA the Wise <[email-masked]>
+# Maintainer: KAA the Wise <[email-masked]>
+pkgname=scc
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="A very fast accurate code counter with complexity calculations and COCOMO estimates written in pure Go"
+url="https://github.com/boyter/scc"
+arch="all"
+license="MIT"
+makedepends="go"
+options="!check" # no test files present
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+	go build -v -o bin/"$pkgname"
+}
+
+package() {
+	install -Dm0755 bin/"$pkgname" -t "$pkgdir"/usr/bin
+}
+
+sha512sums="
+ecf47ae92806c2e4c696b99d7b5ef4f24527708c9e8d452d0341c00bd93ed7523f165e429b38c1a269f168793aabf95291e43b4f9a1dc8c5a79127fd5fe16721  scc-3.1.0.tar.gz
+"
-- 
2.38.4

---

From: Kevin Daudt <[email-masked]>
Date: Sun, 26 Mar 2023 16:04:46 +0000

> +++ b/testing/scc/APKBUILD

Created a merge request for this: https://lists.alpinelinux.org/~alpine/aports/patches/4163