Subject: [alpine-aports] [PATCH] main/nano: Upgrade to 2.7.4. Change maintainer.

From: Przemyslaw Pawelczyk <[email-masked]>
Date: Sat, 14 Jan 2017 01:50:16 +0100

Old alleged maintainer (Michael Zhou) made himself maintainer with
commit d2f2f034f33f4c6d8df8573da9455b475f6550f6, but he never touched
nano ever again.  He has almost no trace of any activity in aports repo
since 2011 (1 commit in 2016).

Natanael Copa is the most active contributor, so hopefully he's not
against becoming maintainer of another package.
---
 main/nano/APKBUILD | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/main/nano/APKBUILD b/main/nano/APKBUILD
index 850af16fb8a7..b5b8362e69e3 100644
--- a/main/nano/APKBUILD
+++ b/main/nano/APKBUILD
@@ -1,13 +1,12 @@
 # Contributor: Michael Mason <[email-masked]>
-# Maintainer: Michael Zhou <[email-masked]>
+# Maintainer: Natanael Copa <[email-masked]>
 pkgname=nano
-pkgver=2.7.3
+pkgver=2.7.4
 pkgrel=0
 pkgdesc="Text Editor. GNU nano is designed to be a free replacement for the Pico text editor."
 url="http://www.nano-editor.org/"
 arch="all"
 license="GPL"
-depends=
 makedepends="ncurses-dev file-dev"
 subpackages="$pkgname-doc $pkgname-syntax::noarch"
 source="http://www.nano-editor.org/dist/v${pkgver%.*}/$pkgname-$pkgver.tar.gz
@@ -31,7 +30,7 @@ build() {
 package() {
 	cd "$builddir"
 	make DESTDIR="$pkgdir" install
-	install -Dm644 doc/nanorc.sample \
+	install -Dm644 doc/sample.nanorc \
 		"$pkgdir"/etc/nanorc || return 1
 
 	# Proper syntax highlighting for APKBUILDs
@@ -48,6 +47,6 @@ syntax() {
 		"$subpkgdir"/usr/share/$pkgname/ || return 1
 }
 
-md5sums="007ba6321212d3ec38f46236465b6ea8  nano-2.7.3.tar.gz"
-sha256sums="3574d4594d051f3b572c47d63bfc3763fb1148c50b811ba7a016bacd94887a88  nano-2.7.3.tar.gz"
-sha512sums="cd159cf193f05b37f770ac79e532fe96be158688d241ab7090861016fe0da9dde2ab504d0703b8feea8043e1deded3f10f0ab4dd5cceba99fe4a1dfcf5062b0b  nano-2.7.3.tar.gz"
+md5sums="e3a6b2740eb31f8a06d585f44d883895  nano-2.7.4.tar.gz"
+sha256sums="23ffc2de52d687739fed6dc2fc94df36aa7da7bb52c8740c523fdd7336fdbc8c  nano-2.7.4.tar.gz"
+sha512sums="029fa2ef72a8762f376f1cfc3f4cdcabfcb226868e5c68c5980162333099f23e74e77da2dda66b4e70e2840b9a0e472db821248327b417b3cf5132093eeb80ee  nano-2.7.4.tar.gz"
-- 
2.8.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Przemyslaw Pawelczyk <[email-masked]>
Date: Sat, 14 Jan 2017 20:41:46 +0100

Łukasz Jendrysik was not aware of my nano upgrade in patchwork,
so he did PR in github and Jakub Jirutka applied it quickly then.
Here is the remaining part of my original patch.

 main/nano/APKBUILD | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

index 3bbd36ac9945..ccdfc2f661d9 100644
 pkgver=2.7.4
-pkgrel=0
+pkgrel=1
 source="http://www.nano-editor.org/dist/v${pkgver%.*}/$pkgname-$pkgver.tar.gz"
-- 
2.8.3

---