Subject: [alpine-aports] [PATCH 1/3] main/apache2: Unify .pre-upgrade with .pre-install.

From: Przemyslaw Pawelczyk <[email-masked]>
Date: Mon, 20 Jun 2016 12:18:39 +0200

apache2.pre-upgrade now links to apache2.pre-install.

It's not something we want to do for all packages in master (edge).
apache2 already had .pre-upgrade script (ensuring www-data group
existence and making apache user a member of it), which is what existing
.pre-install script also does, so this kind of unification is fine here.

In most other cases linking .pre-upgrade to .pre-install should happen
only in 3.4-stable branch.
---
 main/apache2/apache2.pre-upgrade | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
 mode change 100644 => 120000 main/apache2/apache2.pre-upgrade

diff --git a/main/apache2/apache2.pre-upgrade b/main/apache2/apache2.pre-upgrade
deleted file mode 100644
index bb3dba99cbdb..000000000000
--- a/main/apache2/apache2.pre-upgrade
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-addgroup -S -g 82 www-data 2>/dev/null
-addgroup apache www-data 2>/dev/null
-
-exit 0
diff --git a/main/apache2/apache2.pre-upgrade b/main/apache2/apache2.pre-upgrade
new file mode 120000
index 000000000000..df3b23038035
--- /dev/null
+++ b/main/apache2/apache2.pre-upgrade
@@ -0,0 +1 @@
+apache2.pre-install
\ No newline at end of file
-- 
2.6.6

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Przemyslaw Pawelczyk <[email-masked]>
Date: Mon, 20 Jun 2016 12:18:40 +0200

Make sure that user is part of the same named group.

Requires patch "main/apache2: Unify .pre-upgrade with .pre-install."
---
 main/apache2/apache2.pre-install | 1 +
 1 file changed, 1 insertion(+)

diff --git a/main/apache2/apache2.pre-install b/main/apache2/apache2.pre-install
index d4ede7476687..9323e75fe5b0 100644
--- a/main/apache2/apache2.pre-install
+++ b/main/apache2/apache2.pre-install
@@ -3,6 +3,7 @@
 addgroup -S -g 82 www-data 2>/dev/null
 addgroup -S apache 2>/dev/null
 adduser -S -D -H -h /var/www -s /sbin/nologin -G apache -g apache apache 2>/dev/null
+addgroup apache apache 2>/dev/null # AL 3.4 band-aid for ccc056dbf9d3
 addgroup apache www-data 2>/dev/null
 
 exit 0
-- 
2.6.6

---

---

From: Przemyslaw Pawelczyk <[email-masked]>
Date: Mon, 20 Jun 2016 12:18:41 +0200

---
 main/apache2/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index 75f1b4d92725..da01165defc9 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=apache2
 _pkgreal=httpd
 pkgver=2.4.20
-pkgrel=1
+pkgrel=2
 pkgdesc="A high performance Unix-based HTTP server"
 url="http://httpd.apache.org/"
 arch="all"
-- 
2.6.6

---