Subject: [alpine-aports] [PATCH 1/2] main/build-base: drop patch dependency

From: Sören Tempel <[email-masked]>
Date: Tue, 8 Sep 2015 00:39:20 +0200

build-base should only include basic build tools for compiling C/C++
programs. patch(1) is a useful tool in that process but our busybox
version already ships a patch program.

However, abuild(1) needs the GNU version of patch thus this dependency
was moved to the alpine-sdk package.
---
 main/build-base/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/main/build-base/APKBUILD b/main/build-base/APKBUILD
index d114acb..9ae0ceb 100644
--- a/main/build-base/APKBUILD
+++ b/main/build-base/APKBUILD
@@ -1,10 +1,10 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=build-base
 pkgver=0.4
-pkgrel=0
+pkgrel=1
 url=http://dev.alpinelinux.org/cgit
 pkgdesc="Meta package for build base"
-depends="binutils gcc make patch libc-dev fortify-headers g++"
+depends="binutils gcc make libc-dev fortify-headers g++"
 arch="noarch"
 license=none
 
-- 
2.5.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Sören Tempel <[email-masked]>
Date: Tue, 8 Sep 2015 00:39:21 +0200

See the commit message of the last commit for more details.
---
 main/alpine-sdk/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/main/alpine-sdk/APKBUILD b/main/alpine-sdk/APKBUILD
index 12ddfc1..602b9ef 100644
--- a/main/alpine-sdk/APKBUILD
+++ b/main/alpine-sdk/APKBUILD
@@ -1,10 +1,10 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=alpine-sdk
 pkgver=0.4
-pkgrel=1
+pkgrel=2
 url=http://dev.alpinelinux.org/cgit
 pkgdesc="Alpine Software Development Kit meta package"
-depends="abuild build-base git squashfs-tools cdrkit acct mkinitfs mtools"
+depends="abuild build-base patch git squashfs-tools cdrkit acct mkinitfs mtools"
 arch="noarch"
 license="GPL2"
 
@@ -15,4 +15,4 @@ build() {
 
 package() {
 	mkdir -p "$pkgdir"
-}	
+}
-- 
2.5.1

---