Subject: [alpine-aports] [PATCH 1/3] main/iptables: Added description to init.d script

From: Daniele Coli <[email-masked]>
Date: Fri, 30 Oct 2015 19:12:19 +0100

Added description to init.d script in order to make it compliant
with rc-system and avoid annoying warning messages on syslog.
---
 main/iptables/APKBUILD       | 6 +++---
 main/iptables/iptables.initd | 5 +++++
 2 files changed, 8 insertions(+), 3 deletions(-)

diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index f79ebd0..8a14ac6 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,7 +2,7 @@
 
 pkgname=iptables
 pkgver=1.4.21
-pkgrel=3
+pkgrel=4
 pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
 url="http://www.netfilter.org/projects/iptables/index.html"
 arch="all"
@@ -90,12 +90,12 @@ ip6tables() {
 
 md5sums="536d048c8e8eeebcd9757d0863ebb0c0  iptables-1.4.21.tar.bz2
 cd9f429bf0dbd73be5f95bf0d7169728  iptables-1.4.14-musl-fixes.patch
-ce106a4222a174d2e102b1975fe0295c  iptables.initd
+2e8175456a98221c0be9b758d064ee09  iptables.initd
 c91286c54f8fe0de6ed8950f375cb7a5  iptables.confd
 d3f37ebc2cd3fbfc326c3a8df5a79e11  ip6tables.confd"
 sha256sums="52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0  iptables-1.4.21.tar.bz2
 3ad64af68ea70aa6de0649a68176c2ac68e1c0db567babb472648695dbff8f90  iptables-1.4.14-musl-fixes.patch
-6c2da067887658c897a11254e001bfb1510c8b34d759212b51b7630d0e7e4ae8  iptables.initd
+f297f985ad35fe45800f0c1c7aaf348c3fa920b97be2020c76983ab54e384ba0  iptables.initd
 421acbcd310f9c51e20e22e59af9452b1ba5d0db33e8960eba0095271060c3db  iptables.confd
 31ef5d759c64afd0ecbcb56b3982ed2bdb5ed9c8553c628c13d4a3b5687118a3  ip6tables.confd"
 sha512sums="dd4baccdb080284d8620e6ed59beafc2677813f3e099051764b07f8e394f6d94ca11861b181f3cce7c55c66de64c1e2add13dc1a0b64e24050cd9fb7aea0689b  iptables-1.4.21.tar.bz2
diff --git a/main/iptables/iptables.initd b/main/iptables/iptables.initd
index 891adc0..98b52d0 100644
--- a/main/iptables/iptables.initd
+++ b/main/iptables/iptables.initd
@@ -3,6 +3,11 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.4.11.init,v 1.2 2011/12/04 10:15:59 swegener Exp $
 
+description="IPv4/IPv6 packet filtering and NAT"
+description_save="Save firewall state"
+description_panic="Drop all packets"
+description_reload="Reload configuration"
+
 extra_commands="save panic"
 extra_started_commands="reload"
 
-- 
2.6.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Daniele Coli <[email-masked]>
Date: Fri, 30 Oct 2015 19:12:20 +0100

Added description to init.d script in order to make it compliant
with rc-system and avoid annoying warning messages on syslog.
---
 main/openvpn/APKBUILD      | 6 +++---
 main/openvpn/openvpn.initd | 2 ++
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/main/openvpn/APKBUILD b/main/openvpn/APKBUILD
index c8528e1..846fa21 100644
--- a/main/openvpn/APKBUILD
+++ b/main/openvpn/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=openvpn
 pkgver=2.3.8
-pkgrel=0
+pkgrel=1
 pkgdesc="A robust, and highly configurable VPN (Virtual Private Network)"
 url="http://openvpn.sourceforge.net/"
 arch="all"
@@ -74,12 +74,12 @@ pam() {
 }
 
 md5sums="51d996f1f1fc30f501ae251a254effeb  openvpn-2.3.8.tar.gz
-6587953f1ac10cf9261041b7527a6b55  openvpn.initd
+5098518a5749197148132593072e1b3b  openvpn.initd
 9eca88cac6294027ec1bb7be74185c3a  openvpn.confd
 dc72fecd1a1bcef937603057cd6574b1  openvpn.up
 dc3ff0bae442b9aedd947b8ffda1687a  openvpn.down"
 sha256sums="532435eff61c14b44a583f27b72f93e7864e96c95fe51134ec0ad4b1b1107c51  openvpn-2.3.8.tar.gz
-ab7291aaf161020fb4c27a6f24ef0346c66d86f92d29cbd31723cc305502c247  openvpn.initd
+fcb9f5e224dc3e73fddf537a15dd9c3c018002d499fa6a4680e747f42bb99609  openvpn.initd
 330149a83684ddabe413d134d4c8efad4c88b18c2ab67165014deff5f7fffad2  openvpn.confd
 848da0929c37b2112769232fbbdf61961b6107c6726d4b74d1ceb034b39ad5dd  openvpn.up
 39debebcd8c899f20e6d355cbc8eaab46e28b83a9f6c33a94c065688a4f3d2c7  openvpn.down"
diff --git a/main/openvpn/openvpn.initd b/main/openvpn/openvpn.initd
index a3b2fda..20c142f 100644
--- a/main/openvpn/openvpn.initd
+++ b/main/openvpn/openvpn.initd
@@ -2,6 +2,8 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+description="VPN service"
+
 VPNDIR=${VPNDIR:-/etc/openvpn}
 VPN=${SVCNAME#*.}
 if [ -n "${VPN}" ] && [ ${SVCNAME} != "openvpn" ]; then
-- 
2.6.1

---

---

From: Daniele Coli <[email-masked]>
Date: Fri, 30 Oct 2015 19:12:21 +0100

Added description to init.d script in order to make it compliant
with rc-system and avoid annoying warning messages on syslog.
---
 main/dovecot/APKBUILD      | 6 +++---
 main/dovecot/dovecot.initd | 3 +++
 2 files changed, 6 insertions(+), 3 deletions(-)

diff --git a/main/dovecot/APKBUILD b/main/dovecot/APKBUILD
index 3e8d24a..20738c1 100644
--- a/main/dovecot/APKBUILD
+++ b/main/dovecot/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=dovecot
 pkgver=2.2.19
-pkgrel=0
+pkgrel=1
 pkgdesc="IMAP and POP3 server"
 url="http://www.dovecot.org/"
 arch="all"
@@ -130,12 +130,12 @@ config() {
 md5sums="95591b6556413edc2f0b160fb469d04c  dovecot-2.2.19.tar.gz
 49f7a03284cc657857fe2ae22b8c82a0  hide-dl-errors.patch
 1a88280b65efb6cb7f70bc5a88bf264c  dovecot.logrotate
-2a63d966ce4d9c63cecf99d183c394a0  dovecot.initd
+f730fd2f5e94cdb8ce0ff4df54ebb49b  dovecot.initd
 95cf57ecc835882228bbbb019ce3abf8  dovecot-sample-config.post-install"
 sha256sums="759e1e3f9d907cdaabad1f5fbacc793ca191d234c084bec3bba42966952a4e9f  dovecot-2.2.19.tar.gz
 d6accdd6e271647c01ab8fa0a9491ee822486484961e2d5c252bf70e816d2bfa  hide-dl-errors.patch
 2ac04bb7b5c503cd87ba044482e651dbe5c9d84a4268891fb2aa9ba26e62f833  dovecot.logrotate
-e6dd8e654a66aeb84ae63959de290ccf6ba05d890232a107edf1bb83a88767bb  dovecot.initd
+6cad7099764c04b6ed1a1c4fbc308d66657ad31db627dd058cbbde4e883ccc00  dovecot.initd
 7dab0591eca7fe1473ae7b39ed9ae0d7d51617ffea01252ace5c3aa68150693f  dovecot-sample-config.post-install"
 sha512sums="1b9d605a6a5862ade9d1ca634a9e0171b7c212ab025fc2059051c3795470685b66516fa9fbe5ad91d84388268ea15795f2dcd70ffdf81736ce4d80fd284835e9  dovecot-2.2.19.tar.gz
 1e9a1f2990019236546c7be581a4d6d0b430110d27a00bc3298f5c154ef9a4aadefa193d02a017912f826d771058fd5c6ef6cb454e14f0d15749fa8f3a68c64a  hide-dl-errors.patch
diff --git a/main/dovecot/dovecot.initd b/main/dovecot/dovecot.initd
index 646f80a..fdfb5a9 100644
--- a/main/dovecot/dovecot.initd
+++ b/main/dovecot/dovecot.initd
@@ -1,5 +1,8 @@
 #!/sbin/openrc-run
 
+description="Secure POP3/IMAP server"
+description_reload="Reload configuration"
+
 extra_started_commands="reload"
 
 depend() {
-- 
2.6.1

---