Subject: [alpine-aports] [PATCH 1/2] main/abuild: Depend on patch

From: Sören Tempel <[email-masked]>
Date: Thu, 24 Sep 2015 23:54:56 +0200

Some patches can only be applied with GNU patch (example: OpenSSH
aport), thus abuild needs to depend on patch.

See also: e4e72a78d0ea922149226c9880ed095dcd550118
---
 main/abuild/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 1d987b6..a80588a 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,13 +2,13 @@
 pkgname=abuild
 pkgver=2.24.0
 _ver=${pkgver%_git*}
-pkgrel=6
+pkgrel=7
 pkgdesc="Script to build Alpine Packages"
 url="http://git.alpinelinux.org/cgit/abuild/"
 arch="all"
 license="GPL2"
 depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
-	attr tar pkgconf"
+	attr tar pkgconf patch"
 if [ "$CBUILD" = "$CHOST" ]; then
 	depends="$depends curl"
 fi
-- 
2.5.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Sören Tempel <[email-masked]>
Date: Thu, 24 Sep 2015 23:54:57 +0200

GNU patch is only needed by abuild.

See also: Latest abuild commit and e4e72a78d0ea922149226c9880ed095dcd550118
---
 main/alpine-sdk/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/main/alpine-sdk/APKBUILD b/main/alpine-sdk/APKBUILD
index 602b9ef..6228e44 100644
--- a/main/alpine-sdk/APKBUILD
+++ b/main/alpine-sdk/APKBUILD
@@ -1,10 +1,10 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=alpine-sdk
 pkgver=0.4
-pkgrel=2
+pkgrel=3
 url=http://dev.alpinelinux.org/cgit
 pkgdesc="Alpine Software Development Kit meta package"
-depends="abuild build-base patch git squashfs-tools cdrkit acct mkinitfs mtools"
+depends="abuild build-base git squashfs-tools cdrkit acct mkinitfs mtools"
 arch="noarch"
 license="GPL2"
 
-- 
2.5.3

---