Subject: [alpine-aports] [PATCH 1/2] main/mcpp: move from testing

From: Sören Tempel <[email-masked]>
Date: Wed, 30 Sep 2015 17:51:11 +0200

---
 main/mcpp/01-zeroc-fixes.patch     | 75 ++++++++++++++++++++++++++++++++++++++
 main/mcpp/02-gniibe-fixes.patch    | 33 +++++++++++++++++
 main/mcpp/APKBUILD                 | 65 +++++++++++++++++++++++++++++++++
 testing/mcpp/01-zeroc-fixes.patch  | 75 --------------------------------------
 testing/mcpp/02-gniibe-fixes.patch | 33 -----------------
 testing/mcpp/APKBUILD              | 65 ---------------------------------
 6 files changed, 173 insertions(+), 173 deletions(-)
 create mode 100644 main/mcpp/01-zeroc-fixes.patch
 create mode 100644 main/mcpp/02-gniibe-fixes.patch
 create mode 100644 main/mcpp/APKBUILD
 delete mode 100644 testing/mcpp/01-zeroc-fixes.patch
 delete mode 100644 testing/mcpp/02-gniibe-fixes.patch
 delete mode 100644 testing/mcpp/APKBUILD

diff --git a/main/mcpp/01-zeroc-fixes.patch b/main/mcpp/01-zeroc-fixes.patch
new file mode 100644
index 0000000..fff5d32
--- /dev/null
+++ b/main/mcpp/01-zeroc-fixes.patch
@@ -0,0 +1,75 @@
+Description: Fixes by ZeroC, Inc.
+Author: ZeroC, Inc.
+Bug-Debian: http://bugs.debian.org/611749
+
+--- mcpp-2.7.2.orig/src/main.c
++++ mcpp-2.7.2/src/main.c
+@@ -326,6 +326,8 @@ static void     init_main( void)
+             = FALSE;
+     option_flags.trig = TRIGRAPHS_INIT;
+     option_flags.dig = DIGRAPHS_INIT;
++    sh_file = NULL;
++    sh_line = 0;
+ }
+ 
+ int     mcpp_lib_main
+--- mcpp-2.7.2.orig/src/support.c
++++ mcpp-2.7.2/src/support.c
+@@ -188,7 +188,7 @@ static char *   append_to_buffer(
+     size_t      length
+ )
+ {
+-    if (mem_buf_p->bytes_avail < length) {  /* Need to allocate more memory */
++    if (mem_buf_p->bytes_avail < length + 1) {  /* Need to allocate more memory */
+         size_t size = MAX( BUF_INCR_SIZE, length);
+ 
+         if (mem_buf_p->buffer == NULL) {            /* 1st append   */
+@@ -1722,6 +1722,8 @@ com_start:
+                     sp -= 2;
+                     while (*sp != '\n')     /* Until end of line    */
+                         mcpp_fputc( *sp++, OUT);
++                    mcpp_fputc( '\n', OUT);
++                    wrong_line = TRUE;
+                 }
+                 goto  end_line;
+             default:                        /* Not a comment        */
+--- mcpp-2.7.2.orig/src/internal.H
++++ mcpp-2.7.2/src/internal.H
+@@ -390,6 +390,8 @@ extern char * const     work_end;   /* E
+ extern char     identifier[];       /* Lastly scanned name          */
+ extern IFINFO   ifstack[];          /* Information of #if nesting   */
+ extern char     work_buf[];
++extern FILEINFO * sh_file;
++extern int      sh_line;
+         /* Temporary buffer for directive line and macro expansion  */
+ 
+ /* main.c   */
+@@ -557,6 +559,6 @@ extern void     init_system( void);
+ #endif
+ #endif
+ 
+-#if HOST_HAVE_STPCPY
++#if HOST_HAVE_STPCPY && !defined(stpcpy)
+ extern char *   stpcpy( char * dest, const char * src);
+ #endif
+--- mcpp-2.7.2.orig/src/system.c
++++ mcpp-2.7.2/src/system.c
+@@ -3858,6 +3858,9 @@ static int  chk_dirp(
+ }
+ #endif
+ 
++FILEINFO*       sh_file;
++int             sh_line;
++
+ void    sharp(
+     FILEINFO *  sharp_file,
+     int         flag        /* Flag to append to the line for GCC   */
+@@ -3868,8 +3871,6 @@ void    sharp(
+  * else (i.e. 'sharp_file' is NULL) 'infile'.
+  */
+ {
+-    static FILEINFO *   sh_file;
+-    static int  sh_line;
+     FILEINFO *  file;
+     int         line;
+ 
diff --git a/main/mcpp/02-gniibe-fixes.patch b/main/mcpp/02-gniibe-fixes.patch
new file mode 100644
index 0000000..cb5aa6c
--- /dev/null
+++ b/main/mcpp/02-gniibe-fixes.patch
@@ -0,0 +1,33 @@
+Description: Simple fixes
+ * Fix freeing unmalloced memory
+   The memory of 'in_file' is not malloced, but points to argv[].
+   It is wrong to free it.
+ * When there is no input file specified by argv, it causes error
+   and fp_in == NULL.  Check is needed to call fclose for fp_in.
+Author: NIIBE Yutaka
+
+## Fixes the issue reported at:
+## http://www.forallsecure.com/bug-reports/6b11b6fccda17cc467e055ccf7fec3fa2d89ec00/
+
+Index: mcpp-2.7.2/src/main.c
+===================================================================
+--- mcpp-2.7.2.orig/src/main.c	2013-07-09 03:03:05.610947658 +0000
++++ mcpp-2.7.2/src/main.c	2013-07-09 03:03:05.534947624 +0000
+@@ -428,16 +428,11 @@
+ 
+ fatal_error_exit:
+ #if MCPP_LIB
+-    /* Free malloced memory */
+-    if (mcpp_debug & MACRO_CALL) {
+-        if (in_file != stdin_name)
+-            free( in_file);
+-    }
+     clear_filelist();
+     clear_symtable();
+ #endif
+ 
+-    if (fp_in != stdin)
++    if (fp_in && fp_in != stdin)
+         fclose( fp_in);
+     if (fp_out != stdout)
+         fclose( fp_out);
diff --git a/main/mcpp/APKBUILD b/main/mcpp/APKBUILD
new file mode 100644
index 0000000..007b6a4
--- /dev/null
+++ b/main/mcpp/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Sören Tempel <[email-masked]>
+# Maintainer: Sören Tempel <[email-masked]>
+pkgname=mcpp
+pkgver=2.7.2
+pkgrel=0
+pkgdesc="A portable C preprocessor"
+url="http://mcpp.sourceforge.net"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz
+	01-zeroc-fixes.patch
+	02-gniibe-fixes.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+	cd "$_builddir"
+	update_config_sub || return 1
+
+	local i
+	for i in $source; do
+		case $i in
+		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+		esac
+	done
+}
+
+build() {
+	cd "$_builddir"
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--localstatedir=/var \
+		--enable-mcpplib \
+		--disable-static \
+		|| return 1
+	make || return 1
+}
+
+package() {
+	cd "$_builddir"
+	make DESTDIR="$pkgdir" install || return 1
+
+	mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+	mv "$pkgdir"/usr/share/doc/$pkgname/LICENSE \
+		"$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+}
+
+md5sums="512de48c87ab023a69250edc7a0c7b05  mcpp-2.7.2.tar.gz
+e231a2c976ccf14b548deaee840faeb7  01-zeroc-fixes.patch
+1801827678e80d0ef73655a88064a35b  02-gniibe-fixes.patch"
+sha256sums="3b9b4421888519876c4fc68ade324a3bbd81ceeb7092ecdbbc2055099fcb8864  mcpp-2.7.2.tar.gz
+6ed331f58edc7a24e769ac065ab43ed9f09f06487fda37095cacd413b81f522c  01-zeroc-fixes.patch
+30a790e63e387a95e45c2b73b3942948e1e852155250dd769a5598c33d374504  02-gniibe-fixes.patch"
+sha512sums="1ca885cb13fdb684de9d0595a9215b52f48a93a69077d82cdcacafe40d9a61fb77b00a3ff2b8890e7bc0a0fcc0c8d70d4093c00c280351cd4459aba67c573235  mcpp-2.7.2.tar.gz
+86b2e851490e180dfe3028a5a37019ea423924c921ab053a642fb78d4533a87f913ede2928daf9da4daf60e67795a24521186b40c76961ae99ebeb75f8aa95ad  01-zeroc-fixes.patch
+a31a0f2e7430381e5e62ea4257a35891ce9d2f3beed60c6caad3b6d298a58557e9c850223840ef8c6f6c2e8139cf4a4edf29ac93b2532680feafba503fcfaf6d  02-gniibe-fixes.patch"
diff --git a/testing/mcpp/01-zeroc-fixes.patch b/testing/mcpp/01-zeroc-fixes.patch
deleted file mode 100644
index fff5d32..0000000
--- a/testing/mcpp/01-zeroc-fixes.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Description: Fixes by ZeroC, Inc.
-Author: ZeroC, Inc.
-Bug-Debian: http://bugs.debian.org/611749
-
---- mcpp-2.7.2.orig/src/main.c
-+++ mcpp-2.7.2/src/main.c
-@@ -326,6 +326,8 @@ static void     init_main( void)
-             = FALSE;
-     option_flags.trig = TRIGRAPHS_INIT;
-     option_flags.dig = DIGRAPHS_INIT;
-+    sh_file = NULL;
-+    sh_line = 0;
- }
- 
- int     mcpp_lib_main
---- mcpp-2.7.2.orig/src/support.c
-+++ mcpp-2.7.2/src/support.c
-@@ -188,7 +188,7 @@ static char *   append_to_buffer(
-     size_t      length
- )
- {
--    if (mem_buf_p->bytes_avail < length) {  /* Need to allocate more memory */
-+    if (mem_buf_p->bytes_avail < length + 1) {  /* Need to allocate more memory */
-         size_t size = MAX( BUF_INCR_SIZE, length);
- 
-         if (mem_buf_p->buffer == NULL) {            /* 1st append   */
-@@ -1722,6 +1722,8 @@ com_start:
-                     sp -= 2;
-                     while (*sp != '\n')     /* Until end of line    */
-                         mcpp_fputc( *sp++, OUT);
-+                    mcpp_fputc( '\n', OUT);
-+                    wrong_line = TRUE;
-                 }
-                 goto  end_line;
-             default:                        /* Not a comment        */
---- mcpp-2.7.2.orig/src/internal.H
-+++ mcpp-2.7.2/src/internal.H
-@@ -390,6 +390,8 @@ extern char * const     work_end;   /* E
- extern char     identifier[];       /* Lastly scanned name          */
- extern IFINFO   ifstack[];          /* Information of #if nesting   */
- extern char     work_buf[];
-+extern FILEINFO * sh_file;
-+extern int      sh_line;
-         /* Temporary buffer for directive line and macro expansion  */
- 
- /* main.c   */
-@@ -557,6 +559,6 @@ extern void     init_system( void);
- #endif
- #endif
- 
--#if HOST_HAVE_STPCPY
-+#if HOST_HAVE_STPCPY && !defined(stpcpy)
- extern char *   stpcpy( char * dest, const char * src);
- #endif
---- mcpp-2.7.2.orig/src/system.c
-+++ mcpp-2.7.2/src/system.c
-@@ -3858,6 +3858,9 @@ static int  chk_dirp(
- }
- #endif
- 
-+FILEINFO*       sh_file;
-+int             sh_line;
-+
- void    sharp(
-     FILEINFO *  sharp_file,
-     int         flag        /* Flag to append to the line for GCC   */
-@@ -3868,8 +3871,6 @@ void    sharp(
-  * else (i.e. 'sharp_file' is NULL) 'infile'.
-  */
- {
--    static FILEINFO *   sh_file;
--    static int  sh_line;
-     FILEINFO *  file;
-     int         line;
- 
diff --git a/testing/mcpp/02-gniibe-fixes.patch b/testing/mcpp/02-gniibe-fixes.patch
deleted file mode 100644
index cb5aa6c..0000000
--- a/testing/mcpp/02-gniibe-fixes.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: Simple fixes
- * Fix freeing unmalloced memory
-   The memory of 'in_file' is not malloced, but points to argv[].
-   It is wrong to free it.
- * When there is no input file specified by argv, it causes error
-   and fp_in == NULL.  Check is needed to call fclose for fp_in.
-Author: NIIBE Yutaka
-
-## Fixes the issue reported at:
-## http://www.forallsecure.com/bug-reports/6b11b6fccda17cc467e055ccf7fec3fa2d89ec00/
-
-Index: mcpp-2.7.2/src/main.c
-===================================================================
---- mcpp-2.7.2.orig/src/main.c	2013-07-09 03:03:05.610947658 +0000
-+++ mcpp-2.7.2/src/main.c	2013-07-09 03:03:05.534947624 +0000
-@@ -428,16 +428,11 @@
- 
- fatal_error_exit:
- #if MCPP_LIB
--    /* Free malloced memory */
--    if (mcpp_debug & MACRO_CALL) {
--        if (in_file != stdin_name)
--            free( in_file);
--    }
-     clear_filelist();
-     clear_symtable();
- #endif
- 
--    if (fp_in != stdin)
-+    if (fp_in && fp_in != stdin)
-         fclose( fp_in);
-     if (fp_out != stdout)
-         fclose( fp_out);
diff --git a/testing/mcpp/APKBUILD b/testing/mcpp/APKBUILD
deleted file mode 100644
index 007b6a4..0000000
--- a/testing/mcpp/APKBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Contributor: Sören Tempel <[email-masked]>
-# Maintainer: Sören Tempel <[email-masked]>
-pkgname=mcpp
-pkgver=2.7.2
-pkgrel=0
-pkgdesc="A portable C preprocessor"
-url="http://mcpp.sourceforge.net"
-arch="all"
-license="custom"
-depends=""
-depends_dev=""
-makedepends=""
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz
-	01-zeroc-fixes.patch
-	02-gniibe-fixes.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
-	cd "$_builddir"
-	update_config_sub || return 1
-
-	local i
-	for i in $source; do
-		case $i in
-		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
-		esac
-	done
-}
-
-build() {
-	cd "$_builddir"
-	./configure \
-		--build=$CBUILD \
-		--host=$CHOST \
-		--prefix=/usr \
-		--sysconfdir=/etc \
-		--mandir=/usr/share/man \
-		--infodir=/usr/share/info \
-		--localstatedir=/var \
-		--enable-mcpplib \
-		--disable-static \
-		|| return 1
-	make || return 1
-}
-
-package() {
-	cd "$_builddir"
-	make DESTDIR="$pkgdir" install || return 1
-
-	mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
-	mv "$pkgdir"/usr/share/doc/$pkgname/LICENSE \
-		"$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
-}
-
-md5sums="512de48c87ab023a69250edc7a0c7b05  mcpp-2.7.2.tar.gz
-e231a2c976ccf14b548deaee840faeb7  01-zeroc-fixes.patch
-1801827678e80d0ef73655a88064a35b  02-gniibe-fixes.patch"
-sha256sums="3b9b4421888519876c4fc68ade324a3bbd81ceeb7092ecdbbc2055099fcb8864  mcpp-2.7.2.tar.gz
-6ed331f58edc7a24e769ac065ab43ed9f09f06487fda37095cacd413b81f522c  01-zeroc-fixes.patch
-30a790e63e387a95e45c2b73b3942948e1e852155250dd769a5598c33d374504  02-gniibe-fixes.patch"
-sha512sums="1ca885cb13fdb684de9d0595a9215b52f48a93a69077d82cdcacafe40d9a61fb77b00a3ff2b8890e7bc0a0fcc0c8d70d4093c00c280351cd4459aba67c573235  mcpp-2.7.2.tar.gz
-86b2e851490e180dfe3028a5a37019ea423924c921ab053a642fb78d4533a87f913ede2928daf9da4daf60e67795a24521186b40c76961ae99ebeb75f8aa95ad  01-zeroc-fixes.patch
-a31a0f2e7430381e5e62ea4257a35891ce9d2f3beed60c6caad3b6d298a58557e9c850223840ef8c6f6c2e8139cf4a4edf29ac93b2532680feafba503fcfaf6d  02-gniibe-fixes.patch"
-- 
2.6.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Sören Tempel <[email-masked]>
Date: Wed, 30 Sep 2015 17:51:12 +0200

---
 main/xrdb/APKBUILD | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)

diff --git a/main/xrdb/APKBUILD b/main/xrdb/APKBUILD
index d28fd5e..444b412 100644
--- a/main/xrdb/APKBUILD
+++ b/main/xrdb/APKBUILD
@@ -1,14 +1,18 @@
+# Contributor: Sören Tempel <[email-masked]>
+# Contributor: Natanael Copa <[email-masked]>
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=xrdb
 pkgver=1.1.0
-pkgrel=0
+pkgrel=1
 pkgdesc="X server resource database utility"
 url="http://xorg.freedesktop.org/"
 arch="all"
 license="custom"
-subpackages="$pkgname-doc"
-depends=
+depends="mcpp"
+depends_dev=""
 makedepends="libxmu-dev libx11-dev"
+install=""
+subpackages="$pkgname-doc"
 source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
 
 build () {
@@ -18,6 +22,9 @@ build () {
 		--host=$CHOST \
 		--prefix=/usr \
 		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--localstatedir=/var \
+		--with-cpp=/usr/bin/mcpp \
 		|| return 1
 	make || return 1
 }
@@ -26,6 +33,7 @@ package() {
 	cd "$srcdir"/$pkgname-$pkgver
 	make DESTDIR="$pkgdir" install || return 1
 }
+
 md5sums="b54c7e3e53b4f332d41ed435433fbda0  xrdb-1.1.0.tar.bz2"
 sha256sums="73827b6bbfc9d27ca287d95a1224c306d7053cd7b8156641698d7dc541ca565b  xrdb-1.1.0.tar.bz2"
 sha512sums="8e2a177653d5aa895c71ed3640e0f1dd9fe8bf5cd6f0c6ff7e372394a2a41c3aa2286905fd9c69e3d140024d235b81a1f32b5d4012b1ac5ac1ed945599dee407  xrdb-1.1.0.tar.bz2"
-- 
2.6.0

---