Subject: [alpine-aports] [PATCH 1/2] testing/libcypher-parser: new aport (update to upstream version 0.5.1)

From: Chris Leishman <[email-masked]>
Date: Wed, 17 Aug 2016 11:13:14 -0700

https://github.com/cleishm/libcypher-parser
Parsing library for the Cypher query language
---
 testing/libcypher-parser/APKBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/testing/libcypher-parser/APKBUILD b/testing/libcypher-parser/APKBUILD
index dbc8bc6..1e223ed 100644
--- a/testing/libcypher-parser/APKBUILD
+++ b/testing/libcypher-parser/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Chris Leishman <[email-masked]>
 # Maintainer: Chris Leishman <[email-masked]>
 pkgname=libcypher-parser
-pkgver=0.5.0
+pkgver=0.5.1
 pkgrel=0
 pkgdesc="Parsing library for the Cypher query language"
 url="https://github.com/cleishm/libcypher-parser"
@@ -64,6 +64,6 @@ lint() {
     rmdir "$pkgdir"/usr/bin "$pkgdir"/usr 2>/dev/null
     return 0
 }
-md5sums="3e878e6d004e357f2d2dd8094e3ec70c  libcypher-parser-0.5.0.tar.gz"
-sha256sums="cb73505029ef63d3bb0e69f0e984035c797ee0df60476b0361c570e74e431ee4  libcypher-parser-0.5.0.tar.gz"
-sha512sums="ee79dcbcc243ea79971fc1b4ad2c9ab43e09a6fbcaa92194fbb43f89c1f8dfe8bf45bfa09e3a37e223835f17ce2004aa3e2721d3f7af14bfcf4d0785b65fb390  libcypher-parser-0.5.0.tar.gz"
+md5sums="c4c9a3bd9a97f4d97c1ffeb1ff19ebbe  libcypher-parser-0.5.1.tar.gz"
+sha256sums="bc9e3234e97b2e7c5829bfe17ed9e2f6a619a2e66144b6db7a6082e697441ead  libcypher-parser-0.5.1.tar.gz"
+sha512sums="632d65741332cc81cb42bbf61f53074677d81db27b6a8f2ce9f44fa04f82f16fd13b78c1ed34518124f7e10b77dc87fa3d4f791d19e076c6dc668b89faa82a56  libcypher-parser-0.5.1.tar.gz"
-- 
2.9.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Chris Leishman <[email-masked]>
Date: Wed, 17 Aug 2016 11:13:15 -0700

https://github.com/cleishm/libneo4j-client
Client library and CLI for the Neo4j graph database
---
 testing/libneo4j-client/APKBUILD             | 14 +++++--------
 testing/libneo4j-client/fortify_compat.patch | 31 ----------------------------
 2 files changed, 5 insertions(+), 40 deletions(-)
 delete mode 100644 testing/libneo4j-client/fortify_compat.patch

diff --git a/testing/libneo4j-client/APKBUILD b/testing/libneo4j-client/APKBUILD
index 56aa5c0..952e611 100644
--- a/testing/libneo4j-client/APKBUILD
+++ b/testing/libneo4j-client/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Chris Leishman <[email-masked]>
 # Maintainer: Chris Leishman <[email-masked]>
 pkgname=libneo4j-client
-pkgver=1.1.0
+pkgver=1.2.1
 pkgrel=0
 pkgdesc="Client library for the Neo4j graph database"
 url="https://github.com/cleishm/libneo4j-client"
@@ -12,7 +12,7 @@ depends_dev="openssl-dev"
 makedepends="$depends_dev automake autoconf libtool check-dev doxygen pkgconfig fts fts-dev libedit-dev libcypher-parser-dev"
 install=""
 subpackages="$pkgname-dev $pkgname-doc neo4j-client neo4j-client-doc"
-source="https://github.com/cleishm/libneo4j-client/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz fortify_compat.patch"
+source="https://github.com/cleishm/libneo4j-client/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
 
 _builddir="$srcdir"/"$pkgname-$pkgver"
 build() {
@@ -65,10 +65,6 @@ client() {
     rmdir "$pkgdir"/usr/bin "$pkgdir"/usr 2>/dev/null
     return 0
 }
-
-md5sums="e9d17aa10a44df5f0b030fd129b576fa  libneo4j-client-1.1.0.tar.gz
-9d51c9b8826337a2c82767fc21fa576d  fortify_compat.patch"
-sha256sums="486ca50519e7377d356a14f1f061fa331301ac10b41ddca08f3bff87a11b82a5  libneo4j-client-1.1.0.tar.gz
-39126e82e1c7d56cdd3786e070c64aeb43fe54d0b6878c020c8804006f00700f  fortify_compat.patch"
-sha512sums="5bf06f019fb71939b65d2b2a83ee3f2597a1b9ca171307834ea93cd394502e5506863cc21268477ed2f7231579f35faa203d19bd4c909a5cc60e5deda5d0766d  libneo4j-client-1.1.0.tar.gz
-eeb15d3580b175da31b97adcf133bdb206fc6ec44244c341f638d9356e5845dc4d3c3521d08f774d45cf73d56ad00631d07a04afbf060e01d412ea0de0cb96cc  fortify_compat.patch"
+md5sums="f405b5c6e60b503f971e900b5f060820  libneo4j-client-1.2.1.tar.gz"
+sha256sums="d5dfff272dc864c2c0874cac62df60a92161dc43c9d3faa02ab79ca6081cf470  libneo4j-client-1.2.1.tar.gz"
+sha512sums="3a9e573edadb2659317db053e95c0bb75be7a42092934c3d4ef859882c126e873acd63329ff58339969e846910a922f85563734379205a2309ea543c0c455b33  libneo4j-client-1.2.1.tar.gz"
diff --git a/testing/libneo4j-client/fortify_compat.patch b/testing/libneo4j-client/fortify_compat.patch
deleted file mode 100644
index 528b698..0000000
--- a/testing/libneo4j-client/fortify_compat.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/lib/posix_iostream.c b/src/lib/posix_iostream.c
-index 3f78f6d..3d9876e 100644
---- a/src/lib/posix_iostream.c
-+++ b/src/lib/posix_iostream.c
-@@ -37,7 +37,7 @@ static ssize_t posix_write(neo4j_iostream_t *self,
- static ssize_t posix_writev(neo4j_iostream_t *self,
-         const struct iovec *iov, unsigned int iovcnt);
- static int posix_flush(neo4j_iostream_t *self);
--static int posix_close(neo4j_iostream_t *self);
-+static int neo4j_posix_close(neo4j_iostream_t *self);
- 
- 
- neo4j_iostream_t *neo4j_posix_iostream(int fd)
-@@ -58,7 +58,7 @@ neo4j_iostream_t *neo4j_posix_iostream(int fd)
-     iostream->write = posix_write;
-     iostream->writev = posix_writev;
-     iostream->flush = posix_flush;
--    iostream->close = posix_close;
-+    iostream->close = neo4j_posix_close;
-     return iostream;
- }
- 
-@@ -131,7 +131,7 @@ int posix_flush(neo4j_iostream_t *self)
- }
- 
- 
--int posix_close(neo4j_iostream_t *self)
-+int neo4j_posix_close(neo4j_iostream_t *self)
- {
-     struct posix_iostream *ios = container_of(self,
-             struct posix_iostream, _iostream);
-- 
2.9.3

---