Subject: [alpine-aports] [PATCH] testing/mupdf: allow both x11 and gl backends

From: Daniel Sabogal <[email-masked]>
Date: Sun, 23 Oct 2016 23:51:16 -0400

ref #5921
Default mupdf symlink to mupdf-x11
---
 testing/mupdf/APKBUILD | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/testing/mupdf/APKBUILD b/testing/mupdf/APKBUILD
index 8246d53..7962f6a 100644
--- a/testing/mupdf/APKBUILD
+++ b/testing/mupdf/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Michael Zhou <[email-masked]>
 pkgname=mupdf
 pkgver=1.9a
-pkgrel=5
+pkgrel=6
 pkgdesc="A lightweight PDF and XPS viewer"
 url="http://mupdf.com"
 arch="all"
@@ -48,7 +48,7 @@ package() {
 
 _x11() {
 	pkgdesc="A lightweight PDF and XPS viewer with X11 backend"
-	depends="!mupdf-gl mupdf"
+	depends="mupdf"
 	mkdir -p "$subpkgdir"/usr/bin
 	mv "$pkgdir"/usr/bin/mupdf-x11 \
 		"$subpkgdir"/usr/bin/ || return 1
@@ -57,11 +57,10 @@ _x11() {
 
 _gl() {
 	pkgdesc="A lightweight PDF and XPS viewer with OpenGL backend"
-	depends="!mupdf-x11 mupdf"
+	depends="mupdf"
 	mkdir -p "$subpkgdir"/usr/bin
 	mv "$pkgdir"/usr/bin/mupdf-gl \
 		"$subpkgdir"/usr/bin/ || return 1
-	ln -s /usr/bin/mupdf-gl "$subpkgdir"/usr/bin/mupdf
 }
 
 _tools() {
-- 
2.10.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Daniel Sabogal <[email-masked]>
Date: Sun, 23 Oct 2016 23:51:17 -0400

---
 community/elixir/APKBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/community/elixir/APKBUILD b/community/elixir/APKBUILD
index e78daba..ef861cc 100644
--- a/community/elixir/APKBUILD
+++ b/community/elixir/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Marlus Saraiva <[email-masked]>
 
 pkgname=elixir
-pkgver=1.3.2
+pkgver=1.3.4
 pkgrel=0
 pkgdesc="Elixir is a dynamic, functional language designed for building scalable and maintainable applications"
 url="http://elixir-lang.org"
@@ -25,6 +25,6 @@ package() {
 	make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
 }
 
-md5sums="52ad748b6debed964496bb099b74adeeb3d1240c  elixir-1.3.2.tar.gz"
-sha256sums="be24efee0655206063208c5bb4157638310ff7e063b7ebd9d79e1c77e8344c4b  elixir-1.3.2.tar.gz"
-sha512sums="e50b4645d5720ab28dbedcfd4ef9919b10edd4290a2b1e9b2a69e8c3223ee3cdb3c8f8cc6d9191e6934970a7d0cbdc8396b9d7df6fc02e855cf4eae1707b5f7f  elixir-1.3.2.tar.gz"
+md5sums="ebbefbe4a48264972d7193ba9b71d1f5  elixir-1.3.4.tar.gz"
+sha256sums="f5ee5353d8dbe610b1dfd276d22f2038d57d9a7d3cea69dac10da2b098bd2033  elixir-1.3.4.tar.gz"
+sha512sums="84c8c5dfbde82d125855caf46e2848e9a91e7af46ab259c3e8b6f9c1d228e11058dd62cc142b70eb6d374f04ea502749c9ee8263867daabfc8d51edce7b3fcab  elixir-1.3.4.tar.gz"
-- 
2.10.1

---