Subject: [alpine-aports] [PATCH] testing/php7: upgrade to 7.0.6

From: Andy Blyler <[email-masked]>
Date: Fri, 1 Apr 2016 00:46:59 -0500

---
 testing/php7/APKBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index f53a6f8..6aca627 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Valery Kartel <[email-masked]>
 pkgname=php7
 _pkgreal=php
-pkgver=7.0.5
+pkgver=7.0.6
 pkgrel=1
 pkgdesc="The PHP language runtime engine - 7th branch"
 url="http://www.php.net/"
@@ -404,7 +404,7 @@ xsl()		{ _mv_ext xsl $pkgname-dom; }
 zip()		{ _mv_ext zip; }
 zlib()		{ _mv_ext zlib; }
 
-md5sums="b15e6836babcbf0aa446678ee38f896b  php-7.0.5.tar.bz2
+md5sums="c89a1046ff06f6aff699057376e297b6  php-7.0.6.tar.bz2
 a340f27e83ed4482d2fbb98658ef71cb  php7-fpm.initd
 25bde13e7894c2930d97fad68d5dd3b3  php7-fpm.logrotate
 47be6cd1ed92f21579e15bf2003a709f  php7-module.conf
@@ -413,7 +413,7 @@ a340f27e83ed4482d2fbb98658ef71cb  php7-fpm.initd
 d872e633c9b33c3c9f629dd2edd2e5c5  includedir.patch
 6ba762ab7a105163b8e5b3913deae109  pid_log.patch
 7f12fabdd1494e1c994cadd167e401d8  fix-crypt.patch"
-sha256sums="2c09af7fe64537ea795f098b9b542ead407ef83f7cdc65b3787115ccbbb51de9  php-7.0.5.tar.bz2
+sha256sums="14ddf192a9965c858c1e742a61456be2f34a4db87556172c0d76f08de96329b7  php-7.0.6.tar.bz2
 eca59e8b0498c1c93b35f9a5109ae56d0cda9d94822727d689371ccad31b3615  php7-fpm.initd
 6e4406f21b69085714cdb9d9a67c08e27a1c737ab353f9813cb2fc268352d2c6  php7-fpm.logrotate
 276c823ee666ea73b36d4e97174eeea05713125b61f7f8681e350453c4123143  php7-module.conf
@@ -422,7 +422,7 @@ f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab  install-pear.p
 ea74966a23b1b54548ee35e9ccc2fc8d2b7c2285c385c44d6b23d9e2f25ea1a7  includedir.patch
 0cca8729c64682387a8c44ed74f0966da697f2817152d8d05bb25bedc7eaafec  pid_log.patch
 ffc10d325be398a5560fe9265e89f056ef2eba27981c98300be30bbc2f18a4ec  fix-crypt.patch"
-sha512sums="13d6dcd339211b22761586f2804c7470634e00b36e5e0b7bcf5188c017f950cbf49a2d4dd41047a7d44c70ed9474097a7290fc84ee3c26532e2ad8a2cbe706d7  php-7.0.5.tar.bz2
+sha512sums="7f44cc5df3b9bb4394ac39069fdc2993086dd8e159e97275bf5fa4dd399d416e9ea1b057cdf855bae1c0f9c2129af1914495d9d2512ce90a7dd3ce4206aa9286  php-7.0.6.tar.bz2
 89076ab8e170a8f886b88bb30aa3e6a6b4463155a18ea53485cc9e3898c81afa3d01fb8403d28a45dc1680f09c645c2d81d8272bc8b9c7ced41e59b0ba226216  php7-fpm.initd
 cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691  php7-fpm.logrotate
 fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daebd48eed78b045dc051ced69fbf1f11efc7ad81d884a639a99  php7-module.conf
-- 
2.8.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Andy Blyler <[email-masked]>
Date: Fri, 29 Apr 2016 13:06:58 -0500

---
 testing/php7/APKBUILD        | 21 ++++++----------
 testing/php7/fix-crypt.patch | 59 --------------------------------------------
 2 files changed, 8 insertions(+), 72 deletions(-)
 delete mode 100644 testing/php7/fix-crypt.patch

diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index f53a6f8..d81acdc 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Valery Kartel <[email-masked]>
 pkgname=php7
 _pkgreal=php
-pkgver=7.0.5
+pkgver=7.0.6
 pkgrel=1
 pkgdesc="The PHP language runtime engine - 7th branch"
 url="http://www.php.net/"
@@ -86,9 +86,7 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
 	install-pear.patch
 	tidy-buffio.patch
 	includedir.patch
-	pid_log.patch
-	fix-crypt.patch
-	"
+	pid_log.patch"
 
 _apiver="20151012"
 _builddir="$srcdir"/$_pkgreal-$pkgver
@@ -404,30 +402,27 @@ xsl()		{ _mv_ext xsl $pkgname-dom; }
 zip()		{ _mv_ext zip; }
 zlib()		{ _mv_ext zlib; }
 
-md5sums="b15e6836babcbf0aa446678ee38f896b  php-7.0.5.tar.bz2
+md5sums="c89a1046ff06f6aff699057376e297b6  php-7.0.6.tar.bz2
 a340f27e83ed4482d2fbb98658ef71cb  php7-fpm.initd
 25bde13e7894c2930d97fad68d5dd3b3  php7-fpm.logrotate
 47be6cd1ed92f21579e15bf2003a709f  php7-module.conf
 483bc0a85c50a9a9aedbe14a19ed4526  install-pear.patch
 66f0037a029f9eed2b31d2e1d50f1860  tidy-buffio.patch
 d872e633c9b33c3c9f629dd2edd2e5c5  includedir.patch
-6ba762ab7a105163b8e5b3913deae109  pid_log.patch
-7f12fabdd1494e1c994cadd167e401d8  fix-crypt.patch"
-sha256sums="2c09af7fe64537ea795f098b9b542ead407ef83f7cdc65b3787115ccbbb51de9  php-7.0.5.tar.bz2
+6ba762ab7a105163b8e5b3913deae109  pid_log.patch"
+sha256sums="14ddf192a9965c858c1e742a61456be2f34a4db87556172c0d76f08de96329b7  php-7.0.6.tar.bz2
 eca59e8b0498c1c93b35f9a5109ae56d0cda9d94822727d689371ccad31b3615  php7-fpm.initd
 6e4406f21b69085714cdb9d9a67c08e27a1c737ab353f9813cb2fc268352d2c6  php7-fpm.logrotate
 276c823ee666ea73b36d4e97174eeea05713125b61f7f8681e350453c4123143  php7-module.conf
 f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab  install-pear.patch
 5dc8f32e5e2b1cd6317ada5a5adb9b5f0802ed6e0dbe065d7bfcc0f55d47e0d5  tidy-buffio.patch
 ea74966a23b1b54548ee35e9ccc2fc8d2b7c2285c385c44d6b23d9e2f25ea1a7  includedir.patch
-0cca8729c64682387a8c44ed74f0966da697f2817152d8d05bb25bedc7eaafec  pid_log.patch
-ffc10d325be398a5560fe9265e89f056ef2eba27981c98300be30bbc2f18a4ec  fix-crypt.patch"
-sha512sums="13d6dcd339211b22761586f2804c7470634e00b36e5e0b7bcf5188c017f950cbf49a2d4dd41047a7d44c70ed9474097a7290fc84ee3c26532e2ad8a2cbe706d7  php-7.0.5.tar.bz2
+0cca8729c64682387a8c44ed74f0966da697f2817152d8d05bb25bedc7eaafec  pid_log.patch"
+sha512sums="7f44cc5df3b9bb4394ac39069fdc2993086dd8e159e97275bf5fa4dd399d416e9ea1b057cdf855bae1c0f9c2129af1914495d9d2512ce90a7dd3ce4206aa9286  php-7.0.6.tar.bz2
 89076ab8e170a8f886b88bb30aa3e6a6b4463155a18ea53485cc9e3898c81afa3d01fb8403d28a45dc1680f09c645c2d81d8272bc8b9c7ced41e59b0ba226216  php7-fpm.initd
 cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691  php7-fpm.logrotate
 fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daebd48eed78b045dc051ced69fbf1f11efc7ad81d884a639a99  php7-module.conf
 f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505  install-pear.patch
 6894c9cba7752a3406e774d9efc0e058c37433493c1c20101e9563bf247c112157a67e306b06b9517b0422eca521f543d637a6cbd2cea7639e43f13d773b3d2b  tidy-buffio.patch
 199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b  includedir.patch
-82231c7b27b4d044272857dc713674884715ed8e36e54be06faa5d2a949ba4bca597628958a9c5683ec51c36e05a00f6be811c7e95112b0314c98528f584a8d6  pid_log.patch
-b4badb1850bf99210498d6e27136ee275379b5c39c52904b292aed204d5c95a845ed53db7dd56856121b3019ffefc7632419f9b2c45f431165ec0b5c5cbe974d  fix-crypt.patch"
+82231c7b27b4d044272857dc713674884715ed8e36e54be06faa5d2a949ba4bca597628958a9c5683ec51c36e05a00f6be811c7e95112b0314c98528f584a8d6  pid_log.patch"
diff --git a/testing/php7/fix-crypt.patch b/testing/php7/fix-crypt.patch
deleted file mode 100644
index 8f0d919..0000000
--- a/testing/php7/fix-crypt.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-https://bugs.php.net/bug.php?id=67512
-
---- php-7.0.4.orig/ext/standard/crypt.c
-+++ php-7.0.4/ext/standard/crypt.c
-@@ -58,6 +58,7 @@
- #include "php_lcg.h"
- #include "php_crypt.h"
- #include "php_rand.h"
-+#include "php_config.h"
- 
- /* The capabilities of the crypt() function is determined by the test programs
-  * run by configure from aclocal.m4.  They will set PHP_STD_DES_CRYPT,
-@@ -245,24 +246,27 @@
- 		}
- 	}
- #else
-+	if (salt[0] != '$' && salt[0] != '_' && (!IS_VALID_SALT_CHARACTER(salt[0]) || !IS_VALID_SALT_CHARACTER(salt[1]))) {
-+		if (!quiet) {
-+			/* error consistently about invalid DES fallbacks */
-+			php_error_docref(NULL, E_DEPRECATED, DES_INVALID_SALT_ERROR);
-+		}
-+	}
- 
--# if defined(HAVE_CRYPT_R) && (defined(_REENTRANT) || defined(_THREAD_SAFE))
- 	{
--#  if defined(CRYPT_R_STRUCT_CRYPT_DATA)
-+#  if defined(HAVE_CRYPT_R)
-+#    if defined(CRYPT_R_STRUCT_CRYPT_DATA)
- 		struct crypt_data buffer;
- 		memset(&buffer, 0, sizeof(buffer));
--#  elif defined(CRYPT_R_CRYPTD)
-+#    elif defined(CRYPT_R_CRYPTD)
- 		CRYPTD buffer;
-+#    else
-+#      error Data struct used by crypt_r() is unknown. Please report.
-+#    endif
-+		crypt_res = crypt_r(password, salt, &buffer);
- #  else
--#    error Data struct used by crypt_r() is unknown. Please report.
-+		crypt_res = crypt(password, salt, &buffer);
- #  endif
--		if (salt[0] != '$' && salt[0] != '_' && (!IS_VALID_SALT_CHARACTER(salt[0]) || !IS_VALID_SALT_CHARACTER(salt[1]))) {
--			if (!quiet) {
--				/* error consistently about invalid DES fallbacks */
--				php_error_docref(NULL, E_DEPRECATED, DES_INVALID_SALT_ERROR);
--			}
--		}
--		crypt_res = crypt_r(password, salt, &buffer);
- 		if (!crypt_res || (salt[0] == '*' && salt[1] == '0')) {
- 			return NULL;
- 		} else {
-@@ -270,7 +274,6 @@
- 			return result;
- 		}
- 	}
--# endif
- #endif
- }
- /* }}} */
-- 
2.8.1

---