Subject: [PATCH 1/2] testing/font-noto-emoji: remove, requires Python 2

From: Bart Ribbers <[email-masked]>
Date: Tue, 16 Jul 2019 21:49:19 +0200

---
 testing/font-noto-emoji/APKBUILD | 32 --------------------------------
 1 file changed, 32 deletions(-)
 delete mode 100644 testing/font-noto-emoji/APKBUILD

diff --git a/testing/font-noto-emoji/APKBUILD b/testing/font-noto-emoji/APKBUILD
deleted file mode 100644
index 788f8df238..0000000000
--- a/testing/font-noto-emoji/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Sören Tempel <[email-masked]>
-# Maintainer: Sören Tempel <[email-masked]>
-pkgname=font-noto-emoji
-pkgver=20180102
-_commit=153e1d4c026c124fbac6ee93e559b5df375f24f5
-pkgrel=1
-pkgdesc="Google Noto emoji fonts"
-url="https://www.google.com/get/noto/"
-arch="noarch"
-license="OFL-1.1"
-depends=""
-depends_dev=""
-makedepends="optipng py-fonttools>=3.21.2-r1 cairo-dev imagemagick
-	py-setuptools bash nototools libpng-dev python2"
-install=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-emoji/archive/${_commit}.tar.gz"
-builddir="$srcdir/noto-emoji-$_commit"
-
-build() {
-	cd "$builddir"
-	make || return 1
-}
-
-package() {
-	cd "$builddir"
-	mkdir -p "$pkgdir"/usr/share/fonts/noto/
-	install -m644 NotoColorEmoji.ttf fonts/NotoEmoji-Regular.ttf \
-		"$pkgdir"/usr/share/fonts/noto/ || return 1
-}
-
-sha512sums="b2da342ccee73e72aac41a59afe0a726acf66cd1314f9582eb890b80ab646a340db14acbf4bd3146de9f30b50f84f38f76ca56369b7ef4b70b3e901e31b72355  font-noto-emoji-20180102.tar.gz"
-- 
2.22.0

---

From: Bart Ribbers <[email-masked]>
Date: Tue, 16 Jul 2019 21:49:20 +0200

---
 testing/nototools/APKBUILD        | 36 -------------------------------
 testing/nototools/data_path.patch | 14 ------------
 testing/nototools/unichr.patch    | 11 ----------
 3 files changed, 61 deletions(-)
 delete mode 100644 testing/nototools/APKBUILD
 delete mode 100644 testing/nototools/data_path.patch
 delete mode 100644 testing/nototools/unichr.patch

diff --git a/testing/nototools/APKBUILD b/testing/nototools/APKBUILD
deleted file mode 100644
index 8aa4c67a9b..0000000000
--- a/testing/nototools/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Sören Tempel <[email-masked]>
-# Maintainer:
-pkgname=nototools
-pkgver=20171030
-_commit=3627598b4e858c6eb43e9ee76400d7072570a3e8
-pkgrel=0
-pkgdesc="Noto fonts support tools and scripts"
-url="https://www.google.com/get/noto/"
-arch="noarch"
-license="Apache-2.0"
-depends="python2"
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/$pkgname/archive/$_commit.tar.gz
-	data_path.patch
-	unichr.patch"
-builddir="$srcdir/$pkgname-$_commit"
-
-build() {
-	cd "$builddir"
-	python2 setup.py build || return 1
-}
-
-package() {
-	cd "$builddir"
-	python2 setup.py install --prefix=/usr \
-		--root="$pkgdir" || return 1
-
-	mkdir -p "$pkgdir"/usr/share/nototools
-	cp -r third_party "$pkgdir"/usr/share/nototools
-}
-
-sha512sums="d33ff3ac320b64cc41f5bf7f703084d5a954ca31cde55f1802344568a82421f7055b95c4953f8a3dc76fbc90cbcc3956505fc92d3eb33c1c90870fa4a9033e11  nototools-20171030.tar.gz
-e0d37ab7c2398695a00053c8c47346406d5cf8dda7ff3e24482d5318786794bb601fd2dd813437054b558d52df8934fc3050dc41a9ec9090a08835cabedaaa1c  data_path.patch
-507b929b029aa63095fc157237c526a527f6e58a7ef3c8f93c9880a7559cd5cf2ec98051a4825803acdbc3c56c661100e247b0cdd49b861d11ca98aa5a1d7964  unichr.patch"
diff --git a/testing/nototools/data_path.patch b/testing/nototools/data_path.patch
deleted file mode 100644
index bbfcefdc7c..0000000000
--- a/testing/nototools/data_path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -upr a/nototools/unicode_data.py b/nototools/unicode_data.py
---- a/nototools/unicode_data.py	2016-07-18 23:42:00.000000000 +0200
-+++ b/nototools/unicode_data.py	2016-12-16 01:27:55.783284557 +0100
-@@ -401,8 +401,7 @@ def all_scripts():
-   return frozenset(_script_code_to_long_name.keys())
- 
- 
--_DATA_DIR_PATH = path.join(path.abspath(path.dirname(__file__)),
--                           os.pardir, "third_party", "ucd")
-+_DATA_DIR_PATH = "/usr/share/nototools/third_party/ucd"
- 
- 
- def open_unicode_data_file(data_file_name):
-Only in b/nototools: unicode_data.py.orig
diff --git a/testing/nototools/unichr.patch b/testing/nototools/unichr.patch
deleted file mode 100644
index 325e8aaf6e..0000000000
--- a/testing/nototools/unichr.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -upr a/nototools/unicode_data.py b/nototools/unicode_data.py
---- a/nototools/unicode_data.py	2016-07-18 23:42:00.000000000 +0200
-+++ b/nototools/unicode_data.py	2016-12-16 01:26:52.293428181 +0100
-@@ -33,7 +33,6 @@ from os import path
- import re
- import sys
- 
--from fontTools.misc.py23 import unichr
- try:
-   import unicodedata2 as unicodedata  # Unicode 8 compliant native lib
- except ImportError:
-- 
2.22.0