Subject: [PATCH 1/3] testing/py3-junitparser: new aport

From: Marian Buschsieweke <[email-masked]>
Date: Thu, 18 Jul 2019 19:53:45 +0200

https://github.com/gastlygem/junitparser
Parses JUnit/xUnit Result XML files with ease
---
 testing/py3-junitparser/APKBUILD | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-junitparser/APKBUILD

diff --git a/testing/py3-junitparser/APKBUILD b/testing/py3-junitparser/APKBUILD
new file mode 100644
index 0000000000..81e1830964
--- /dev/null
+++ b/testing/py3-junitparser/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-junitparser
+_realname=junitparser
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Parses JUnit/xUnit Result XML files with ease"
+url="https://github.com/gastlygem/junitparser"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-future"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gastlygem/$_realname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ff196f8249044908a3b12262fdf694e95f451a5937e033a3dc1ab6e9a004fb2a3acff1feb55ee7d2d4ca396dc55e15b879eb67eafadef717e75056e7f9d27074  py3-junitparser-1.3.2.tar.gz"
-- 
2.22.0

---

From: Marian Buschsieweke <[email-masked]>
Date: Thu, 18 Jul 2019 19:53:46 +0200

Kiwi TCMS client library in Python
https://github.com/kiwitcms/tcms-api
---
 testing/py3-tcms-api/APKBUILD | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-tcms-api/APKBUILD

diff --git a/testing/py3-tcms-api/APKBUILD b/testing/py3-tcms-api/APKBUILD
new file mode 100644
index 0000000000..fed48d05b7
--- /dev/null
+++ b/testing/py3-tcms-api/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-tcms-api
+_realname=tcms-api
+pkgver=6.7
+pkgrel=0
+pkgdesc="Kiwi TCMS client library in Python"
+url="https://github.com/kiwitcms/tcms-api"
+arch="noarch"
+license="LGPL-2.1-only"
+depends="python3 py3-kerberos"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kiwitcms/$_realname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="4213157c35e01f313a3424e85a521d82e2e77e5eaa6ca633b736c1c4d40d3a1c2928a30722291401058ccf6a33e3f06924cf00910ec02efd38eecad42a5d7c37  py3-tcms-api-6.7.tar.gz"
-- 
2.22.0

---

From: Marian Buschsieweke <[email-masked]>
Date: Thu, 18 Jul 2019 19:53:47 +0200

junit.xml plugin for Kiwi TCMS
https://github.com/kiwitcms/junit.xml-plugin
---
 .../py3-kiwitcms-junit.xml-plugin/APKBUILD    | 27 +++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-kiwitcms-junit.xml-plugin/APKBUILD

diff --git a/testing/py3-kiwitcms-junit.xml-plugin/APKBUILD b/testing/py3-kiwitcms-junit.xml-plugin/APKBUILD
new file mode 100644
index 0000000000..43c901534b
--- /dev/null
+++ b/testing/py3-kiwitcms-junit.xml-plugin/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Marian Buschsieweke <[email-masked]>
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-kiwitcms-junit.xml-plugin
+_pkgname=kiwitcms-junit.xml-plugin
+pkgver=0.3
+pkgrel=0
+pkgdesc="junit.xml plugin for Kiwi TCMS"
+url="https://github.com/kiwitcms/junit.xml-plugin"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3 py3-tcms-api"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	python3 setup.py test
+}
+sha512sums="572bcfeb8fd4d757573b7bb87d17d17547614336deb4fb4b68f4a41fc5ceff6c081e837675e50e1165e640e46a0458202b6e175f0207578f5c28c926e1b03e17  py3-kiwitcms-junit.xml-plugin-0.3.tar.gz"
-- 
2.22.0