~alpine/aports

testing/libretro-core-info: new aport v2 PROPOSED

Bart Ribbers
Bart Ribbers: 2
 testing/libretro-core-info: new aport
 testing/retroarch: add retroarch-joypad-autoconfig and libretro-core-info to depends

 2 files changed, 19 insertions(+), 2 deletions(-)
Export patchset (mbox)
How do I use this?

Copy & paste the following snippet into your terminal to import this patchset into git:

curl -s https://lists.alpinelinux.org/~alpine/aports/patches/2860/mbox | git am -3
Learn more about email & git

[PATCH v2 1/2] testing/libretro-core-info: new aport Export this patch

Bart Ribbers
---
 testing/libretro-core-info/APKBUILD | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 testing/libretro-core-info/APKBUILD

diff --git a/testing/libretro-core-info/APKBUILD b/testing/libretro-core-info/APKBUILD
new file mode 100644
index 0000000000..7714f99349
--- /dev/null
+++ b/testing/libretro-core-info/APKBUILD
@@ -0,0 +1,17 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libretro-core-info
pkgver=1.7.7
pkgrel=0
arch="noarch"
url="https://www.libretro.com/"
pkgdesc="Libretro core info files"
license="none" # No code, just info files
source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/$pkgname/archive/v$pkgver.tar.gz"
options="!check" # No code to test

package() {
	DESTDIR="$pkgdir" make install
}

sha512sums="14c4689592a8a3d1b59fdba4eb4a3fdfe8bcf7eb683bcdb04545d3c53b95f1fce97264188d7c55eb56b034b5be77819de313e7cca8d7d7b402f829fbf3626f0f  libretro-core-info-1.7.7.tar.gz"
-- 
2.22.0

[PATCH v2 2/2] testing/retroarch: add retroarch-joypad-autoconfig and libretro-core-info to depends Export this patch

Bart Ribbers
---
 testing/retroarch/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/testing/retroarch/APKBUILD b/testing/retroarch/APKBUILD
index fd726eade9..91a11e4511 100644
--- a/testing/retroarch/APKBUILD
+++ b/testing/retroarch/APKBUILD
@@ -3,12 +3,12 @@
pkgname=retroarch
_pkgname=RetroArch
pkgver=1.7.7
pkgrel=2
pkgrel=3
arch="all"
url="https://www.libretro.com/"
pkgdesc="Reference frontend for the libretro API"
license="GPL-2.0-only"
depends="retroarch-assets"
depends="retroarch-assets retroarch-joypad-autoconfig libretro-core-info"
makedepends="linux-headers mesa-dev qt5-qtbase-dev wayland-dev wayland-protocols zlib-dev alsa-lib-dev pulseaudio-dev sdl2-dev flac-dev mbedtls-dev libusb-dev ffmpeg-dev libxkbcommon-dev eudev-dev vulkan-loader-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/$pkgname/archive/v$pkgver.tar.gz
	config.patch"
-- 
2.22.0
View this thread in the archives