Subject: [PATCH 1/2] testing/libretro-database: new aport

From: Bart Ribbers <[email-masked]>
Date: Wed, 21 Aug 2019 13:31:59 +0200

---
 testing/libretro-database/APKBUILD            | 19 +++++++++++++++++++
 .../fix-busybox-incompability.patch           | 13 +++++++++++++
 2 files changed, 32 insertions(+)
 create mode 100644 testing/libretro-database/APKBUILD
 create mode 100644 testing/libretro-database/fix-busybox-incompability.patch

diff --git a/testing/libretro-database/APKBUILD b/testing/libretro-database/APKBUILD
new file mode 100644
index 0000000000..513f0905ff
--- /dev/null
+++ b/testing/libretro-database/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Bart Ribbers <[email-masked]>
+# Maintainer: Bart Ribbers <[email-masked]>
+pkgname=libretro-database
+pkgver=1.7.7
+pkgrel=0
+arch="noarch"
+url="https://www.libretro.com/"
+pkgdesc="Libretro core info files"
+license="none" # No code, just info files
+source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/libretro-database/archive/v$pkgver.tar.gz
+	fix-busybox-incompability.patch"
+options="!check" # No code to test
+
+package() {
+	DESTDIR="$pkgdir" make install
+}
+
+sha512sums="9e0c590439e9de0e3d3ce3b0d43f777eb39e118753f4acd87d902329bbe6d2b6d18b7554bbaba2bc5b4e44c325490e5e543c5b07eae37be0cce41343d18b965b  libretro-database-1.7.7.tar.gz
+41670da3518bf5aa80f0916e94f81c6aed4c8ca5c1cae941c521440d5c019b96c3594e2efc3849e397d71deda8b9db7bed6fabb0ecf305572688179bbffc1406  fix-busybox-incompability.patch"
diff --git a/testing/libretro-database/fix-busybox-incompability.patch b/testing/libretro-database/fix-busybox-incompability.patch
new file mode 100644
index 0000000000..24c4467dc8
--- /dev/null
+++ b/testing/libretro-database/fix-busybox-incompability.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 0c3a33fd..65436325 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,7 +16,7 @@ all:
+ 
+ install:
+ 	mkdir -p $(DESTDIR)$(INSTALLDIR)
+-	cp -ar -t $(DESTDIR)$(INSTALLDIR) cht cursors rdb
++	cp -ar cht cursors rdb $(DESTDIR)$(INSTALLDIR)
+ 	find $(DESTDIR)$(INSTALLDIR) -type f -name "*.zip" -delete
+ 	find $(DESTDIR)$(INSTALLDIR) -type f -name "*.xml" -delete
+ 
-- 
2.21.0

---

From: Bart Ribbers <[email-masked]>
Date: Wed, 21 Aug 2019 13:32:00 +0200

---
 testing/retroarch/APKBUILD     |  6 +++---
 testing/retroarch/config.patch | 34 +++++++++++++++++++++++++++++-----
 2 files changed, 32 insertions(+), 8 deletions(-)

diff --git a/testing/retroarch/APKBUILD b/testing/retroarch/APKBUILD
index 1900646919..6136050ec5 100644
--- a/testing/retroarch/APKBUILD
+++ b/testing/retroarch/APKBUILD
@@ -3,12 +3,12 @@
 pkgname=retroarch
 _pkgname=RetroArch
 pkgver=1.7.7
-pkgrel=4
+pkgrel=5
 arch="all"
 url="https://retroarch.com"
 pkgdesc="Reference frontend for the libretro API"
 license="GPL-2.0-only"
-depends="retroarch-assets retroarch-joypad-autoconfig libretro-core-info"
+depends="retroarch-assets retroarch-joypad-autoconfig libretro-core-info libretro-database"
 makedepends="linux-headers mesa-dev qt5-qtbase-dev wayland-dev wayland-protocols zlib-dev alsa-lib-dev pulseaudio-dev sdl2-dev flac-dev mbedtls-dev libusb-dev ffmpeg-dev libxkbcommon-dev eudev-dev vulkan-loader-dev"
 source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/$pkgname/archive/v$pkgver.tar.gz
 	config.patch"
@@ -35,4 +35,4 @@ package() {
 }
 
 sha512sums="4ad70f092d1de34de5c4d2d83bae93ca26a1461e45e6bc17bbce9f3d6498d5639a3f97aa5881af29750377a819d4710c94a144450a3af54e0014b60790ba7155  retroarch-1.7.7.tar.gz
-4d17bb19fda8ba526b86c2283c39e06861c5bf603d969bfdabb30da03aba3307b4a0cdfc57b632ebf5c08abb9535b9dc0ccb4baf28aab6fcee6a42acfe846d73  config.patch"
+5a52f852831f7cef272373e100bd740c98a50ed52531ef1c5a715a4e648ca859f6243104ff13d2ba243f579d06b9658389155d3a09dc324712d3d63a56ebf578  config.patch"
diff --git a/testing/retroarch/config.patch b/testing/retroarch/config.patch
index fc5359975c..0fa34e3c98 100644
--- a/testing/retroarch/config.patch
+++ b/testing/retroarch/config.patch
@@ -1,9 +1,13 @@
 diff --git a/retroarch.cfg b/retroarch.cfg
-index 9d7c109bfe..f62b3018a2 100644
+index 9d7c109bfe..648fee1dc1 100644
 --- a/retroarch.cfg
 +++ b/retroarch.cfg
-@@ -642,7 +642,7 @@
- # menu_show_online_updater = true
+@@ -639,10 +639,10 @@
+ #### Menu
+ 
+ # If disabled, will hide 'Online Updater' inside the menu.
+-# menu_show_online_updater = true
++menu_show_online_updater = false
  
  # If disabled, will hide the ability to update cores (and core info files) inside the menu.
 -# menu_show_core_updater = true
@@ -11,6 +15,15 @@ index 9d7c109bfe..f62b3018a2 100644
  
  # If disabled, the libretro core will keep running in the background when we
  # are in the menu.
+@@ -655,7 +655,7 @@
+ # menu_mouse_enable = false
+ 
+ # Enable touch controls inside the menu.
+-# menu_pointer_enable = false
++menu_pointer_enable = true
+ 
+ # Shows current date and/or time inside menu.
+ # menu_timedate_enable = true
 @@ -771,7 +771,7 @@
  
  # Assets directory. This location is queried by default when menu interfaces try to look for
@@ -20,7 +33,7 @@ index 9d7c109bfe..f62b3018a2 100644
  
  # Dynamic wallpapers directory. The place to store the wallpapers dynamically
  # loaded by the menu depending on context.
-@@ -784,10 +784,10 @@
+@@ -784,19 +784,19 @@
  # rgui_browser_directory =
  
  # Core directory for libretro core implementations.
@@ -32,4 +45,15 @@ index 9d7c109bfe..f62b3018a2 100644
 +libretro_info_path = /usr/share/libretro/info
  
  # Path to content database directory.
- # content_database_path =
+-# content_database_path =
++content_database_path = /usr/share/libretro/database
+ 
+ # Saved queries are stored to this directory.
+ # cursor_directory =
+ 
+ # Path to cheat database directory.
+-# cheat_database_path =
++cheat_database_path = /usr/share/libretro/database
+ 
+ # Defines a directory where CPU-based video filters are kept.
+ # video_filter_dir =
-- 
2.21.0