Subject: [PATCH 1/5] testing/plymouth-kcm: new aport

From: Bart Ribbers <[email-masked]>
Date: Mon, 16 Sep 2019 13:43:15 +0200

---
 testing/plymouth-kcm/APKBUILD | 41 +++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
 create mode 100644 testing/plymouth-kcm/APKBUILD

diff --git a/testing/plymouth-kcm/APKBUILD b/testing/plymouth-kcm/APKBUILD
new file mode 100644
index 0000000000..24d038fc3f
--- /dev/null
+++ b/testing/plymouth-kcm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Bart Ribbers <[email-masked]>
+# Maintainer: Bart Ribbers <[email-masked]>
+pkgname=plymouth-kcm
+pkgver=5.16.5
+pkgrel=0
+arch="all"
+url="https://cgit.kde.org/plymouth-kcm.git"
+pkgdesc="KCM to manage the Plymouth (Boot) theme "
+license="GPL-2.0-or-later"
+depends="plymouth"
+makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev knewstuff-dev kio-dev kdeclarative-dev ki18n-dev kconfig-dev kconfigwidgets-dev plymouth-dev kcmutils"
+source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+prepare() {
+	default_prepare
+
+	mkdir "$builddir"/build
+}
+
+build() {
+	cd "$builddir"/build
+	cmake "$builddir" \
+		-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_INSTALL_LIBDIR=lib
+	make
+}
+
+check() {
+	cd "$builddir"/build
+	CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+	cd "$builddir"/build
+	DESTDIR="$pkgdir" make install
+}
+
+sha512sums="9544cd44cddb5736b38be649e61bf0ed0c7553ac0fa8e7de978e297cfa3d0046339832937ee8ca2e83f610b5516b90c512ebaeb20a9c66c7ea47fb93c1d3fd36  plymouth-kcm-5.16.5.tar.xz"
-- 
2.21.0

---

From: Bart Ribbers <[email-masked]>
Date: Mon, 16 Sep 2019 13:43:16 +0200

---
 {testing => community}/plymouth-kcm/APKBUILD | 0
 1 file changed, 0 insertions(+), 0 deletions(-)
 rename {testing => community}/plymouth-kcm/APKBUILD (100%)

diff --git a/testing/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
similarity index 100%
rename from testing/plymouth-kcm/APKBUILD
rename to community/plymouth-kcm/APKBUILD
-- 
2.21.0

---

From: Bart Ribbers <[email-masked]>
Date: Mon, 16 Sep 2019 13:43:17 +0200

---
 testing/breeze-plymouth/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/breeze-plymouth/APKBUILD

diff --git a/testing/breeze-plymouth/APKBUILD b/testing/breeze-plymouth/APKBUILD
new file mode 100644
index 0000000000..02e41af438
--- /dev/null
+++ b/testing/breeze-plymouth/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <[email-masked]>
+# Maintainer: Bart Ribbers <[email-masked]>
+pkgname=breeze-plymouth
+pkgver=5.16.5
+pkgrel=0
+arch="all"
+url="https://kde.org/"
+pkgdesc="Breeze theme for Plymouth"
+license="GPL-2.0-or-later"
+depends="plymouth"
+makedepends="extra-cmake-modules plymouth-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
+options="!check" # No tests
+
+build() {
+	# Get distro information to display on the splash screen
+	source /etc/os-release
+
+	cmake \
+		-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DDISTRO_NAME="$NAME" \
+		-DDISTRO_VERSION="$VERSION_ID"
+	make
+}
+
+package() {
+	DESTDIR="$pkgdir" make install
+}
+
+sha512sums="2934d43c44b5683964fd14b3a5498c41989c5fb69182b29cef9bc588470c299f16662028e8c2101228a3c3299789ffdc21e33ed49d90965a2add2d9bd79a4ee6  breeze-plymouth-5.16.5.tar.xz"
-- 
2.21.0

---

From: Bart Ribbers <[email-masked]>
Date: Mon, 16 Sep 2019 13:43:18 +0200

---
 {testing => community}/breeze-plymouth/APKBUILD | 0
 1 file changed, 0 insertions(+), 0 deletions(-)
 rename {testing => community}/breeze-plymouth/APKBUILD (100%)

diff --git a/testing/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
similarity index 100%
rename from testing/breeze-plymouth/APKBUILD
rename to community/breeze-plymouth/APKBUILD
-- 
2.21.0

---

From: Bart Ribbers <[email-masked]>
Date: Mon, 16 Sep 2019 13:43:19 +0200

---
 community/plasma/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/community/plasma/APKBUILD b/community/plasma/APKBUILD
index 75d3f8e6c8..7c27aea9d9 100644
--- a/community/plasma/APKBUILD
+++ b/community/plasma/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Bart Ribbers <[email-masked]>
 pkgname=plasma
 pkgver=5.16.5
-pkgrel=1
+pkgrel=2
 pkgdesc="Plasma (Base) meta package"
 url="https://kde.org/plasma-desktop"
 arch="noarch !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
@@ -50,7 +50,7 @@ package() {
 
 extras() {
 	pkgdesc="Additional Plasma apps meta package"
-	depends="oxygen breeze-grub plasma-sdk"
+	depends="oxygen breeze-grub plasma-sdk breeze-plymouth plymouth-kcm"
 
 	mkdir -p "$subpkgdir"
 }
-- 
2.21.0