Subject: [PATCH 1/2] testing/py3-html2text: new aport

From: Galen Abell <[email-masked]>
Date: Tue, 26 Nov 2019 17:47:53 +0100

https://github.com/Alir3z4/html2text
Convert HTML to Markdown-formatted text
testing/
---
 testing/py3-html2text/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/py3-html2text/APKBUILD

diff --git a/testing/py3-html2text/APKBUILD b/testing/py3-html2text/APKBUILD
new file mode 100644
index 0000000000..c8ad6ac6ac
--- /dev/null
+++ b/testing/py3-html2text/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Galen Abell <[email-masked]>
+# Maintainer: Galen Abell <[email-masked]>
+pkgname="py3-html2text"
+_pyname="html2text"
+pkgver="2019.8.11"
+pkgrel=0
+pkgdesc="Convert HTML to Markdown-formatted text"
+url="https://github.com/Alir3z4/html2text"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+options="!check" # TODO tests fail for some reason
+subpackages="$pkgname-doc"
+source="$_pyname-$pkgver.tar.gz::https://github.com/Alir3z4/html2text/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+doc() {
+	cd "$builddir"
+	mkdir -p "$subpkgdir/usr/share/doc/$_pyname"
+	mv docs/* "$subpkgdir/usr/share/doc/$_pyname"
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="a6638c026d9e6dc4bca880f9775ca9ada69d70cae40f18a8442966f2038ab3b8d52c91cb5eb4b698e4f96c6c799360410c6bf35206312806d84b42e4404d14c7  html2text-2019.8.11.tar.gz"
-- 
2.24.0

---

From: Galen Abell <[email-masked]>
Date: Tue, 26 Nov 2019 17:47:54 +0100

https://github.com/rss2email/rss2email
Forward RSS feeds to your email address, community maintained
testing/
---
 testing/py3-rss2email/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-rss2email/APKBUILD

diff --git a/testing/py3-rss2email/APKBUILD b/testing/py3-rss2email/APKBUILD
new file mode 100644
index 0000000000..77d0499117
--- /dev/null
+++ b/testing/py3-rss2email/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Galen Abell <[email-masked]>
+# Maintainer: Galen Abell <[email-masked]>
+pkgname="py3-rss2email"
+_pyname="rss2email"
+pkgver="3.11"
+pkgrel=0
+pkgdesc="Forward RSS feeds to your email address, community maintained"
+url="https://github.com/rss2email/rss2email"
+arch="noarch"
+license="GPL-2.0-only"
+depends="python3 py3-feedparser py3-html2text"
+makedepends="py3-setuptools"
+checkdepends="py3-beautifulsoup4"
+source="$_pyname-$pkgver.tar.gz::https://github.com/rss2email/rss2email/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="2efdef703a4b4774d85926f500a37689aea3a324f63a13a686a2322c9f69ac7b940c5b953f417d9259e1493b3dafde4c2e1ddb3433d085fb2400cd06001141bb  rss2email-3.11.tar.gz"
-- 
2.24.0