Subject: [PATCH] testing/telegraf: fix package setup

From: Galen Abell <[email-masked]>
Date: Sat, 4 Jan 2020 14:33:37 -0500

Telegraf's conf.d command line uses the additional config directory
`telegraf.d` (which is default for telegraf), but the package installs
the directory `telegraf.conf.d`.
---
 testing/telegraf/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/telegraf/APKBUILD b/testing/telegraf/APKBUILD
index 7ede05c220..fdfa9e87ff 100644
--- a/testing/telegraf/APKBUILD
+++ b/testing/telegraf/APKBUILD
@@ -44,7 +44,7 @@ package() {
 	install -Dm644 "$srcdir/$pkgname.confd" "$pkgdir/etc/conf.d/$pkgname"
 	install -Dm755 "$builddir/$pkgname" "$pkgdir/usr/bin/$pkgname"
 	install -Dm644 "$builddir/etc/$pkgname.conf" "$pkgdir/etc/$pkgname.conf"
-	install -dm755 "$pkgdir/etc/$pkgname.conf.d"
+	install -dm755 "$pkgdir/etc/$pkgname.d"
 }
 
 sha512sums="a28033aef4b21c3570f0e3bc4e316cd6da691069b7cd3faab5607a5990ec1f2a7d3cf73437ea75a98f825f99ccf47264984c93afe4eb63f348ed4912dea31a83  telegraf-1.13.0.tar.gz
-- 
2.24.1

---

From: Galen Abell <[email-masked]>
Date: Sun, 5 Jan 2020 12:47:52 -0500

Telegraf's conf.d command line uses the additional config directory
`telegraf.d`, but the package installs the directory `telegraf.conf.d`.
---
Bumped pkgrel (oops), switched -config-directory to /etc/telegraf.conf.d
rather than changing created directory.

 testing/telegraf/APKBUILD       | 2 +-
 testing/telegraf/telegraf.confd | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/testing/telegraf/APKBUILD b/testing/telegraf/APKBUILD
index 7ede05c220..cb0cb4c1a0 100644
--- a/testing/telegraf/APKBUILD
+++ b/testing/telegraf/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Konstantin Kulikov <[email-masked]>
 pkgname=telegraf
 pkgver=1.13.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A plugin-driven server agent for collecting & reporting metrics, part of the InfluxDB project"
 url="https://www.influxdata.com/time-series-platform/telegraf/"
 arch="x86_64 aarch64"
diff --git a/testing/telegraf/telegraf.confd b/testing/telegraf/telegraf.confd
index b29a46ea2a..bf6a22907d 100644
--- a/testing/telegraf/telegraf.confd
+++ b/testing/telegraf/telegraf.confd
@@ -1,4 +1,4 @@
-TELEGRAF_OPTS="-config /etc/telegraf.conf -config-directory /etc/telegraf.d"
+TELEGRAF_OPTS="-config /etc/telegraf.conf -config-directory /etc/telegraf.conf.d"
 
 # Uncomment to enable logging to syslog.
 #error_logger="logger -t $RC_SVCNAME"
-- 
2.24.1