Subject: [PATCH 1/2] testing/py3-mpd2: new aport

From: Galen Abell <[email-masked]>
Date: Mon, 10 Feb 2020 22:07:12 -0500

https://github.com/Mic92/python-mpd2
Python client interface for MPD
testing/
---
 testing/py3-mpd2/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-mpd2/APKBUILD

diff --git a/testing/py3-mpd2/APKBUILD b/testing/py3-mpd2/APKBUILD
new file mode 100644
index 0000000000..c3c316fde3
--- /dev/null
+++ b/testing/py3-mpd2/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Galen Abell <[email-masked]>
+# Maintainer: Galen Abell <[email-masked]>
+pkgname="py3-mpd2"
+_pyname="python-mpd2"
+pkgver="1.1.0"
+pkgrel=0
+pkgdesc="Python client interface for MPD"
+url="https://github.com/Mic92/python-mpd2"
+arch="noarch"
+license="LGPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-mock py3-twisted"
+source="$_pyname-$pkgver.tar.gz::https://github.com/Mic92/python-mpd2/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 -m unittest mpd.tests
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="65b17ae34b2c731b7d45801211e49eacfc18239d5575075be0c11ace350da19b82dd151fefc42077454a988d3deb1b489471f739ddea2d915cb3c241669dbe32  python-mpd2-1.1.0.tar.gz"
--
2.25.0

---

From: Galen Abell <[email-masked]>
Date: Mon, 10 Feb 2020 22:07:13 -0500

https://github.com/eonpatapon/mpDris2
MPRIS V2.1 support for mpd
testing/
---
 testing/mpdris2/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/mpdris2/APKBUILD

diff --git a/testing/mpdris2/APKBUILD b/testing/mpdris2/APKBUILD
new file mode 100644
index 0000000000..c5a6902039
--- /dev/null
+++ b/testing/mpdris2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Galen Abell <[email-masked]>
+# Maintainer: Galen Abell <[email-masked]>
+pkgname="mpdris2"
+pkgver="0.8"
+pkgrel=0
+pkgdesc="MPRIS V2.1 support for mpd"
+url="https://github.com/eonpatapon/mpDris2"
+arch="noarch"
+license="GPL-3.0-only"
+depends="py3-mpd2"
+makedepends="autoconf automake"
+options="!check" # no tests
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/eonpatapon/mpDris2/archive/$pkgver.tar.gz"
+builddir="$srcdir/mpDris2-$pkgver"
+
+build() {
+	./autogen.sh \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--localstatedir=/var
+	make
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+sha512sums="b3c2973723e9fb3140a4e6c9e3dfe66cc305c2ad5014e1e63a165e3ec371b4135570fdf72f57081e86420bd652a9baeb32fd229989582e5f115c8613e0759f52  mpdris2-0.8.tar.gz"
-- 
2.25.0