Subject: [PATCH 1/2] testing/sshign: upgrade to 0.2.1

From: Drew DeVault <[email-masked]>
Date: Mon, 29 Jun 2020 07:43:39 -0600

---
 testing/sshign/APKBUILD | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

diff --git a/testing/sshign/APKBUILD b/testing/sshign/APKBUILD
index 8ea1fbc7bf..ed48b930e6 100644
--- a/testing/sshign/APKBUILD
+++ b/testing/sshign/APKBUILD
@@ -1,14 +1,14 @@
 # Maintainer: Drew DeVault <[email-masked]>
 pkgname=sshign
-pkgver=0.1.0
-pkgrel=1
+pkgver=0.2.1
+pkgrel=0
 pkgdesc="Small program to sign & verify files with your SSH key"
 url="https://git.sr.ht/~minus/sshign"
 arch="all"
 license="MIT"
-makedepends="go"
+makedepends="go scdoc"
 source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~minus/sshign/archive/$pkgver.tar.gz"
-options="!check" # No upstream tests
+subpackages="$pkgname-doc"
 
 build() {
 	make PREFIX=/usr
@@ -18,4 +18,8 @@ package() {
 	make install PREFIX=/usr DESTDIR="$pkgdir"
 }
 
-sha512sums="284b56f7420fbf8a0a96fcb8456b28d9ed759320d1b3bc8c06f96211f535817fcc54a7a925807fe845b28e5294a76305fb15f566659eef1e8a2f70e51bb6fe2f  sshign-0.1.0.tar.gz"
+check() {
+	go test ./...
+}
+
+sha512sums="82b730d870b7319e690ec0ab46f42aa738f94491c0b0637b01421abb6d6f28daf444e453280b6c3e4bc11f10eeaf1ae08edb20713ce32d5abcae71e16e3b41f2  sshign-0.2.1.tar.gz"
-- 
2.27.0

---

From: Drew DeVault <[email-masked]>
Date: Mon, 29 Jun 2020 07:43:40 -0600

---
 {testing => community}/sshign/APKBUILD | 0
 1 file changed, 0 insertions(+), 0 deletions(-)
 rename {testing => community}/sshign/APKBUILD (100%)

diff --git a/testing/sshign/APKBUILD b/community/sshign/APKBUILD
similarity index 100%
rename from testing/sshign/APKBUILD
rename to community/sshign/APKBUILD
-- 
2.27.0