Subject: [PATCH 1/5] testing/py3-dict2xml: new aport

From: Drew DeVault <[email-masked]>
Date: Mon, 19 Oct 2020 22:23:33 -0400

---
 testing/py3-dict2xml/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-dict2xml/APKBUILD

diff --git a/testing/py3-dict2xml/APKBUILD b/testing/py3-dict2xml/APKBUILD
new file mode 100644
index 0000000000..1256a3733d
--- /dev/null
+++ b/testing/py3-dict2xml/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py3-dict2xml
+_pyname=dict2xml
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Small utility to convert a python dictionary into an XML string"
+url="https://github.com/delfick/python-dict2xml"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py check
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="7ed2af3facc81d70b1ccb1a1ffacdd7f72a38b7435048f170f657e8b48f3f9a144238df93e577ea8d3bfae019edfbbe35da7b2e7cd82fbb8f59cd3f646ac6a6e  dict2xml-1.7.0.tar.gz"
-- 
2.28.0

---

From: Drew DeVault <[email-masked]>
Date: Mon, 19 Oct 2020 22:23:34 -0400

---
 testing/py3-i18naddress/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-i18naddress/APKBUILD

diff --git a/testing/py3-i18naddress/APKBUILD b/testing/py3-i18naddress/APKBUILD
new file mode 100644
index 0000000000..a333b87262
--- /dev/null
+++ b/testing/py3-i18naddress/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py3-i18naddress
+_pyname=google-i18n-address
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="Address validation helpers for Google's i18n address database"
+url="https://github.com/mirumee/google-i18n-address"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py check
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="a64e598b838f9d83b70b4f6acb3dc6c8930239e44b726f39a8f973334e2927d0394d1f323ca53acd43f4d9abede2a7ee48427f48a90427cbae7aada4cd8f08a5  google-i18n-address-2.4.0.tar.gz"
-- 
2.28.0

---

From: Drew DeVault <[email-masked]>
Date: Mon, 19 Oct 2020 22:23:35 -0400

---
 community/py3-configargparse/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/community/py3-configargparse/APKBUILD b/community/py3-configargparse/APKBUILD
index 59f34e4308..911dcb736c 100644
--- a/community/py3-configargparse/APKBUILD
+++ b/community/py3-configargparse/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Stuart Cardall <[email-masked]>
 pkgname=py3-configargparse
 _pkgname=ConfigArgParse
-pkgver=0.15.2
+pkgver=1.2.3
 pkgrel=0
 pkgdesc="A drop-in replacement for argparse"
 url="https://github.com/bw2/ConfigArgParse"
@@ -31,5 +31,5 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="c8403751506b3ce096d707067659492422ecef8e684107935ab26f2e518c7c2c4baca8882cac55dd1961a86e5ad95b73389bc1a681cd2a67b5000bd6d626d2d9  py3-configargparse-0.15.2.tar.gz
+sha512sums="bfa8f9ca8ab5c6d4cdf2a7e7c577c99fafdf7f743c81057bebbb6045c45de2cdbf5d738f7765e5dcac5a45baa92e2a8bc7ad3879776b9cf4862e3da94e78c4cc  py3-configargparse-1.2.3.tar.gz
 32171e9ed37e0662bdb8cd95f9a3ec25fd1fe1e9f68047ecc1da4f20278fe1bc56707a4d21654b75421ecb13f2307817b7116fdb6fc8d44df59c993027511d83  skip-failing-tests.patch"
-- 
2.28.0

---

From: Drew DeVault <[email-masked]>
Date: Mon, 19 Oct 2020 22:23:36 -0400

---
 testing/py3-intervaltree/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-intervaltree/APKBUILD

diff --git a/testing/py3-intervaltree/APKBUILD b/testing/py3-intervaltree/APKBUILD
new file mode 100644
index 0000000000..a33250b8ba
--- /dev/null
+++ b/testing/py3-intervaltree/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py3-intervaltree
+_pyname=intervaltree
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="Editable interval tree data structure for Python"
+url="https://github.com/chaimleib/intervaltree"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-sortedcontainers"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py check
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="adb49726912ad6e9cf6c0985b4fb94df91b4ef54aa2eb327186d7f15bc992745d81654d49f1dd2ce95f7173683ba2a072787ef1e8b389cd9b7e23b9ae743906a  intervaltree-3.1.0.tar.gz"
-- 
2.28.0

---

From: Drew DeVault <[email-masked]>
Date: Mon, 19 Oct 2020 22:23:37 -0400

---
 testing/xml2rfc/APKBUILD | 19 ++++++++++++++++---
 1 file changed, 16 insertions(+), 3 deletions(-)

diff --git a/testing/xml2rfc/APKBUILD b/testing/xml2rfc/APKBUILD
index 6b041214e5..807cf78efe 100644
--- a/testing/xml2rfc/APKBUILD
+++ b/testing/xml2rfc/APKBUILD
@@ -2,14 +2,27 @@
 # Maintainer:
 pkgname=xml2rfc
 pkgver=3.2.1
-pkgrel=0
+pkgrel=1
 pkgdesc="tool for converting XML documents into internet drafts and RFCs"
-options="!check" # Requires unpackaged i18naddress
 url="https://tools.ietf.org/"
 arch="noarch"
 license="BSD-2-Clause"
-depends="python3 py3-setuptools py3-six py3-requests py3-lxml"
+depends="
+	py3-configargparse
+	py3-dict2xml
+	py3-i18naddress
+	py3-intervaltree
+	py3-kitchen
+	py3-lxml
+	py3-pycountry
+	py3-pyflakes
+	py3-pypdf2
+	py3-requests
+	py3-six
+"
+makedepends="py3-setuptools"
 source="https://files.pythonhosted.org/packages/source/x/xml2rfc/xml2rfc-$pkgver.tar.gz"
+options="!check" # Requires Noto fonts for PDF tests
 
 build() {
 	python3 setup.py build
-- 
2.28.0