Subject: [PATCH 1/2] community/newsflash: upgrade to 1.4.3

From: Alistair Francis <[email-masked]>
Date: Tue, 7 Sep 2021 20:42:19 +1000

Signed-off-by: Alistair Francis <[email-masked]>
---
 community/newsflash/APKBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index c613c7b1ab..5311e07421 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -1,16 +1,16 @@
 # Contributor: Alex McGrath <[email-masked]>
 # Maintainer: Alex McGrath <[email-masked]>
 pkgname=newsflash
-pkgver=1.4.2
+pkgver=1.4.3
 pkgrel=0
 pkgdesc="An rss feed reader that supports various web based services"
 url="https://gitlab.com/news-flash/news_flash_gtk/"
 arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
 license="GPL-3.0-only"
 makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl-dev"
-source="newsflash-$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/$pkgver/news_flash_gtk-$pkgver.tar.gz"
+source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz"
 options="!check" # no tests
-builddir="$srcdir/news_flash_gtk-$pkgver"
+builddir="$srcdir/news_flash_gtk-v.$pkgver"
 
 build() {
 	export RUSTC_BOOTSTRAP=obfstr
@@ -23,5 +23,5 @@ package() {
 }
 
 sha512sums="
-28a50818dceaceccfe02d5016689ef666294d6c55a8dea0a2cafb470f27d3965acabe2c34c0539e58e43180ec3b8c8e9a8e4fa3596296bb9a8837c8431f0f50d  newsflash-1.4.2.tar.gz
+d5048644563d0afbb273422c2316148c97e05e20b4f1aaab71206fb34e13b31cadf268752fbe09036ae8c0cb7d80ce36a4748d114d35047249daf92cfa641df3  news_flash_gtk-v.1.4.3.tar.gz
 "
-- 
2.31.1

---

From: Alistair Francis <[email-masked]>
Date: Tue, 7 Sep 2021 20:42:20 +1000

Apply a patch to bump the NewsBlur API crate to fix a login failure.

Signed-off-by: Alistair Francis <[email-masked]>
---
 ...rgo.lock-Bump-the-newsblur-API-crate.patch | 29 +++++++++++++++++++
 community/newsflash/APKBUILD                  |  7 +++--
 2 files changed, 34 insertions(+), 2 deletions(-)
 create mode 100644 community/newsflash/0001-Cargo.lock-Bump-the-newsblur-API-crate.patch

diff --git a/community/newsflash/0001-Cargo.lock-Bump-the-newsblur-API-crate.patch b/community/newsflash/0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
new file mode 100644
index 0000000000..76ee4dde88
--- /dev/null
+++ b/community/newsflash/0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
@@ -0,0 +1,29 @@
+From 5581648af0c87378e79a6c4ec214f6954949176c Mon Sep 17 00:00:00 2001
+From: Alistair Francis <[email-masked]>
+Date: Tue, 7 Sep 2021 20:33:26 +1000
+Subject: [PATCH] Cargo.lock: Bump the newsblur API crate
+
+Signed-off-by: Alistair Francis <[email-masked]>
+---
+ Cargo.lock | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index 93be16f..ef89dc1 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -1890,9 +1890,9 @@ dependencies = [
+ 
+ [[package]]
+ name = "newsblur_api"
+-version = "0.1.1"
++version = "0.1.2"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "fd77391c1b68a5678882fb3bf2777dfa3761d2c0615e8b4c60d29199b3b405d2"
++checksum = "78451667cd4ba4d62baa55f6b71346c1d30c8300b13e3262d17a6d973fcbec14"
+ dependencies = [
+  "failure",
+  "reqwest",
+-- 
+2.31.1
+
diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index 5311e07421..814d235e51 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -2,13 +2,15 @@
 # Maintainer: Alex McGrath <[email-masked]>
 pkgname=newsflash
 pkgver=1.4.3
-pkgrel=0
+pkgrel=1
 pkgdesc="An rss feed reader that supports various web based services"
 url="https://gitlab.com/news-flash/news_flash_gtk/"
 arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
 license="GPL-3.0-only"
 makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl-dev"
-source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz"
+source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/v.$pkgver/news_flash_gtk-v.$pkgver.tar.gz
+	0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
+	"
 options="!check" # no tests
 builddir="$srcdir/news_flash_gtk-v.$pkgver"
 
@@ -24,4 +26,5 @@ package() {
 
 sha512sums="
 d5048644563d0afbb273422c2316148c97e05e20b4f1aaab71206fb34e13b31cadf268752fbe09036ae8c0cb7d80ce36a4748d114d35047249daf92cfa641df3  news_flash_gtk-v.1.4.3.tar.gz
+444b77082d44d5c710d19d752dfd885442cc85c5f1bf3eda2280baed8b0937b1e2175433db93b3b6ce741f94fd71cf8f5ed265852813a0b446bebff51f8c5fc1  0001-Cargo.lock-Bump-the-newsblur-API-crate.patch
 "
-- 
2.31.1