Subject: [PATCH 1/3] testing/py3-sphinx-autorun: add aport

From: Dhruvin Gandhi <[email-masked]>
Date: Fri, 10 Dec 2021 18:11:09 +0530

---
 testing/py3-sphinx-autorun/APKBUILD | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-sphinx-autorun/APKBUILD

diff --git a/testing/py3-sphinx-autorun/APKBUILD b/testing/py3-sphinx-autorun/APKBUILD
new file mode 100644
index 0000000000..d19ac7cce3
--- /dev/null
+++ b/testing/py3-sphinx-autorun/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=py3-sphinx-autorun
+_pyname=sphinx-autorun
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Sphinx extension to attach the output of runblock directive to the document"
+url="https://github.com/WhyNotHugo/sphinx-autorun"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-sphinx"
+makedepends="py3-setuptools py3-setuptools_scm"
+options="!check" # no tests
+source="https://files.pythonhosted.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+cfe99a9cd249d142fa52986964bca7fa392d15036e69f504b3ea0fdabd37a7c43329101df7cb5d02ff614b9da9cbef15a39f519bf416daa0589829fb7b21a482  sphinx-autorun-1.1.1.tar.gz
+"
-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Fri, 10 Dec 2021 18:11:10 +0530

---
 testing/py3-sphinx-click/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/py3-sphinx-click/APKBUILD

diff --git a/testing/py3-sphinx-click/APKBUILD b/testing/py3-sphinx-click/APKBUILD
new file mode 100644
index 0000000000..2632b995ff
--- /dev/null
+++ b/testing/py3-sphinx-click/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=py3-sphinx-click
+_pyname=sphinx-click
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Sphinx plugin to extract documentation from click-based applications"
+url="https://github.com/click-contrib/sphinx-click"
+arch="noarch"
+license="MIT"
+depends="python3 py3-sphinx py3-click py3-docutils"
+makedepends="py3-setuptools py3-pbr"
+checkdepends="py3-pytest py3-click py3-coverage"
+source="https://files.pythonhosted.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	pytest
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+dcf60ca31dcc7c1f45157ed88a5d723d8b531f01b617fb0cc4ada8f09c709b23b55a86bcf8bbe66bf4c2f5ef77329123d271724887022a43b86747087e87ed7c  sphinx-click-3.0.2.tar.gz
+"
-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Fri, 10 Dec 2021 18:11:11 +0530

---
 testing/todoman/APKBUILD               | 49 +++++++++++---------------
 testing/todoman/remove-rtd-theme.patch | 21 +++++++++++
 2 files changed, 41 insertions(+), 29 deletions(-)
 create mode 100644 testing/todoman/remove-rtd-theme.patch

diff --git a/testing/todoman/APKBUILD b/testing/todoman/APKBUILD
index 2b319744e8..7672606e1c 100644
--- a/testing/todoman/APKBUILD
+++ b/testing/todoman/APKBUILD
@@ -1,47 +1,38 @@
 # Contributor: Philipp Glaum <[email-masked]>
-# Maintainer: Philipp Glaum <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
 pkgname=todoman
-_pkgname=todoman
-pkgver=3.8.0
-pkgrel=2
+pkgver=4.0.1
+pkgrel=0
 pkgdesc="A simple CalDav-based todo manager"
 url="https://pypi.org/project/todoman/"
 arch="noarch"
 license="ISC"
-depends="python3
-	py3-atomicwrites
-	py3-click
-	py3-click-log
-	py3-configobj
-	py3-humanize
-	py3-icalendar
-	py3-parsedatetime
-	py3-dateutil
-	py3-xdg
-	py3-tabulate
-	py3-urwid
-	"
-makedepends="py3-setuptools_scm py3-setuptools"
-checkdepends="py3-flake8
-	py3-flake8-import-order
-	py3-freezegun
-	py3-hypothesis
-	py3-pytest
-	py3-pytest-cov
-	py3-pytest-runner
-	"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+depends="python3 py3-atomicwrites py3-click py3-click-log py3-humanize py3-icalendar
+	py3-parsedatetime py3-dateutil py3-xdg py3-tabulate py3-urwid"
+makedepends="py3-setuptools py3-setuptools_scm py3-sphinx py3-sphinx-click
+	py3-sphinx-autorun"
+checkdepends="py-tox py3-flake8 py3-flake8-import-order py3-freezegun py3-hypothesis
+	py3-pytest py3-pytest-cov py3-pytest-runner"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
+	remove-rtd-theme.patch"
+subpackages="$pkgname-doc"
+builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
 	python3 setup.py build
+	make -C docs man PYTHONPATH="$PWD"
 }
 
 check() {
-	python3 setup.py test
+	tox -e py39
 }
 
 package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	install -Dm644 docs/build/man/todo.1 "$pkgdir"/usr/share/man/man1/todo.1
 }
 
-sha512sums="67cb498265fdb802ca0993618ae8e06918d0440d6f1092d155571d85a507f098e9e172e852b82f3854a965d72c57aba749ad964922f274be03181def4a527198  todoman-3.8.0.tar.gz"
+sha512sums="
+606be4553330741bb664c2261ba33f9feb68023c38c4e5278febadae3c9267d5bcc0b63966a41ac3d2ec38f44c16f9368ec502d2ce1a782a9108ca4a38d9e04c  todoman-4.0.1.tar.gz
+2eb6a2f3af64c23004a278aea52120dd0376d3b37a9aafdda233d47de530f99adf75e4bbb82678353eddf42229c9713dcf8d939a12c157f910f3c774f947ab64  remove-rtd-theme.patch
+"
diff --git a/testing/todoman/remove-rtd-theme.patch b/testing/todoman/remove-rtd-theme.patch
new file mode 100644
index 0000000000..68b97223b2
--- /dev/null
+++ b/testing/todoman/remove-rtd-theme.patch
@@ -0,0 +1,21 @@
+--- a/docs/source/conf.py
++++ b/docs/source/conf.py
+@@ -42,7 +42,6 @@
+     "sphinx_autorun",
+     "sphinx.ext.todo",
+     "sphinx.ext.viewcode",
+-    "sphinx_rtd_theme",
+ ]
+ 
+ source_suffix = ".rst"
+@@ -63,10 +62,6 @@
+ 
+ # If true, `todo` and `todoList` produce output, else they produce nothing.
+ todo_include_todos = True
+-
+-# -- Options for HTML output ----------------------------------------------
+-
+-html_theme = "sphinx_rtd_theme"
+ 
+ # -- Options for manual page output ---------------------------------------
+ 
-- 
2.34.1