Subject: [PATCH v3 1/3] testing/hledger: new aport

From: Dhruvin Gandhi <[email-masked]>
Date: Mon, 13 Dec 2021 11:49:34 +0530

---
 testing/hledger/APKBUILD | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 testing/hledger/APKBUILD

diff --git a/testing/hledger/APKBUILD b/testing/hledger/APKBUILD
new file mode 100644
index 0000000000..4b88c431a2
--- /dev/null
+++ b/testing/hledger/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=hledger
+pkgver=1.24.1
+pkgrel=0
+pkgdesc="Command-line interface for the hledger accounting system"
+url="https://hledger.org/hledger.html"
+arch="x86_64" # limited by ghc
+license="GPL-3.0-only"
+makedepends="ghc cabal libffi-dev ncurses-dev"
+subpackages="$pkgname-doc $pkgname-bash-completion"
+source="https://hackage.haskell.org/package/hledger-$pkgver/hledger-$pkgver.tar.gz"
+
+export CABAL_DIR="$srcdir"/cabal
+
+build() {
+	cabal update
+	cabal build --prefix=/usr --enable-relocatable
+}
+
+check() {
+	cabal test
+}
+
+package() {
+	local ghcver=$(ghc --version | cut -d " " -f 8)
+	install -Dm755 \
+		"dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
+		"$pkgdir"/usr/bin/$pkgname
+	install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+	install -Dm644 shell-completion/$pkgname-completion.bash \
+		"$pkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+sha512sums="
+0941258f7c6f699967261eaf9e20c1f81f6694b8f559ac1e729f37cff64dce3b787447f69c222115437318e8ccd6c4273e52befa41b3419f8fb4cc131c7fcdf7  hledger-1.24.1.tar.gz
+"
-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Mon, 13 Dec 2021 11:49:35 +0530

---
 testing/hledger-ui/APKBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/hledger-ui/APKBUILD

diff --git a/testing/hledger-ui/APKBUILD b/testing/hledger-ui/APKBUILD
new file mode 100644
index 0000000000..1930eed76b
--- /dev/null
+++ b/testing/hledger-ui/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=hledger-ui
+pkgver=1.24.1
+pkgrel=0
+pkgdesc="Curses-style terminal interface for the hledger accounting system"
+url="https://hledger.org/hledger-ui.html"
+arch="x86_64" # limited by ghc
+license="GPL-3.0-only"
+makedepends="ghc cabal libffi-dev ncurses-dev"
+subpackages="$pkgname-doc"
+source="https://hackage.haskell.org/package/hledger-ui-$pkgver/hledger-ui-$pkgver.tar.gz"
+
+export CABAL_DIR="$srcdir"/cabal
+
+build() {
+	cabal update
+	cabal build --prefix=/usr --enable-relocatable
+}
+
+check() {
+	cabal test
+}
+
+package() {
+	local ghcver=$(ghc --version | cut -d " " -f 8)
+	install -Dm755 \
+		"dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
+		"$pkgdir"/usr/bin/$pkgname
+	install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="
+9a71ba18c76a477a12df34adb4d1d11e5a72769b14e27950ff675107faf210dbe9ee18d4e6bf13151789f73591e72b62fb7f3ea581a2ddff6457814d9220f4d4  hledger-ui-1.24.1.tar.gz
+"
-- 
2.34.1

---

From: Dhruvin Gandhi <[email-masked]>
Date: Mon, 13 Dec 2021 11:49:36 +0530

---
 testing/hledger-web/APKBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/hledger-web/APKBUILD

diff --git a/testing/hledger-web/APKBUILD b/testing/hledger-web/APKBUILD
new file mode 100644
index 0000000000..e3b5252b92
--- /dev/null
+++ b/testing/hledger-web/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dhruvin Gandhi <[email-masked]>
+# Maintainer: Dhruvin Gandhi <[email-masked]>
+pkgname=hledger-web
+pkgver=1.24.1
+pkgrel=0
+pkgdesc="Web interface for the hledger accounting system"
+url="https://hledger.org/hledger-web.html"
+arch="x86_64" # limited by ghc
+license="GPL-3.0-only"
+makedepends="ghc cabal libffi-dev ncurses-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://hackage.haskell.org/package/hledger-web-$pkgver/hledger-web-$pkgver.tar.gz"
+
+export CABAL_DIR="$srcdir"/cabal
+
+build() {
+	cabal update
+	cabal build --prefix=/usr --enable-relocatable
+}
+
+check() {
+	cabal test
+}
+
+package() {
+	local ghcver=$(ghc --version | cut -d " " -f 8)
+	install -Dm755 \
+		"dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
+		"$pkgdir"/usr/bin/$pkgname
+	install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="
+49e6292faad4a1311d1af950a98a546e6ec61f5dfa97539e62a806e63bbd43351861ab4c45f8eb7284e98367fb92e206a217e998c6572ca8b2f37e91bb93daaf  hledger-web-1.24.1.tar.gz
+"
-- 
2.34.1