Subject: [PATCH 1/2] main/iputils: upgrade to 20211215

From: Petr Vorel <[email-masked]>
Date: Wed, 15 Dec 2021 19:54:54 +0100

tftp and traceroute6 has been removed in this release [1][2].

[1] https://github.com/iputils/iputils/pull/369
[2] https://github.com/iputils/iputils/pull/362

Signed-off-by: Petr Vorel <[email-masked]>
---
 main/iputils/APKBUILD | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/main/iputils/APKBUILD b/main/iputils/APKBUILD
index cc8b954373..e0da44b8a5 100644
--- a/main/iputils/APKBUILD
+++ b/main/iputils/APKBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=iputils
-pkgver=20210722
+pkgver=20211215
 pkgrel=0
 pkgdesc="IP Configuration Utilities (and Ping)"
 options="!check suid"
@@ -15,8 +15,6 @@ build() {
 	abuild-meson \
 		-DNO_SETCAP_OR_SUID=true \
 		-DBUILD_RARPD=true \
-		-DBUILD_TFTPD=true \
-		-DBUILD_TRACEROUTE6=true \
 		-DBUILD_MANS=false \
 		-DUSE_IDN=false \
 		-DUSE_GETTEXT=false \
@@ -28,12 +26,12 @@ package() {
 	local name
 	cd "$builddir"/build
 
-	for name in arping clockdiff rarpd rdisc tftpd/tftpd tracepath; do
+	for name in arping clockdiff rarpd rdisc tracepath; do
 		install -D -m755 $name "$pkgdir"/usr/sbin/${name##*/}
 	done
 	install -D -m755 ninfod/ninfod "$pkgdir"/usr/sbin/ninfod
 
-	for name in ping/ping traceroute6; do
+	for name in ping/ping; do
 		install -D -m4755 $name "$pkgdir"/bin/${name##*/}
 	done
 
@@ -42,5 +40,5 @@ package() {
 }
 
 sha512sums="
-8f85bf468f8ef1e2832e9bbf9009552df4a6d723dd130fa0d5b2aa3bae617c972f936143c2370c3b4ce2ba2499828c91a299ee42cf81fa81aabe10552db2b328  iputils-20210722.tar.gz
+191062e51f7c8e8b38e3e4a96845adb77cd69f487d548c7cc578fad544443b4bc0dbe965d8f8e6fbda0a2f5b2fe2829789c05f873190c53d773245959298f6e9  iputils-20211215.tar.gz
 "
-- 
2.34.1

---

From: Petr Vorel <[email-masked]>
Date: Wed, 15 Dec 2021 19:54:55 +0100

ninfod, rarpd, rdisc are legacy tools which are going to be removed from
upstream in next release [1], following previous removals [2].
Remove them now from Alpine.

[1] https://github.com/iputils/iputils/pull/388
[2] https://github.com/iputils/iputils/issues/363

Signed-off-by: Petr Vorel <[email-masked]>
---
 main/iputils/APKBUILD | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/main/iputils/APKBUILD b/main/iputils/APKBUILD
index e0da44b8a5..a944d603b7 100644
--- a/main/iputils/APKBUILD
+++ b/main/iputils/APKBUILD
@@ -14,7 +14,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/iputils/iputils/archive/$pkg
 build() {
 	abuild-meson \
 		-DNO_SETCAP_OR_SUID=true \
-		-DBUILD_RARPD=true \
+		-DBUILD_NINFOD=false \
+		-DBUILD_RARPD=false \
+		-DBUILD_RDISC=false \
 		-DBUILD_MANS=false \
 		-DUSE_IDN=false \
 		-DUSE_GETTEXT=false \
@@ -26,14 +28,11 @@ package() {
 	local name
 	cd "$builddir"/build
 
-	for name in arping clockdiff rarpd rdisc tracepath; do
+	for name in arping clockdiff tracepath; do
 		install -D -m755 $name "$pkgdir"/usr/sbin/${name##*/}
 	done
-	install -D -m755 ninfod/ninfod "$pkgdir"/usr/sbin/ninfod
 
-	for name in ping/ping; do
-		install -D -m4755 $name "$pkgdir"/bin/${name##*/}
-	done
+	install -D -m4755 ping/ping "$pkgdir"/bin/ping
 
 	ln -s tracepath "$pkgdir"/usr/sbin/tracepath6
 	ln -s ping "$pkgdir"/bin/ping6
-- 
2.34.1