Subject: [PATCH] testing/bindfs: new aport

From: Daniel Gerber <[email-masked]>
Date: Fri, 17 Dec 2021 10:21:46 +0100

https://bindfs.org
FUSE filesystem for mirroring a directory to another directory
---
 testing/bindfs/APKBUILD                   | 43 +++++++++++++++++++++++
 testing/bindfs/musl-getmntent-issue.patch | 18 ++++++++++
 2 files changed, 61 insertions(+)
 create mode 100644 testing/bindfs/APKBUILD
 create mode 100644 testing/bindfs/musl-getmntent-issue.patch

diff --git a/testing/bindfs/APKBUILD b/testing/bindfs/APKBUILD
new file mode 100644
index 0000000000..b207572b1c
--- /dev/null
+++ b/testing/bindfs/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Daniel Gerber <[email-masked]>
+# Maintainer:
+pkgname=bindfs
+pkgver=1.15.1
+pkgrel=0
+pkgdesc="FUSE filesystem for mirroring a directory to another directory"
+url="https://bindfs.org"
+arch="all"
+license="GPL-2.0-or-later"
+depends="fuse3"						  # or fuse
+makedepends="fuse3-dev"				  # or fuse-dev
+checkdepends="ruby ruby-etc"
+install=""
+subpackages="$pkgname-doc"
+source="https://bindfs.org/downloads/bindfs-$pkgver.tar.gz
+	musl-getmntent-issue.patch"
+builddir="$srcdir/bindfs-$pkgver"
+
+
+build() {
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--localstatedir=/var
+	make
+}
+
+check() {
+	# NOTE: this requires the fuse kernel module to be loaded
+	make check
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+da9003f141b7aa2c23651b3b836b1d979bf1b19915f307c05e40ae6906aab738036cc8b5df6caeec158e4fa6b7bca71489ea7884ff1607c6fea72a603a048d59  bindfs-1.15.1.tar.gz
+1c6491241393974923ed512ac2621c864f6f5e9f7e6faca83154cb785332049b49e18dda31ce297a4531bb0abf42d5039c996d0223eac105b0b7af377fd8c2ec  musl-getmntent-issue.patch
+"
diff --git a/testing/bindfs/musl-getmntent-issue.patch b/testing/bindfs/musl-getmntent-issue.patch
new file mode 100644
index 0000000000..9003c6f9b2
--- /dev/null
+++ b/testing/bindfs/musl-getmntent-issue.patch
@@ -0,0 +1,18 @@
+# workaroung for musl getmntent: avoid using fusermount in test setup
+--- a/tests/common.rb
++++ b/tests/common.rb
+@@ -213,11 +213,5 @@ def nonroot_testenv(bindfs_args, options = {}, &block)
+ end
+
+ def umount_cmd
+-    if !`which fusermount3`.strip.empty?
+-        'fusermount3 -uz'
+-    elsif !`which fusermount`.strip.empty?
+-        'fusermount -uz'
+-    else
+-        'umount'
+-    end
++    'umount'
+ end
+
+ def assert
-- 
2.32.0

---

From: Daniel Gerber <[email-masked]>
Date: Wed, 29 Dec 2021 16:31:23 +0100

https://bindfs.org
FUSE filesystem for mirroring a directory to another directory
---
 testing/bindfs/APKBUILD                   | 41 +++++++++++++++++++++++
 testing/bindfs/musl-getmntent-issue.patch | 18 ++++++++++
 2 files changed, 59 insertions(+)
 create mode 100644 testing/bindfs/APKBUILD
 create mode 100644 testing/bindfs/musl-getmntent-issue.patch

index 0000000000..65b77c3cd5
@@ -0,0 +1,41 @@
+makedepends="linux-headers fuse3-dev" # or fuse-dev