Subject: [PATCH] testing/autotrash: new aport

From: Thiago Perrotta <[email-masked]>
Date: Sat, 25 Dec 2021 18:24:08 -0500

https://bneijt.nl/pr/autotrash/
Tool to automatically purge old trashed files

Signed-off-by: Thiago Perrotta <[email-masked]>
---
 testing/autotrash/APKBUILD | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 testing/autotrash/APKBUILD

diff --git a/testing/autotrash/APKBUILD b/testing/autotrash/APKBUILD
new file mode 100644
index 0000000000..4cf1bb33a8
--- /dev/null
+++ b/testing/autotrash/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Thiago Perrotta <[email-masked]>
+# Maintainer: Thiago Perrotta <[email-masked]>
+pkgname=autotrash
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Tool to automatically purge old trashed files"
+url="https://bneijt.nl/pr/autotrash/"
+arch="noarch"
+license="GPLv3"
+depends="python3 py3-setuptools"
+options="!check"  # no tests
+source="https://files.pythonhosted.org/packages/source/a/autotrash/autotrash-$pkgver.tar.gz"
+
+build() {
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+sha512sums="
+b39be5a5cf137dde74d104565a536ceb8208d0c900f0b900c94ae7320b5e65b788e90ffbaaa14f90810931997def2aabfe858a8a00e3b7d9252d6738c6036dc3  autotrash-0.4.4.tar.gz
+"
-- 
2.34.1

---

From: Thiago Perrotta <[email-masked]>
Date: Sun, 26 Dec 2021 13:48:50 -0500

Signed-off-by: Thiago Perrotta <[email-masked]>
---
Difference to V1: Use correct SPDX license ID, thanks to Kevin Daudt for
the comment.

index 0000000000..d9b1f18220
+license="GPL-3.0-or-later"