Subject: [PATCH] testing/urlwatch: new aport

From: Thiago Perrotta <[email-masked]>
Date: Wed, 29 Dec 2021 13:56:19 -0500

https://thp.io/2008/urlwatch/
Tool for monitoring webpages for updates

Signed-off-by: Thiago Perrotta <[email-masked]>
---
Ensure to merge py3-minidb before urlwatch.

This aport build is currently expected to fail because py3-minidb
doesn't exist at HEAD.

I am sending a new aport for it separately.

 testing/urlwatch/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/urlwatch/APKBUILD

diff --git a/testing/urlwatch/APKBUILD b/testing/urlwatch/APKBUILD
new file mode 100644
index 0000000000..72c99f2dee
--- /dev/null
+++ b/testing/urlwatch/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Thiago Perrotta <[email-masked]>
+# Maintainer: Thiago Perrotta <[email-masked]>
+pkgname=urlwatch
+pkgver=2.24
+pkgrel=0
+pkgdesc="Tool for monitoring webpages for updates"
+url="https://thp.io/2008/urlwatch/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-appdirs py3-cssselect py3-keyring py3-lxml py3-minidb py3-requests py3-yaml"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-docutils py3-pycodestyle"
+subpackages="$pkgname-doc"
+source="https://files.pythonhosted.org/packages/source/u/urlwatch/urlwatch-$pkgver.tar.gz"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	pytest
+}
+
+package() {
+	python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+	install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" COPYING
+}
+
+sha512sums="
+ed84cb69ecd8894851c3be0165edfa1dfee92a0b49ea1383e4cfd7c31eb0604f99b1a90d9508753064b58bdd8fc4c0369d817303858d07562b37c3f2ac4cae52  urlwatch-2.24.tar.gz
+"
-- 
2.34.1

---

From: mailinglist-bot <[email-masked]>
Date: Wed, 29 Dec 2021 19:23:49 -0000

> +depends="python3 py3-appdirs py3-cssselect py3-keyring py3-lxml py3-minidb py3-requests py3-yaml"

Thiago Perrotta <[email-masked]> replied via email:

```

Signed-off-by: Thiago Perrotta <[email-masked]>
---
Address psykose's comment, splitting depends entries on individual
lines.

I am leaving checkdepends() untouched as it only contains three items.

 testing/urlwatch/APKBUILD | 40 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
 create mode 100644 testing/urlwatch/APKBUILD

index 0000000000..c702f82b3c
@@ -0,0 +1,40 @@
+depends="
+  python3
+  py3-appdirs
+  py3-cssselect
+  py3-keyring
+  py3-lxml
+  py3-minidb
+  py3-requests
+  py3-yaml
+  "

```

-- 
via https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/28987#note_202150