Subject: [PATCH v2 1/2] testing/kakoune: remove redundant builddir declaration

From: Cormac Stephenson <[email-masked]>
Date: Thu, 13 Jan 2022 15:10:57 +0000

The Makefile in the top level works fine, and this way patches apply as
expected.
---
 testing/kakoune/APKBUILD | 1 -
 1 file changed, 1 deletion(-)

diff --git a/testing/kakoune/APKBUILD b/testing/kakoune/APKBUILD
index 73aebf23c2..df042681b6 100644
--- a/testing/kakoune/APKBUILD
+++ b/testing/kakoune/APKBUILD
@@ -13,7 +13,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/mawww/kakoune/archive/v$pkgv
 	alpine-linux.kak
 	"
 
-builddir="$srcdir/$pkgname-$pkgver/src"
 build() {
 	make debug=no
 }
-- 
2.34.1

---

From: Cormac Stephenson <[email-masked]>
Date: Thu, 13 Jan 2022 15:10:59 +0000

---
v2 includes pkgrel bump

 testing/kakoune/0001-fix-CXXFLAGS.patch | 25 +++++++++++++++++++++++++
 testing/kakoune/APKBUILD                |  4 +++-
 2 files changed, 28 insertions(+), 1 deletion(-)
 create mode 100644 testing/kakoune/0001-fix-CXXFLAGS.patch

diff --git a/testing/kakoune/0001-fix-CXXFLAGS.patch b/testing/kakoune/0001-fix-CXXFLAGS.patch
new file mode 100644
index 0000000000..54299cb252
--- /dev/null
+++ b/testing/kakoune/0001-fix-CXXFLAGS.patch
@@ -0,0 +1,25 @@
+From 4f4e4cc5a52efa02b763440d5bf6f5923258eafc Mon Sep 17 00:00:00 2001
+From: Cormac Stephenson <[email-masked]>
+Date: Thu, 13 Jan 2022 05:04:52 +0000
+Subject: [PATCH] fix CXXFLAGS
+
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 63bf1833..abea58aa 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -16,7 +16,7 @@ ifeq ($(debug),yes)
+     suffix := .debug
+ else
+     ifeq ($(debug),no)
+-        CXXFLAGS += -O3
++        # CXXFLAGS += -O3
+         suffix := .opt
+     else
+         $(error debug should be either yes or no)
+-- 
+2.34.1
+
diff --git a/testing/kakoune/APKBUILD b/testing/kakoune/APKBUILD
index df042681b6..82bd0aaf46 100644
--- a/testing/kakoune/APKBUILD
+++ b/testing/kakoune/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Jakub Skrzypnik <[email-masked]>
 pkgname=kakoune
 pkgver=2021.11.08
-pkgrel=0
+pkgrel=1
 pkgdesc="Code editor heavily inspired by Vim, but with less keystrokes"
 url="http://kakoune.org"
 arch="all"
@@ -11,6 +11,7 @@ makedepends="asciidoc"
 subpackages="$pkgname-doc"
 source="$pkgname-$pkgver.tar.gz::https://github.com/mawww/kakoune/archive/v$pkgver.tar.gz
 	alpine-linux.kak
+	0001-fix-CXXFLAGS.patch
 	"
 
 build() {
@@ -29,4 +30,5 @@ package() {
 sha512sums="
 7ddb5952f07caa0f2861e71805d6bac574f2b90e8eac2358c251c1a99c3b85a914dd313c28da3d7871fd65f9b0c598ae8dc287e847f3ec17ee38b28d2a9fa0ec  kakoune-2021.11.08.tar.gz
 c5b11dc28adf785b4e83637fe1d5c9db334616d2d3f6c667823745e273f739c57d0d408b9bec8a65210e3c7ccb80a5b488ebbb3c0c5de8bdec13e1b4b4d02b77  alpine-linux.kak
+23d05861de3c23c8193b1b6d7ca0d2b5b33548c0ae9a317186ccca6533b51daffb9064d3ab9e7ac0a0a794e119633089ca34673b6d9dd56041e2f9046b38b87b  0001-fix-CXXFLAGS.patch
 "
-- 
2.34.1