Subject: [PATCH 1/3] testing/wlrobs: enable more arches

From: Drew DeVault <[email-masked]>
Date: Tue, 15 Feb 2022 10:20:10 +0100

---
 testing/wlrobs/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/wlrobs/APKBUILD b/testing/wlrobs/APKBUILD
index 7431e62265..353bcc0c3c 100644
--- a/testing/wlrobs/APKBUILD
+++ b/testing/wlrobs/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.0
 pkgrel=1
 pkgdesc="obs-studio plugin that allows you to screen capture on wlroots"
 url="https://hg.sr.ht/~scoopta/wlrobs"
-arch="x86 x86_64" # obs-stduio not provided on other platforms
+arch="all"
 license="GPL-3.0-only"
 makedepends="meson ninja obs-studio-dev wayland-dev"
 source="https://dev.alpinelinux.org/archive/wlrobs/wlrobs-$pkgver.tar.gz "
-- 
2.35.1

---

From: Drew DeVault <[email-masked]>
Date: Tue, 15 Feb 2022 10:20:11 +0100

This causes the dmabuf backend to be built.
---
 testing/wlrobs/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/wlrobs/APKBUILD b/testing/wlrobs/APKBUILD
index 353bcc0c3c..3edd554cb4 100644
--- a/testing/wlrobs/APKBUILD
+++ b/testing/wlrobs/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="obs-studio plugin that allows you to screen capture on wlroots"
 url="https://hg.sr.ht/~scoopta/wlrobs"
 arch="all"
 license="GPL-3.0-only"
-makedepends="meson ninja obs-studio-dev wayland-dev"
+makedepends="meson ninja obs-studio-dev wayland-dev libdrm-dev mesa-dev"
 source="https://dev.alpinelinux.org/archive/wlrobs/wlrobs-$pkgver.tar.gz "
 builddir="$srcdir/$pkgname-v$pkgver"
 options="!check" # No tests provided
-- 
2.35.1

---

From: Drew DeVault <[email-masked]>
Date: Tue, 15 Feb 2022 10:20:12 +0100

---

diff --git a/testing/wlrobs/APKBUILD b/testing/wlrobs/APKBUILD
index 3edd554cb4..3db1e242ff 100644
--- a/testing/wlrobs/APKBUILD
+++ b/testing/wlrobs/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Marian Buschsieweke <[email-masked]>
 pkgname=wlrobs
 pkgver=1.0
-pkgrel=1
+pkgrel=2
 pkgdesc="obs-studio plugin that allows you to screen capture on wlroots"
 url="https://hg.sr.ht/~scoopta/wlrobs"
 arch="all"
-- 
2.35.1