Subject: [PATCH v2 1/2] community/harec: upgrade to 72fea91ecc5b4735548f3e3965a8f734c841839b

From: Drew DeVault <[email-masked]>
Date: Thu, 9 Jun 2022 10:20:52 +0200

---
 community/harec/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/community/harec/APKBUILD b/community/harec/APKBUILD
index 8805412319..5ee4e148fa 100644
--- a/community/harec/APKBUILD
+++ b/community/harec/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Drew DeVault <[email-masked]>
 pkgname=harec
-pkgver="0_git20220528"
-_commit=78989a15dfcc301ac2eca07afb1f906e172bd48b
+pkgver="0_git20220609"
+_commit=72fea91ecc5b4735548f3e3965a8f734c841839b
 pkgrel=0
 pkgdesc="The Hare compiler"
 url="https://harelang.org"
@@ -27,5 +27,5 @@ package() {
 }
 
 sha512sums="
-b5e8dd564f037cdf528ebf8b573b825a9d4980e282969fefee465aa9efcff3b9f853293079250444376ad3eabd4048d667c1a54d02182cb33f3a815826761b2c  harec-78989a15dfcc301ac2eca07afb1f906e172bd48b.tar.gz
+7e5be1b6cbf2950577358c770b249391bcaefdc944e085774443362d9746e4b930dcfb2d2ad4bd60fe45321a7ef6b0800645c4f44e9dd269932d0096131bc436  harec-72fea91ecc5b4735548f3e3965a8f734c841839b.tar.gz
 "

base-commit: 36a8d00236ca194d8cb2b98d502dc3d4b07768ec
prerequisite-patch-id: 74dcc23db58b748fe6ce19eb7bad74ce24a1efc3
prerequisite-patch-id: a05594172495edb257634a8e1f9b1a67a55e6c8e
prerequisite-patch-id: f773d4818b28e3063a9862db4cfa3f0264b0b3b1
prerequisite-patch-id: aab92d49d78d7912b472b34fe4814c2b89c29cd4
-- 
2.36.1

---

From: Drew DeVault <[email-masked]>
Date: Thu, 9 Jun 2022 10:20:53 +0200

---
 community/hare/APKBUILD          | 15 +++++++++------
 community/hare/config.aarch64.mk | 17 +++++++++++++++++
 community/hare/config.riscv64.mk | 17 +++++++++++++++++
 community/hare/config.x86_64.mk  | 17 +++++++++++++++++
 4 files changed, 60 insertions(+), 6 deletions(-)

diff --git a/community/hare/APKBUILD b/community/hare/APKBUILD
index 4c86d29bde..a8bf204f77 100644
--- a/community/hare/APKBUILD
+++ b/community/hare/APKBUILD
@@ -1,7 +1,10 @@
 # Maintainer: Drew DeVault <[email-masked]>
+# TODO: This package could be improved if Alpine had better support for
+# cross-compiling with a better standardized and broader set of binutils
+# and gcc packages.
 pkgname=hare
-pkgver="0_git20220528"
-_commit=19e380ccb7dfe2bcab5f94e6bd03004e3e2c6005
+pkgver="0_git20220609"
+_commit=259c1176016fafb3384a785156763c38c99ceb0a
 pkgrel=0
 pkgdesc="The Hare systems programming language"
 url="https://harelang.org"
@@ -36,8 +39,8 @@ package() {
 }
 
 sha512sums="
-507320952af3cad184366fa12f3bb255a8e29e30611a309161120b2cc04a89639760882775f3a9bc44d1cacdcee45773a5b78bfb01a85c2e9c6c3aa706e4e791  hare-19e380ccb7dfe2bcab5f94e6bd03004e3e2c6005.tar.gz
-c30c2979a94d73f5bbb39c3fa250d155548fb07ba93cb4a2111eede51be5fd9017e2b4291f4f16657718e6bc414b90b583a14df572fab4579d26c5680a279dcb  config.aarch64.mk
-6980757c09987363817de0599b59334817831f1c5782ae48a94b88c5b10aa1ab32fdc6c76911d02d1c100d78db98f1ca2167ecdf9580fc4d9bc560577f6fe89e  config.riscv64.mk
-159c2f56f9617a97ecbe2b1ab94c98beb798fa575463bdcfba281a023202df481714c16536e213e859468b50cdd9f339224d8a3b3d57e139a58412b3efba6d84  config.x86_64.mk
+7b803ecc91fc1653ea1de51efa27e90a9931a39b52d8a56e04b5f9460d0cf94b71b19c3134d251e9cf054ce3049ba1fb13547bf31f1c5e76b0667f865890fdb9  hare-259c1176016fafb3384a785156763c38c99ceb0a.tar.gz
+129189cbc86e1ee0ae5c81a12b2797f36b1a9ed742a81496fff14f8527ef6fe4881a261c2156a5bafcaeaf4a692e3cf8b27c473339676e65479e6f3546a3ee99  config.aarch64.mk
+96280a82594b19ec8972946c89fa0f0b9d0e89cc517e6476ace4be8adc66be1d631d75172d36261e9c9414b0e3453be59dd7b4b0abf3735d182c28005dc5eee3  config.riscv64.mk
+ad724530acea8377fd9372af416d467470497a4aa80a0405d1d4a9b6ddce609485549ffd31426884fa277b8dcab279288498413fddc41dc23ea24ad30bab224e  config.x86_64.mk
 "
diff --git a/community/hare/config.aarch64.mk b/community/hare/config.aarch64.mk
index 649d0b979e..d200ba4bdd 100644
--- a/community/hare/config.aarch64.mk
+++ b/community/hare/config.aarch64.mk
@@ -29,3 +29,20 @@ SCDOC=scdoc
 
 # Where to store build artifacts
 HARECACHE=.cache
+BINOUT = .bin
+
+# Cross-compiling settings
+AARCH64_AS=as
+AARCH64_AR=ar
+AARCH64_CC=cc
+AARCH64_LD=ld
+
+RISCV64_AS=riscv64-alpine-linux-musl-as
+RISCV64_AR=riscv64-alpine-linux-musl-ar
+RISCV64_CC=riscv64-alpine-linux-musl-cc
+RISCV64_LD=riscv64-alpine-linux-musl-ld
+
+X86_64_AS=x86_64-alpine-linux-musl-as
+X86_64_AR=x86_64-alpine-linux-musl-ar
+X86_64_CC=x86_64-alpine-linux-musl-cc
+X86_64_LD=x86_64-alpine-linux-musl-ld
diff --git a/community/hare/config.riscv64.mk b/community/hare/config.riscv64.mk
index 989f24b109..47ab809ba8 100644
--- a/community/hare/config.riscv64.mk
+++ b/community/hare/config.riscv64.mk
@@ -29,3 +29,20 @@ SCDOC=scdoc
 
 # Where to store build artifacts
 HARECACHE=.cache
+BINOUT = .bin
+
+# Cross-compiling settings
+AARCH64_AS=aarch64-alpine-linux-musl-as
+AARCH64_AR=aarch64-alpine-linux-musl-ar
+AARCH64_CC=aarch64-alpine-linux-musl-cc
+AARCH64_LD=aarch64-alpine-linux-musl-ld
+
+RISCV64_AS=as
+RISCV64_AR=ar
+RISCV64_CC=cc
+RISCV64_LD=ld
+
+X86_64_AS=x86_64-alpine-linux-musl-as
+X86_64_AR=x86_64-alpine-linux-musl-ar
+X86_64_CC=x86_64-alpine-linux-musl-cc
+X86_64_LD=x86_64-alpine-linux-musl-ld
diff --git a/community/hare/config.x86_64.mk b/community/hare/config.x86_64.mk
index 789fd0d92e..6fe42d4752 100644
--- a/community/hare/config.x86_64.mk
+++ b/community/hare/config.x86_64.mk
@@ -29,3 +29,20 @@ SCDOC=scdoc
 
 # Where to store build artifacts
 HARECACHE=.cache
+BINOUT = .bin
+
+# Cross-compiling settings
+AARCH64_AS=aarch64-alpine-linux-musl-as
+AARCH64_AR=aarch64-alpine-linux-musl-ar
+AARCH64_CC=aarch64-alpine-linux-musl-cc
+AARCH64_LD=aarch64-alpine-linux-musl-ld
+
+RISCV64_AS=riscv64-alpine-linux-musl-as
+RISCV64_AR=riscv64-alpine-linux-musl-ar
+RISCV64_CC=riscv64-alpine-linux-musl-cc
+RISCV64_LD=riscv64-alpine-linux-musl-ld
+
+X86_64_AS=as
+X86_64_AR=ar
+X86_64_CC=cc
+X86_64_LD=ld
-- 
2.36.1