Subject: [PATCH 1/3] testing/py3-blurhash: new aport

From: "Haelwenn (lanodan) Monnier" <[email-masked]>
Date: Fri, 24 Jun 2022 06:36:27 +0200

---
 testing/py3-blurhash/APKBUILD | 37 +++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 testing/py3-blurhash/APKBUILD

diff --git a/testing/py3-blurhash/APKBUILD b/testing/py3-blurhash/APKBUILD
new file mode 100644
index 0000000000..4942dbc37f
--- /dev/null
+++ b/testing/py3-blurhash/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Haelwenn (lanodan) Monnier <[email-masked]>
+# Maintainer: Haelwenn (lanodan) Monnier <[email-masked]>
+pkgname=py3-blurhash
+#_pkgreal is used by apkbuild-pypi to find modules at PyPI
+_pkgreal=blurhash
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Pure-Python implementation of the blurhash algorithm."
+url="http://packages.python.org/pypi/blurhash"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	# No tests in the pypi tarball, no git tags
+	# https://github.com/halcy/blurhash-python/issues/4
+	# python3 setup.py test
+	:
+}
+
+package() {
+	python3 setup.py install \
+		--prefix=/usr \
+		--root="$pkgdir" \
+		--single-version-externally-managed
+}
+
+sha512sums="
+eacef78927a1299bec19f73709435b1be55797273888e7856bbfd46d2aa1afa02f54505c15b76dcd6bd15a6817da0171aa412570c33c7ad487bfe10940ef3fd6  blurhash-1.1.4.tar.gz
+"
-- 
2.35.1

---

From: "Haelwenn (lanodan) Monnier" <[email-masked]>
Date: Fri, 24 Jun 2022 06:36:28 +0200

---
 testing/py3-http-ece/APKBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/py3-http-ece/APKBUILD

diff --git a/testing/py3-http-ece/APKBUILD b/testing/py3-http-ece/APKBUILD
new file mode 100644
index 0000000000..33a51d8b3f
--- /dev/null
+++ b/testing/py3-http-ece/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Haelwenn (lanodan) Monnier <[email-masked]>
+# Maintainer: Haelwenn (lanodan) Monnier <[email-masked]>
+pkgname=py3-http-ece
+#_pkgreal is used by apkbuild-pypi to find modules at PyPI
+_pkgreal=http_ece
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Encrypted Content Encoding for HTTP"
+url="http://packages.python.org/pypi/http-ece"
+arch="noarch"
+license="MIT"
+depends="python3 py3-cryptography"
+checkdepends="python3-dev py3-nose py3-coverage py3-mock py3-flake8"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install \
+		--prefix=/usr \
+		--root="$pkgdir" \
+		--single-version-externally-managed
+}
+
+sha512sums="
+ff99cc3aedea325b7aae9c4a800bb58d8f56f86a6d72450d9212113c9d0fdff30c227b7816ec2a38cc9615344c4181ec8f420b4bb521e574b63ce0257a523edf  http_ece-1.1.0.tar.gz
+"
-- 
2.35.1

---

From: "Haelwenn (lanodan) Monnier" <[email-masked]>
Date: Fri, 24 Jun 2022 06:36:29 +0200

---
 testing/py3-mastodon.py/APKBUILD | 34 ++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 testing/py3-mastodon.py/APKBUILD

diff --git a/testing/py3-mastodon.py/APKBUILD b/testing/py3-mastodon.py/APKBUILD
new file mode 100644
index 0000000000..1a1351bac0
--- /dev/null
+++ b/testing/py3-mastodon.py/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Haelwenn (lanodan) Monnier <[email-masked]>
+# Maintainer: Haelwenn (lanodan) Monnier <[email-masked]>
+pkgname=py3-mastodon.py
+_pkgreal=Mastodon.py
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Python wrapper for the Mastodon API"
+url="http://packages.python.org/pypi/Mastodon.py"
+arch="noarch"
+license="MIT"
+depends="python3 py3-requests py3-dateutil py3-six py3-tz py3-magic py3-decorator py3-http-ece py3-cryptography py3-blurhash"
+checkdepends="python3-dev py3-pytest py3-pytest-runner py3-pytest-cov py3-vcrpy py3-pytest-vcr py3-pytest-mock py3-requests-mock"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install \
+		--prefix=/usr \
+		--root="$pkgdir" \
+		--single-version-externally-managed
+}
+
+sha512sums="
+0c1a27b6cfcb4a197614100ffdb40ff8224162c0029598eadebdfa8984fe30519d3b163265d6f198e4a563c0e6a8bf68cafb69938f1a4768724a02f4f6971fa3  Mastodon.py-1.5.1.tar.gz
+"
-- 
2.35.1