Subject: [PATCH 1/2] community/libcamera: remove boost from dependencies

From: Jacopo Mondi <[email-masked]>
Date: Sat, 14 Jan 2023 17:38:43 +0100

Boost is not required anymore to build libcamera since the dependency
has been dropped in commit c1597f989654 ("ipa: raspberrypi: Use
YamlParser to replace dependency on boost").

Signed-off-by: Jacopo Mondi <[email-masked]>
---
 community/libcamera/APKBUILD | 1 -
 1 file changed, 1 deletion(-)

diff --git a/community/libcamera/APKBUILD b/community/libcamera/APKBUILD
index 1399bcda0f74..1bf0015ec127 100644
--- a/community/libcamera/APKBUILD
+++ b/community/libcamera/APKBUILD
@@ -8,7 +8,6 @@ url="https://libcamera.org/"
 arch="all"
 license="LGPL-2.1-or-later AND GPL-2.0-or-later"
 depends_dev="
-	boost-dev
 	eudev-dev
 	glib-dev
 	gnutls-dev
-- 
2.39.0

---

From: Jacopo Mondi <[email-masked]>
Date: Sat, 14 Jan 2023 17:38:44 +0100

The cam test tol can preview frames using SDL2 if available during
compilation.

Add sdl2 and sdl2_image to the dependencies list.

Signed-off-by: Jacopo Mondi <[email-masked]>
---
This is only required for the cam test tool and should probably be made a
libcamera-tools sub-package dependency. Not sure if this can be expressed in
APKBUILD.

 community/libcamera/APKBUILD | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/community/libcamera/APKBUILD b/community/libcamera/APKBUILD
index 1bf0015ec127..252c879e784d 100644
--- a/community/libcamera/APKBUILD
+++ b/community/libcamera/APKBUILD
@@ -13,6 +13,8 @@ depends_dev="
 	gnutls-dev
 	gst-plugins-bad-dev
 	qt5-qtbase-dev
+	sdl2-dev
+	sdl2_image-dev
 	"
 # upstream calls 'date' with a non-POSIX option so we pull in coreutils
 makedepends="$depends_dev
--
2.39.0